aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-08-19 23:35:35 +0800
committerswills <swills@FreeBSD.org>2014-08-19 23:35:35 +0800
commit5b0e640fb6d97c5ebfacfd5cea5b87dd2e7c1346 (patch)
tree09c2d656aaba0bcc376e74ce56d845f491a8ffa7 /math
parent2e2898df5b5a7cac63a843e9a47b43836efbf0db (diff)
downloadfreebsd-ports-gnome-5b0e640fb6d97c5ebfacfd5cea5b87dd2e7c1346.tar.gz
freebsd-ports-gnome-5b0e640fb6d97c5ebfacfd5cea5b87dd2e7c1346.tar.zst
freebsd-ports-gnome-5b0e640fb6d97c5ebfacfd5cea5b87dd2e7c1346.zip
many ruby/rubygem ports: death of rubyforge.org
rubyforge.org shutdown on May 15, 2014. This commit accounts for that by doing several things: - Deprecate ruby that had only rubyforge.org as MASTER_SITES (and so are now only fetchable via our cache) - Deprecate ports that depend on those - Update the WWW pkg-descr line that points to rubyforge.org for rubygem ports (which are still fetchable from rubygems.org) The next step will be to remove rubyforge.org from bsd.sites.mk, after these deprecated ports are deleted. Phabric: D591 With hat: ruby Approved by: portmgr (because of committing to unstaged graphics/mingplot port)
Diffstat (limited to 'math')
-rw-r--r--math/ruby-fftw3/Makefile3
-rw-r--r--math/ruby-gnuplot/Makefile3
-rw-r--r--math/ruby-gsl/Makefile3
-rw-r--r--math/ruby-narray/Makefile3
-rw-r--r--math/ruby-numru_misc/Makefile3
-rw-r--r--math/rubygem-narray/pkg-descr2
6 files changed, 16 insertions, 1 deletions
diff --git a/math/ruby-fftw3/Makefile b/math/ruby-fftw3/Makefile
index 11d12052b96e..555a4d942a6b 100644
--- a/math/ruby-fftw3/Makefile
+++ b/math/ruby-fftw3/Makefile
@@ -31,6 +31,9 @@ DOCS= LICENSE.txt doc/*
OPTIONS_DEFINE= DOCS
+DEPRECATED= Depends on deprecated math/ruby-narray
+EXPIRATION_DATE= 2014-09-20
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}
.for f in ${DOCS}
diff --git a/math/ruby-gnuplot/Makefile b/math/ruby-gnuplot/Makefile
index 5178e4b9cc74..a47b546721ea 100644
--- a/math/ruby-gnuplot/Makefile
+++ b/math/ruby-gnuplot/Makefile
@@ -31,6 +31,9 @@ EXAMPLESDIR= ${RUBY_MODEXAMPLESDIR}
PORTDOCS= *
PORTEXAMPLES= *
+DEPRECATED= Depends on deprecated math/ruby-narray
+EXPIRATION_DATE= 2014-09-20
+
MAKE_ARGS= INSTALL_PROG="${INSTALL_PROGRAM}" \
INSTALL_DATA="${INSTALL_DATA}"
diff --git a/math/ruby-gsl/Makefile b/math/ruby-gsl/Makefile
index e198f599d316..1e585ea393e2 100644
--- a/math/ruby-gsl/Makefile
+++ b/math/ruby-gsl/Makefile
@@ -24,6 +24,9 @@ CONFIGURE_ARGS= -- --with-opt-dir="${LOCALBASE}"
DOCS= AUTHORS ChangeLog THANKS rdoc
+DEPRECATED= RubyForge shutdown May 15 2014
+EXPIRATION_DATE= 2014-09-20
+
OPTIONS_DEFINE= DOCS
post-extract:
diff --git a/math/ruby-narray/Makefile b/math/ruby-narray/Makefile
index dc923937debe..5e4737571516 100644
--- a/math/ruby-narray/Makefile
+++ b/math/ruby-narray/Makefile
@@ -26,6 +26,9 @@ DOC_JA= README.ja SPEC.ja
OPTIONS_DEFINE= DOCS
+DEPRECATED= RubyForge shutdown May 15 2014
+EXPIRATION_DATE= 2014-09-20
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}/ja
.for f in ${DOC_EN}
diff --git a/math/ruby-numru_misc/Makefile b/math/ruby-numru_misc/Makefile
index ceeee38c97dc..fdbd32da992f 100644
--- a/math/ruby-numru_misc/Makefile
+++ b/math/ruby-numru_misc/Makefile
@@ -28,6 +28,9 @@ NO_BUILD= yes
DOCS= ChangeLog LICENSE.txt doc/*
+DEPRECATED= Depends on deprecated math/ruby-narray
+EXPIRATION_DATE= 2014-09-20
+
do-install:
@cd ${WRKSRC}/ && ${RUBY} ./install.rb -d ${STAGEDIR}${RUBY_SITELIBDIR}
@${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}/
diff --git a/math/rubygem-narray/pkg-descr b/math/rubygem-narray/pkg-descr
index 43a6192266dc..eb61e88a9d2e 100644
--- a/math/rubygem-narray/pkg-descr
+++ b/math/rubygem-narray/pkg-descr
@@ -4,4 +4,4 @@ extension library incorporates fast calculation and easy manipulation of large
numerical arrays into the Ruby language. NArray has features similar to NumPy,
but NArray has vector and matrix subclasses.
-WWW: http://narray.rubyforge.org/
+WWW: http://rubygems.org/gems/narray/