aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-05-02 13:28:03 +0800
committerpi <pi@FreeBSD.org>2016-05-02 13:28:03 +0800
commit60f688f0c895f5bac51d7023e33443f451d853c2 (patch)
tree43780101c432c7afa3cf767aaadd85b9e9f0f5ba /math
parent2a82f793df6211dbe2e92a138d07ffc931bc5f8a (diff)
downloadfreebsd-ports-gnome-60f688f0c895f5bac51d7023e33443f451d853c2.tar.gz
freebsd-ports-gnome-60f688f0c895f5bac51d7023e33443f451d853c2.tar.zst
freebsd-ports-gnome-60f688f0c895f5bac51d7023e33443f451d853c2.zip
math/openblas: fix poudriere builds: setting DYNAMIC_ARCH when BULK is defined
PR: 209190 Submitted by: Joseph Mingrone <jrm@ftfl.ca> Approved by: <phd_kimberlite@yahoo.co.jp> (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/openblas/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/math/openblas/Makefile b/math/openblas/Makefile
index 53510d55f110..15f38cb7d9e1 100644
--- a/math/openblas/Makefile
+++ b/math/openblas/Makefile
@@ -40,7 +40,7 @@ OPENMP_DESC= Use OpenMP for threading
AVX_DESC= Support Advanced Vector Extensions (AVX)
AVX2_DESC= Support Advanced Vector Extensions 2 (AVX2)
-.if defined(PACKAGE_BUILDING)
+.if defined(BATCH) || defined(PACKAGE_BUILDING)
OPTIONS_DEFAULT= DYNAMIC_ARCH
.endif
@@ -76,11 +76,6 @@ USES+= compiler:openmp
BUILDFLAGS_THREAD+= USE_OPENMP=1
.endif
-.if ${PORT_OPTIONS:MQUAD_PRECISION}
-BROKEN= QUAD_PRECISION is broken; please disable this option
-BUILDFLAGS+= QUAD_PRECISION=1
-.endif
-
.if ! ${PORT_OPTIONS:MAVX}
BUILDFLAGS+= NO_AVX=1
.endif
@@ -123,7 +118,7 @@ post-patch:
-e 's+%%FIND%%+${FIND}+' \
-e 's+%%XARGS%%+${XARGS}+' \
-e 's+%%REINPLACE_CMD%%+${REINPLACE_CMD}+' \
- -e 's+$$(CROSS_SUFFIX)+${LOCALBASE}/bin/+' \
+ -e 's+$${CROSS_SUFFIX}+${LOCALBASE}/bin/+' \
${WRKSRC}/Makefile.system
.if ${PORT_OPTIONS:MOPENMP}
${REINPLACE_CMD} -e "s+OPENBLAS_NUM_THREADS+OMP_NUM_THREADS+g" \