aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-07-14 10:21:32 +0800
committermaho <maho@FreeBSD.org>2007-07-14 10:21:32 +0800
commit6b806080bb92288778d729e5d93201f18783aee4 (patch)
treea2342a65009197ec536c5bf18e2b47b1fd12292d /math
parent5ccb9aeb461d6fd6be57f09e8307f61255b25574 (diff)
downloadfreebsd-ports-gnome-6b806080bb92288778d729e5d93201f18783aee4.tar.gz
freebsd-ports-gnome-6b806080bb92288778d729e5d93201f18783aee4.tar.zst
freebsd-ports-gnome-6b806080bb92288778d729e5d93201f18783aee4.zip
Now we use USE_FORTRAN=yes to use FORTRAN compiler.
Diffstat (limited to 'math')
-rw-r--r--math/metis-edf/Makefile5
-rw-r--r--math/mumps/Makefile7
2 files changed, 3 insertions, 9 deletions
diff --git a/math/metis-edf/Makefile b/math/metis-edf/Makefile
index 4399049bd4fe..2969cd196fa7 100644
--- a/math/metis-edf/Makefile
+++ b/math/metis-edf/Makefile
@@ -21,10 +21,7 @@ ALL_TARGET= default
MAKE_ENV+= CC="${CC}" AR="${AR}" F77="${F77}" FFLAGS="${FFLAGS}"
REINPLACE_ARGS= -i ""
-WANT_FORTRAN=yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
FFLAGS+= -O2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
diff --git a/math/mumps/Makefile b/math/mumps/Makefile
index 082887aa7f02..b4e2db8c5af6 100644
--- a/math/mumps/Makefile
+++ b/math/mumps/Makefile
@@ -30,13 +30,10 @@ COMMENT= MUltifrontal Massively Parallel sparse direct Solver
# WITH_MPI: Use mpich for the parallel version
#-----------------------------------------------------------------------
-WANT_FORTRAN=yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-
SLAVEDIRS= math/mumps-mpich
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
+
FORTRANLIBS= -lgfortranbegin -lgfortran
GCCLIBDIR= -L`${CAT} ${WRKSRC}/LIBDIR` -L`${CAT} ${WRKSRC}/LIBDIR`/../../..