aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-03-04 16:43:28 +0800
committerbf <bf@FreeBSD.org>2011-03-04 16:43:28 +0800
commit9010bcba225e57ce6fcb72a4d57424abaff66818 (patch)
tree9d376f3e180a2990329e6c98ba32b993497e3ff5 /math
parentec7314ad4e81b02e6748954f092b16581b1a1a2a (diff)
downloadfreebsd-ports-gnome-9010bcba225e57ce6fcb72a4d57424abaff66818.tar.gz
freebsd-ports-gnome-9010bcba225e57ce6fcb72a4d57424abaff66818.tar.zst
freebsd-ports-gnome-9010bcba225e57ce6fcb72a4d57424abaff66818.zip
- Update to 1.9.4
- Fix the build by using the bundled libtool rather than devel/libtool Approved by: makc, miwi (mentors, implicit)
Diffstat (limited to 'math')
-rw-r--r--math/gretl/Makefile13
-rw-r--r--math/gretl/distinfo4
-rw-r--r--math/gretl/files/patch-cli::Makefile.in10
-rw-r--r--math/gretl/files/patch-gui2::Makefile.in9
-rw-r--r--math/gretl/files/patch-lib::Makefile.in16
-rw-r--r--math/gretl/files/patch-plugin::Makefile.in17
-rw-r--r--math/gretl/files/patch-share::Makefile.in13
-rw-r--r--math/gretl/pkg-plist1
8 files changed, 28 insertions, 55 deletions
diff --git a/math/gretl/Makefile b/math/gretl/Makefile
index 9ae68f97e0ba..52cfc501ca8a 100644
--- a/math/gretl/Makefile
+++ b/math/gretl/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= gretl
-PORTVERSION= 1.9.3
+PORTVERSION= 1.9.4
CATEGORIES= math finance
MASTER_SITES= SF
@@ -16,7 +16,7 @@ COMMENT= GNU Regression, Econometrics and Time-series Library
LIB_DEPENDS= fftw3.5:${PORTSDIR}/math/fftw3
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_FORTRAN= yes
USE_GMAKE= yes
@@ -36,7 +36,8 @@ OPTIONS= ATLAS "Use Atlas for BLAS and LAPACK" off \
GUI "Build the graphical user interface and plugins" on \
NLS "Build with Natural Language Support" on \
ODBC "Build with unixODBC database support" off \
- R "Build with libR support" off
+ R "Build with libR support" off \
+ SSE2 "Enable build-time auto-detection of SSE2 on i386 for RNG" off
.include <bsd.port.pre.mk>
@@ -87,6 +88,12 @@ LIB_DEPENDS+= R.0:${PORTSDIR}/math/R
CONFIGURE_ARGS+= --without-libR
.endif
+.if ${ARCH} == "amd64" || (${ARCH} == "i386" && defined(WITH_SSE2))
+CONFIGURE_ARGS+= --enable-sse2=yes
+.else
+CONFIGURE_ARGS+= --enable-sse2=no
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|set term png|set term dumb|g' \
${WRKSRC}/configure
diff --git a/math/gretl/distinfo b/math/gretl/distinfo
index 831b9b414f37..e0dc9bf46ff0 100644
--- a/math/gretl/distinfo
+++ b/math/gretl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gretl-1.9.3.tar.bz2) = 0f54d2d59286656524692fb88a123571dfb1fb5696805346d5cb291f041a9913
-SIZE (gretl-1.9.3.tar.bz2) = 7845369
+SHA256 (gretl-1.9.4.tar.bz2) = 2fc34ee06e2baf7f122d9102b64a4c74360a362fac356d5d65d0486202afd3f7
+SIZE (gretl-1.9.4.tar.bz2) = 8140957
diff --git a/math/gretl/files/patch-cli::Makefile.in b/math/gretl/files/patch-cli::Makefile.in
index 61fd4d5948de..0278c76e4bf0 100644
--- a/math/gretl/files/patch-cli::Makefile.in
+++ b/math/gretl/files/patch-cli::Makefile.in
@@ -1,5 +1,5 @@
--- cli/Makefile.in.orig 2010-08-28 11:10:07.000000000 -0400
-+++ cli/Makefile.in 2011-02-02 15:28:13.000000000 -0500
++++ cli/Makefile.in 2011-03-02 07:41:07.000000000 -0500
@@ -21,6 +21,10 @@
quiet_build = @quiet_build@
@@ -11,7 +11,7 @@
ifeq ($(CC),)
CC = gcc
endif
-@@ -55,10 +59,10 @@
+@@ -55,7 +59,7 @@
DEFS = -DLOCALEDIR=\"$(localedir)\" -DHAVE_CONFIG_H
@@ -19,11 +19,7 @@
+override CFLAGS += -I.. -I$(topsrc) -I$(libsrc) $(READLINE_CFLAGS) $(DEFS) $(CPPFLAGS)
CLI = gretlcli$(EXEEXT)
--LIBTOOL = ../libtool
-+LIBTOOL = @LIBTOOL@
-
- %.o: %.c
- $(CCECHO)
+ LIBTOOL = ../libtool
@@ -68,7 +72,7 @@
$(CLI): .deps $(OBJS)
$(LDECHO)
diff --git a/math/gretl/files/patch-gui2::Makefile.in b/math/gretl/files/patch-gui2::Makefile.in
index 91648096de77..8d3f6f90d830 100644
--- a/math/gretl/files/patch-gui2::Makefile.in
+++ b/math/gretl/files/patch-gui2::Makefile.in
@@ -1,14 +1,5 @@
--- gui2/Makefile.in.orig 2010-08-28 11:10:12.000000000 -0400
+++ gui2/Makefile.in 2011-02-02 15:50:09.000000000 -0500
-@@ -120,7 +120,7 @@
- #### End of system configuration section. ####
-
- SHELL = /bin/sh
--LIBTOOL = ../libtool
-+LIBTOOL = @LIBTOOL@
- PROG = gretl_x11$(EXEEXT)
-
- vpath %.c $(topsrc)/gui2
@@ -221,7 +221,7 @@
$(LIBTOOL) --mode=install $(INSTALL_PROGRAM) -s $(PROG) $(DESTDIR)$(bindir)/$(PROG)
diff --git a/math/gretl/files/patch-lib::Makefile.in b/math/gretl/files/patch-lib::Makefile.in
index a58f01ed37ba..6f68eb5dff5b 100644
--- a/math/gretl/files/patch-lib::Makefile.in
+++ b/math/gretl/files/patch-lib::Makefile.in
@@ -1,5 +1,5 @@
---- lib/Makefile.in.orig 2010-11-17 08:55:23.000000000 -0500
-+++ lib/Makefile.in 2011-02-02 15:59:26.000000000 -0500
+--- lib/Makefile.in.orig 2011-02-16 09:15:14.000000000 -0500
++++ lib/Makefile.in 2011-03-02 09:03:21.000000000 -0500
@@ -38,6 +38,10 @@
RPATH = $(DARWIN_RPATH)
endif
@@ -29,16 +29,12 @@
#### End of system configuration section. ####
-@@ -238,10 +242,10 @@
- LOBJS = $(SRCS:.c=.lo)
- AUX_LOBJ = $(CEPHES_SRC:.c=.lo) $(MINPACK_SRC:.c=.lo)
-
--LIBTOOL = ../libtool
-+LIBTOOL = @LIBTOOL@
+@@ -241,7 +245,7 @@
+ LIBTOOL = ../libtool
override CFLAGS += -I.. -I$(topsrc) -I$(libsrc) $(XML_CFLAGS) $(GLIB_CFLAGS) \
-- $(GMP_CFLAGS) $(FFTW_CFLAGS) $(RLIB_CFLAGS) -DHAVE_CONFIG_H
-+ $(GMP_CFLAGS) $(FFTW_CFLAGS) $(RLIB_CFLAGS) $(CPPFLAGS) -DHAVE_CONFIG_H
+- $(GMP_CFLAGS) $(FFTW_CFLAGS) $(RLIB_CFLAGS) -DHAVE_CONFIG_H $(LIBDEF)
++ $(GMP_CFLAGS) $(FFTW_CFLAGS) $(RLIB_CFLAGS) $(CPPFLAGS) -DHAVE_CONFIG_H $(LIBDEF)
COMPILE = $(LIBTOOL) --mode=compile $(CCV) -c $(CFLAGS)
diff --git a/math/gretl/files/patch-plugin::Makefile.in b/math/gretl/files/patch-plugin::Makefile.in
index cbd2f35e69f1..2f683ea1ab17 100644
--- a/math/gretl/files/patch-plugin::Makefile.in
+++ b/math/gretl/files/patch-plugin::Makefile.in
@@ -1,5 +1,5 @@
---- plugin/Makefile.in.orig 2010-11-18 09:41:28.000000000 -0500
-+++ plugin/Makefile.in 2011-02-02 16:11:27.000000000 -0500
+--- plugin/Makefile.in.orig 2011-02-14 08:52:57.000000000 -0500
++++ plugin/Makefile.in 2011-03-02 09:02:20.000000000 -0500
@@ -12,6 +12,10 @@
INSTALL = @INSTALL@
LN = @LN_S@
@@ -11,16 +11,7 @@
build_gui = @build_gui@
build_mailer = @build_mailer@
have_odbc = @have_odbc@
-@@ -46,7 +50,7 @@
-
- override CFLAGS += -I.. -I$(topsrc)/gui2 -DHAVE_CONFIG_H
-
--LIBTOOL = ../libtool
-+LIBTOOL = @LIBTOOL@
- COMPILE = $(LIBTOOL) --mode=compile $(CCV) -c $(CFLAGS)
-
- ifeq ($(quiet_build),yes)
-@@ -197,7 +201,7 @@
+@@ -198,7 +202,7 @@
override CFLAGS += $(GRETLINC) $(GTK_CFLAGS) $(GMP_CFLAGS) $(MPFR_CFLAGS) \
$(XML_CFLAGS) $(GRETL_LIBOLE2_CFLAGS) $(ZIP_CFLAGS) $(AUDIO_CFLAGS) \
@@ -29,7 +20,7 @@
%.lo: %.c
$(CCECHO)
-@@ -339,13 +343,13 @@
+@@ -340,13 +344,13 @@
.PHONY:
install: $(GRETLLIB) $(PLUGINS) $(URCDATA) $(DWDATA) installdirs
diff --git a/math/gretl/files/patch-share::Makefile.in b/math/gretl/files/patch-share::Makefile.in
index 5d17f50fee8c..147ec53b6811 100644
--- a/math/gretl/files/patch-share::Makefile.in
+++ b/math/gretl/files/patch-share::Makefile.in
@@ -1,5 +1,5 @@
---- share/Makefile.in.orig 2010-08-23 08:47:12.000000000 -0400
-+++ share/Makefile.in 2011-02-05 04:47:43.000000000 -0500
+--- share/Makefile.in.orig 2011-02-10 16:40:30.000000000 -0500
++++ share/Makefile.in 2011-03-02 07:43:03.000000000 -0500
@@ -13,7 +13,7 @@
sharesrc = $(topsrc)/share
pdfdir = ../doc/tex
@@ -39,12 +39,3 @@
install_fonts:
for f in $(sharesrc)/fonts/*.ttf ; do \
-@@ -112,7 +112,7 @@
- $(tooldir)/mkinstalldirs $(DESTDIR)$(gretldir)/scripts/misc
- $(tooldir)/mkinstalldirs $(DESTDIR)$(gretldir)/db
- $(tooldir)/mkinstalldirs $(DESTDIR)$(gretldir)/functions
-- $(tooldir)/mkinstalldirs $(DESTDIR)$(gretldir)/functions/docs
-+# $(tooldir)/mkinstalldirs $(DESTDIR)$(gretldir)/functions/docs
- $(tooldir)/mkinstalldirs $(DESTDIR)$(gretldir)/fonts
-
- clean:
diff --git a/math/gretl/pkg-plist b/math/gretl/pkg-plist
index 18f36c0ecacd..388346ae4411 100644
--- a/math/gretl/pkg-plist
+++ b/math/gretl/pkg-plist
@@ -345,6 +345,7 @@ libdata/pkgconfig/gretl.pc
%%DATADIR%%/data/misc/np.gdt
%%DATADIR%%/data/misc/nysewk.gdt
%%DATADIR%%/data/misc/ooballot.gdt
+%%DATADIR%%/data/misc/nc_crime.gdt
%%DATADIR%%/data/misc/penngrow.gdt
%%DATADIR%%/data/misc/pension.gdt
%%DATADIR%%/data/misc/poisson.gdt