aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-08-17 22:20:40 +0800
committermat <mat@FreeBSD.org>2015-08-17 22:20:40 +0800
commit92a3a7b1bca5423036bca4932e5384d3e51591bd (patch)
tree16be3a9188cf2781563095e15839c170074dd7a7 /math
parented2992b93f898f5612b3952782ac7d9206ed029a (diff)
downloadfreebsd-ports-gnome-92a3a7b1bca5423036bca4932e5384d3e51591bd.tar.gz
freebsd-ports-gnome-92a3a7b1bca5423036bca4932e5384d3e51591bd.tar.zst
freebsd-ports-gnome-92a3a7b1bca5423036bca4932e5384d3e51591bd.zip
Remove UNIQUENAME and LATEST_LINK.
UNIQUENAME was never unique, it was only used by USE_LDCONFIG and now, we won't have conflicts there. Use PKGBASE instead of LATEST_LINK in PKGLATESTFILE, the *only* consumer is pkg-devel, and it works just fine without LATEST_LINK as pkg-devel has the correct PKGNAME anyway. Now that UNIQUENAME is gone, OPTIONSFILE is too. (it's been called OPTIONS_FILE now.) Reviewed by: antoine, bapt Exp-run by: antoine Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D3336
Diffstat (limited to 'math')
-rw-r--r--math/py-matplotlib/Makefile1
-rw-r--r--math/py-symeig/Makefile3
-rw-r--r--math/sage/Makefile2
-rw-r--r--math/vtk5/Makefile1
-rw-r--r--math/vtk6/Makefile2
5 files changed, 0 insertions, 9 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index bdf1d6d4d229..3c15c38e5a7c 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -32,7 +32,6 @@ TKAGGBACKEND_DESC= TKAgg backend support
WXAGGBACKEND_DESC= WXAgg backend support
PORTEXAMPLES= *
-UNIQUENAME= ${PORTNAME}
.include <bsd.port.options.mk>
diff --git a/math/py-symeig/Makefile b/math/py-symeig/Makefile
index c2b45992e646..b4def8e06176 100644
--- a/math/py-symeig/Makefile
+++ b/math/py-symeig/Makefile
@@ -16,9 +16,6 @@ LICENSE= BSD3CLAUSE
BUILD_DEPENDS+= ${PYNUMPY}
RUN_DEPENDS+= ${PYNUMPY}
-LATEST_LINK= py-${PORTNAME}
-OPTIONSFILE= ${PORT_DBDIR}/py-numpy/options
-
USES= fortran python:2
USE_PYTHON= distutils autoplist
diff --git a/math/sage/Makefile b/math/sage/Makefile
index 2caa071ec154..63a7e7f5f01a 100644
--- a/math/sage/Makefile
+++ b/math/sage/Makefile
@@ -48,8 +48,6 @@ MAKE_ENV+= SAGE_PORT=yes \
SAGE_FAT_BINARY=yes \
PERL=${PERL}
-LATEST_LINK= sage-math # Conflicts with graphics/sage.
-
# The following is needed for the lapack subpackage.
MAKE_ARGS+= ARCH="${AR}"
diff --git a/math/vtk5/Makefile b/math/vtk5/Makefile
index 44ec24d3d0c8..923c1c9aa90e 100644
--- a/math/vtk5/Makefile
+++ b/math/vtk5/Makefile
@@ -7,7 +7,6 @@ PORTREVISION= 5
CATEGORIES= math graphics
MASTER_SITES= http://www.vtk.org/files/release/${PORTVERSION:R}/
PKGNAMESUFFIX= 5
-UNIQUENAME= ${PKGBASE}
MAINTAINER= ports@FreeBSD.org
COMMENT= The Visualization Toolkit
diff --git a/math/vtk6/Makefile b/math/vtk6/Makefile
index d5e7a3ae80de..ca5f28fa1d6b 100644
--- a/math/vtk6/Makefile
+++ b/math/vtk6/Makefile
@@ -23,8 +23,6 @@ LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
# TODO
# * VTK Groups
-UNIQUENAME= ${PKGBASE}
-
CONFLICTS= vtk-4*
USE_LDCONFIG= ${PREFIX}/lib/vtk-${VTK_SHORT_VER}
USE_XORG= xt