aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-04-30 02:05:54 +0800
committerijliao <ijliao@FreeBSD.org>2002-04-30 02:05:54 +0800
commitab1ff1663deabb3dd9edb43c7f101b80eb48760b (patch)
tree7e4fdc3bc6d2cde546c2936c75d77c5ec294f74b /math
parent1262e08a60f7e1ed3a8a11f08db55b24406faf32 (diff)
downloadfreebsd-ports-gnome-ab1ff1663deabb3dd9edb43c7f101b80eb48760b.tar.gz
freebsd-ports-gnome-ab1ff1663deabb3dd9edb43c7f101b80eb48760b.tar.zst
freebsd-ports-gnome-ab1ff1663deabb3dd9edb43c7f101b80eb48760b.zip
use USE_PYDISTUTILS
Diffstat (limited to 'math')
-rw-r--r--math/biggles/Makefile12
-rw-r--r--math/py-gnuplot/Makefile8
-rw-r--r--math/py-gsl/Makefile7
3 files changed, 4 insertions, 23 deletions
diff --git a/math/biggles/Makefile b/math/biggles/Makefile
index 3c61267de35e..e4d66d60ca2c 100644
--- a/math/biggles/Makefile
+++ b/math/biggles/Makefile
@@ -15,18 +15,10 @@ DISTNAME= python-${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${PYDISTUTILS} \
- ${PYTHON_SITELIBDIR}/Numeric.pth:${PORTSDIR}/math/py-numeric
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/Numeric.pth:${PORTSDIR}/math/py-numeric
LIB_DEPENDS= plot:${PORTSDIR}/graphics/plotutils
USE_PYTHON= yes
-
-SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
-
-do-build:
- @${SETUP_CMD} build
-
-do-install:
- @${SETUP_CMD} install
+USE_PYDISTUTILS= yes
.include <bsd.port.mk>
diff --git a/math/py-gnuplot/Makefile b/math/py-gnuplot/Makefile
index b29d915dd5f0..dc0941b06545 100644
--- a/math/py-gnuplot/Makefile
+++ b/math/py-gnuplot/Makefile
@@ -19,13 +19,7 @@ RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
${PYTHON_SITELIBDIR}/Numeric/_numpy.so:${PORTSDIR}/math/py-numeric
USE_PYTHON= yes
-SETUP_CMD= cd ${WRKSRC}; ${PYTHON_CMD} setup.py
-
-do-build:
- @${SETUP_CMD} build
-
-do-install:
- @${SETUP_CMD} install
+USE_PYDISTUTILS= yes
post-install:
.if !defined(NOPORTDOCS)
diff --git a/math/py-gsl/Makefile b/math/py-gsl/Makefile
index 97918dfed971..83d53409a538 100644
--- a/math/py-gsl/Makefile
+++ b/math/py-gsl/Makefile
@@ -20,11 +20,6 @@ LIB_DEPENDS= gsl.0:${PORTSDIR}/math/gsl
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g}
USE_PYTHON= yes
-
-do-build:
- @cd ${WRKSRC} && ${PYTHON_CMD} setup.py build
-
-do-install:
- @cd ${WRKSRC} && ${PYTHON_CMD} setup.py install
+USE_PYDISTUTILS= yes
.include <bsd.port.mk>