aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorstephen <stephen@FreeBSD.org>2018-05-24 11:22:45 +0800
committerstephen <stephen@FreeBSD.org>2018-05-24 11:22:45 +0800
commitafccce0450d92b95054615831834728b439b8b89 (patch)
tree1328d7a382357fbbf44c043db635835c239336d0 /math
parent8724da24e74ff1f3f89ec382847cafd2312f88c6 (diff)
downloadfreebsd-ports-gnome-afccce0450d92b95054615831834728b439b8b89.tar.gz
freebsd-ports-gnome-afccce0450d92b95054615831834728b439b8b89.tar.zst
freebsd-ports-gnome-afccce0450d92b95054615831834728b439b8b89.zip
- Add USES=compiler:gcc-c++11-lib hoping to remove build errors on
FreeBSD-11. Reported by: http://beefy9.nyi.freebsd.org/data/111amd64-default/470749/logs/octave-forge-octclip-1.0.8_8.log
Diffstat (limited to 'math')
-rw-r--r--math/octave-forge-octclip/Makefile5
-rw-r--r--math/octave-forge-octclip/files/patch-Makefile15
2 files changed, 17 insertions, 3 deletions
diff --git a/math/octave-forge-octclip/Makefile b/math/octave-forge-octclip/Makefile
index 5207909d5b9e..f5a15754f5ab 100644
--- a/math/octave-forge-octclip/Makefile
+++ b/math/octave-forge-octclip/Makefile
@@ -18,10 +18,9 @@ OCTSRC= ${DISTNAME}
WRKSRC= ${WRKDIR}/${OCTSRC}/src
-.include "${.CURDIR}/../../Mk/bsd.octave.mk"
+USES+= compiler:gcc-c++11-lib
-post-patch:
- ${REINPLACE_CMD} -e s/CC/MKOCTFILE/ -e s/-Wall// -e s/-Wextra// ${WRKSRC}/Makefile
+.include "${.CURDIR}/../../Mk/bsd.octave.mk"
post-build:
${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
diff --git a/math/octave-forge-octclip/files/patch-Makefile b/math/octave-forge-octclip/files/patch-Makefile
new file mode 100644
index 000000000000..00af5564f127
--- /dev/null
+++ b/math/octave-forge-octclip/files/patch-Makefile
@@ -0,0 +1,15 @@
+--- Makefile.orig 2018-05-24 03:17:31 UTC
++++ Makefile
+@@ -6,10 +6,10 @@ FLAGSCOMW=-Wall -Wextra -Wshadow -Wcast-
+ #Common optimization flags for C and C++
+ FLAGSCOMO=-O2 -funroll-loops -fno-common -fshort-enums
+ #Flags for C
+-CFLAGS=-std=c99 -pedantic $(FLAGSCOMW) -Wconversion -Wmissing-prototypes
++CFLAGS+=-std=c99 -pedantic $(FLAGSCOMW) -Wconversion -Wmissing-prototypes
+ CFLAGS+=-Wstrict-prototypes -Wnested-externs $(FLAGSCOMO)
+ #Flags for C++
+-CXXFLAGS=$(FLAGSCOMW) $(FLAGSCOMO)
++CXXFLAGS+=$(FLAGSCOMW) $(FLAGSCOMO)
+ #Export flags for compilers and linker
+ export CFLAGS CXXFLAGS
+