aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorvsevolod <vsevolod@FreeBSD.org>2014-03-31 18:52:41 +0800
committervsevolod <vsevolod@FreeBSD.org>2014-03-31 18:52:41 +0800
commitb2d28fbc243fa56a7524436eb8a40a67e21919ea (patch)
tree9fc136ea46ea9303f975511723c92bae21040bd4 /math
parent44e0929062b22e13829d949aae9773cce5a20372 (diff)
downloadfreebsd-ports-gnome-b2d28fbc243fa56a7524436eb8a40a67e21919ea.tar.gz
freebsd-ports-gnome-b2d28fbc243fa56a7524436eb8a40a67e21919ea.tar.zst
freebsd-ports-gnome-b2d28fbc243fa56a7524436eb8a40a67e21919ea.zip
- Unbreak with clang 3.4 (not bumping revision).
Diffstat (limited to 'math')
-rw-r--r--math/minisat/Makefile2
-rw-r--r--math/minisat/files/patch-minisat-core-SolverTypes.h20
2 files changed, 21 insertions, 1 deletions
diff --git a/math/minisat/Makefile b/math/minisat/Makefile
index b4a66132ea74..5abf052b1855 100644
--- a/math/minisat/Makefile
+++ b/math/minisat/Makefile
@@ -11,6 +11,6 @@ COMMENT= A minimalistic, open-source SAT solver
USES= gmake
USE_LDCONFIG= yes
-MAKE_ENV= prefix=${PREFIX}
+MAKE_ENV= prefix=${PREFIX} CFLAGS="-std=c++03"
.include <bsd.port.mk>
diff --git a/math/minisat/files/patch-minisat-core-SolverTypes.h b/math/minisat/files/patch-minisat-core-SolverTypes.h
new file mode 100644
index 000000000000..0d310cee3069
--- /dev/null
+++ b/math/minisat/files/patch-minisat-core-SolverTypes.h
@@ -0,0 +1,20 @@
+--- minisat/core/SolverTypes.h.orig 2014-03-31 11:50:09.479636337 +0100
++++ minisat/core/SolverTypes.h 2014-03-31 11:50:32.079953517 +0100
+@@ -52,7 +52,7 @@
+ int x;
+
+ // Use this as a constructor:
+- friend Lit mkLit(Var var, bool sign = false);
++ friend Lit mkLit(Var var, bool sign);
+
+ bool operator == (Lit p) const { return x == p.x; }
+ bool operator != (Lit p) const { return x != p.x; }
+@@ -60,7 +60,7 @@
+ };
+
+
+-inline Lit mkLit (Var var, bool sign) { Lit p; p.x = var + var + (int)sign; return p; }
++inline Lit mkLit (Var var, bool sign = false) { Lit p; p.x = var + var + (int)sign; return p; }
+ inline Lit operator ~(Lit p) { Lit q; q.x = p.x ^ 1; return q; }
+ inline Lit operator ^(Lit p, bool b) { Lit q; q.x = p.x ^ (unsigned int)b; return q; }
+ inline bool sign (Lit p) { return p.x & 1; }