aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2012-06-08 00:00:26 +0800
committererwin <erwin@FreeBSD.org>2012-06-08 00:00:26 +0800
commitb84c90fdea9fdb894819acc6a4d171e313abe2a9 (patch)
tree68772a66d3288fe852bf5444befa98d1e84e48e5 /math
parent0cdcd11e1554dcc9c7f550feb240fc8289210106 (diff)
downloadfreebsd-ports-gnome-b84c90fdea9fdb894819acc6a4d171e313abe2a9.tar.gz
freebsd-ports-gnome-b84c90fdea9fdb894819acc6a4d171e313abe2a9.tar.zst
freebsd-ports-gnome-b84c90fdea9fdb894819acc6a4d171e313abe2a9.zip
- Rework the do-fetch target to check for the availability of the
distribution file in DISTDIR. - Remove the hardcoded "fetch" command and replaces it with ${FETCH_BINARY} PR: 168760 Submitted by: Fernando <fernando.apesteguia@gmail.com> (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/dynare/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/math/dynare/Makefile b/math/dynare/Makefile
index 8161aa1b5d2f..d5c23c26928f 100644
--- a/math/dynare/Makefile
+++ b/math/dynare/Makefile
@@ -36,7 +36,9 @@ BUILD_DEPENDS+= octave:${PORTSDIR}/math/octave
.endif
do-fetch:
- fetch -o ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} http://www.dynare.org/download/dynare-4.2/source/${DISTNAME}${EXTRACT_SUFX}/at_download/file
+ if [ ! -f ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ]; then \
+ ${FETCH_BINARY} -o ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} http://www.dynare.org/download/dynare-4.2/source/${DISTNAME}${EXTRACT_SUFX}/at_download/file ;\
+ fi
post-configure:
@${ECHO_MSG} ""