aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2012-04-22 22:14:38 +0800
committerlwhsu <lwhsu@FreeBSD.org>2012-04-22 22:14:38 +0800
commitcc10ab1abca4832a90909c751a66503170fcd1c1 (patch)
treebcb7b92fd61ec545863d0d788fedb0ca31677cce /math
parentc2b987bdbde5d651541f7efc355f923b65af75ab (diff)
downloadfreebsd-ports-gnome-cc10ab1abca4832a90909c751a66503170fcd1c1.tar.gz
freebsd-ports-gnome-cc10ab1abca4832a90909c751a66503170fcd1c1.tar.zst
freebsd-ports-gnome-cc10ab1abca4832a90909c751a66503170fcd1c1.zip
- Update to 3.1
- Update MASTER_SITES - Add LICENSE - Add regression-test target - Respect NOPORTDOCS PR: ports/167183 Submitted by: sbz
Diffstat (limited to 'math')
-rw-r--r--math/py-bitvector/Makefile22
-rw-r--r--math/py-bitvector/distinfo4
-rw-r--r--math/py-bitvector/pkg-descr2
3 files changed, 23 insertions, 5 deletions
diff --git a/math/py-bitvector/Makefile b/math/py-bitvector/Makefile
index a8a4f205cbac..9a44e5d7c0fd 100644
--- a/math/py-bitvector/Makefile
+++ b/math/py-bitvector/Makefile
@@ -6,21 +6,39 @@
#
PORTNAME= bitvector
-PORTVERSION= 1.4
+PORTVERSION= 3.1
CATEGORIES= math python
-MASTER_SITES= http://cobweb.ecn.purdue.edu/~kak/dist/
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= BitVector-${PORTVERSION}
MAINTAINER= lwhsu@FreeBSD.org
COMMENT= A pure-Python memory-efficient packed representation for bit arrays
+LICENSE= PSFL
+
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= BitVector
+PORTDOCS= README BitVector-${PORTVERSION}.html
+
PLIST_FILES= %%PYTHON_SITELIBDIR%%/BitVector.py \
%%PYTHON_SITELIBDIR%%/BitVector.pyc \
%%PYTHON_SITELIBDIR%%/BitVector.pyo
+post-extract:
+ @${RM} -f ${WRKSRC}/test.py
+
+.if !defined(NOPORTDOCS)
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+regression-test:
+ @(cd ${WRKSRC}/TestBitVector && ${PYTHON_CMD} Test.py)
+
.include <bsd.port.mk>
diff --git a/math/py-bitvector/distinfo b/math/py-bitvector/distinfo
index da1fde6108d7..1e85334fb328 100644
--- a/math/py-bitvector/distinfo
+++ b/math/py-bitvector/distinfo
@@ -1,2 +1,2 @@
-SHA256 (BitVector-1.4.tar.gz) = 448b7de69aea70ff8596f85ab01006488a4ac18665acf4b0ac83f1fe94dc5897
-SIZE (BitVector-1.4.tar.gz) = 67420
+SHA256 (BitVector-3.1.tar.gz) = fb839af4a65b9a656d7b6aa7a83c4088023b15f2123ea3a5f8a2764a6c17b1f7
+SIZE (BitVector-3.1.tar.gz) = 157374
diff --git a/math/py-bitvector/pkg-descr b/math/py-bitvector/pkg-descr
index 58a8ec926d64..00efd48c2757 100644
--- a/math/py-bitvector/pkg-descr
+++ b/math/py-bitvector/pkg-descr
@@ -3,4 +3,4 @@ and for logical operations on such arrays. The core idea used in this Python
script for bin packing is based on an internet posting by Josiah Carlson to
the Pyrex mailing list.
-WWW: http://rvl4.ecn.purdue.edu/~kak/dist/BitVector-1.3.html
+WWW: https://engineering.purdue.edu/kak/dist/BitVector-3.1.html