aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-16 00:48:38 +0800
committeraaron <aaron@FreeBSD.org>2006-05-16 00:48:38 +0800
commitd1f85b1e3108a889bee92e1fd8f7edab86287ab6 (patch)
treeb417f2046101a6b9efb89a530860f6bc5bedbb94 /math
parent6409cc2ca57bd938c38258343d9e1c2673d33749 (diff)
downloadfreebsd-ports-gnome-d1f85b1e3108a889bee92e1fd8f7edab86287ab6.tar.gz
freebsd-ports-gnome-d1f85b1e3108a889bee92e1fd8f7edab86287ab6.tar.zst
freebsd-ports-gnome-d1f85b1e3108a889bee92e1fd8f7edab86287ab6.zip
Adding port math/p5-Number-WithError-LaTeX, LaTeX output for Number::WithError
Approved by: tobez (implicit)
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Number-WithError-LaTeX/Makefile35
-rw-r--r--math/p5-Number-WithError-LaTeX/distinfo3
-rw-r--r--math/p5-Number-WithError-LaTeX/pkg-descr13
-rw-r--r--math/p5-Number-WithError-LaTeX/pkg-plist7
5 files changed, 59 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 96c89de89d46..5ef513c39bae 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -210,6 +210,7 @@
SUBDIR += p5-NetCDF
SUBDIR += p5-Number-Compare
SUBDIR += p5-Number-WithError
+ SUBDIR += p5-Number-WithError-LaTeX
SUBDIR += p5-Roman
SUBDIR += p5-Set-IntSpan
SUBDIR += p5-Set-Window
diff --git a/math/p5-Number-WithError-LaTeX/Makefile b/math/p5-Number-WithError-LaTeX/Makefile
new file mode 100644
index 000000000000..c8f9b57d157b
--- /dev/null
+++ b/math/p5-Number-WithError-LaTeX/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Number-WithError-LaTeX
+# Date created: 15 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Number-WithError-LaTeX
+PORTVERSION= 0.02
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Number
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= LaTeX output for Number::WithError
+
+BUILD_DEPENDS= ${SITE_PERL}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util \
+ ${SITE_PERL}/prefork.pm:${PORTSDIR}/devel/p5-prefork \
+ ${SITE_PERL}/Math/SymbolicX/Inline.pm:${PORTSDIR}/math/p5-Math-SymbolicX-Inline \
+ ${SITE_PERL}/Number/WithError.pm:${PORTSDIR}/math/p5-Number-WithError \
+ ${SITE_PERL}/TeX/Encode.pm:${PORTSDIR}/textproc/p5-TeX-Encode
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Number::WithError::LaTeX.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Number-WithError-LaTeX/distinfo b/math/p5-Number-WithError-LaTeX/distinfo
new file mode 100644
index 000000000000..92615c0a7039
--- /dev/null
+++ b/math/p5-Number-WithError-LaTeX/distinfo
@@ -0,0 +1,3 @@
+MD5 (Number-WithError-LaTeX-0.02.tar.gz) = ba6377fe173e9f8b9e25ee6216b93a60
+SHA256 (Number-WithError-LaTeX-0.02.tar.gz) = 4ca6109a322193987e090305dac490f74ba96b51f44da1888167f6425dd6b0d0
+SIZE (Number-WithError-LaTeX-0.02.tar.gz) = 22616
diff --git a/math/p5-Number-WithError-LaTeX/pkg-descr b/math/p5-Number-WithError-LaTeX/pkg-descr
new file mode 100644
index 000000000000..b905a7dd28e1
--- /dev/null
+++ b/math/p5-Number-WithError-LaTeX/pkg-descr
@@ -0,0 +1,13 @@
+This class is a subclass of Number::WithError. It provides the same
+interface and the same exports.
+
+It adds several methods to every object. The main functionality is
+provided by latex(), which dumps the object as valid LaTeX code. Also,
+encode() is a convenient way to encode any UTF-8 string into TeX. It is
+just a convenience thing since it is delegated to TeX::Encode.
+
+Unlike Number::WithError, this module requires perl version 5.8 or later.
+(That is the rationale for creating a separate distribution, too.)
+
+WWW: http://search.cpan.org/dist/Number-WithError-LaTeX
+Author: Steffen Mueller <symbolic-module@steffen-mueller.net>
diff --git a/math/p5-Number-WithError-LaTeX/pkg-plist b/math/p5-Number-WithError-LaTeX/pkg-plist
new file mode 100644
index 000000000000..0d3692c3cba8
--- /dev/null
+++ b/math/p5-Number-WithError-LaTeX/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Number/WithError/LaTeX.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Number/WithError/LaTeX/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Number/WithError/LaTeX
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Number/WithError
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Number
+@dirrmtry %%SITE_PERL%%/Number/WithError
+@dirrmtry %%SITE_PERL%%/Number