aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2015-03-26 08:28:04 +0800
committerbdrewery <bdrewery@FreeBSD.org>2015-03-26 08:28:04 +0800
commitdb3a66f8c54c8aa5f9bcb5aa0a2682cc3276b2e2 (patch)
tree9a0ed33bb1f16802e209033ddb045be49a3431b3 /math
parent35e15f9429113dff36815970c1e0446b4a9556b6 (diff)
downloadfreebsd-ports-gnome-db3a66f8c54c8aa5f9bcb5aa0a2682cc3276b2e2.tar.gz
freebsd-ports-gnome-db3a66f8c54c8aa5f9bcb5aa0a2682cc3276b2e2.tar.zst
freebsd-ports-gnome-db3a66f8c54c8aa5f9bcb5aa0a2682cc3276b2e2.zip
This fails with Clang on 8.4-amd64. Just stick with GCC for now since it is
working everywhere.
Diffstat (limited to 'math')
-rw-r--r--math/miracl/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/math/miracl/Makefile b/math/miracl/Makefile
index a580e1106889..d53e488ce253 100644
--- a/math/miracl/Makefile
+++ b/math/miracl/Makefile
@@ -24,7 +24,8 @@ LICENSE_PERMS_COMMERCIAL= dist-mirror dist-sell pkg-mirror pkg-sell no-auto-acce
ONLY_FOR_ARCHS= i386 amd64
-USES= zip compiler:c++0x
+USES= zip
+USE_GCC= yes
USE_LDCONFIG= yes
EXTRACT_BEFORE_ARGS= -j -L -q
@@ -41,22 +42,18 @@ BUILDCMD= linux
BUILDCMD= linux64
.endif
+.if ${ARCH} == "amd64"
+CFLAGS+= -fPIC
+.endif
+
post-patch:
# C{C,XX} safeness
# CFLAGS safeness
-.if ${ARCH} == "i386"
@${REINPLACE_CMD} -E \
-e 's|gcc|${CC}|' \
-e 's|g\+\+|${CXX}|' \
-e 's|-O2|${CFLAGS}|' \
${WRKSRC}/${BUILDCMD}
-.else
- @${REINPLACE_CMD} -E \
- -e 's|gcc|${CC}|' \
- -e 's|g\+\+|${CXX}|' \
- -e 's|-O2|${CFLAGS} -fPIC|' \
- ${WRKSRC}/${BUILDCMD}
-.endif
# Don't error when files not found
# Fix mrmuldv.cc not existing due to s/gcc/CC/ replacement above.
@${REINPLACE_CMD} -E \