aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-11-04 03:13:53 +0800
committerpav <pav@FreeBSD.org>2005-11-04 03:13:53 +0800
commitdff1af4df17f54f98afc96e7713c77d8d5cb0430 (patch)
tree695b4ccd786c7b49b12e91a06fbc8bc125d8f199 /math
parentc026ceb1171ca937b4f26502b401f35a86aedc2c (diff)
downloadfreebsd-ports-gnome-dff1af4df17f54f98afc96e7713c77d8d5cb0430.tar.gz
freebsd-ports-gnome-dff1af4df17f54f98afc96e7713c77d8d5cb0430.tar.zst
freebsd-ports-gnome-dff1af4df17f54f98afc96e7713c77d8d5cb0430.zip
- Update to 0.8.2
- Fix build with latest cln Submitted by: maintainer
Diffstat (limited to 'math')
-rw-r--r--math/libqalculate/Makefile5
-rw-r--r--math/libqalculate/distinfo4
-rw-r--r--math/libqalculate/files/patch-libqalculate-Number.cc29
-rw-r--r--math/libqalculate/files/patch-src-Makefile.in11
-rw-r--r--math/libqalculate/pkg-plist2
5 files changed, 34 insertions, 17 deletions
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
index f8d71fe545d4..6eaeed1a2557 100644
--- a/math/libqalculate/Makefile
+++ b/math/libqalculate/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libqalculate
-PORTVERSION= 0.8.0
-PORTREVISION= 1
+PORTVERSION= 0.8.2
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= qalculate
@@ -19,7 +18,7 @@ LIB_DEPENDS= cln.4:${PORTSDIR}/math/cln
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_INC_LIBTOOL_VER=15
+USE_LIBTOOL_VER=15
USE_GNOME= intlhack lthack pkgconfig gnomehack glib20 libxml2
INSTALLS_SHLIB= yes
diff --git a/math/libqalculate/distinfo b/math/libqalculate/distinfo
index 3bb70373a693..fa2f320df998 100644
--- a/math/libqalculate/distinfo
+++ b/math/libqalculate/distinfo
@@ -1,2 +1,2 @@
-MD5 (libqalculate-0.8.0.tar.gz) = c3b63fa34093e519d9ff55a590713620
-SIZE (libqalculate-0.8.0.tar.gz) = 665416
+MD5 (libqalculate-0.8.2.tar.gz) = 69824de52bea915f5cc00ed6e3b905c9
+SIZE (libqalculate-0.8.2.tar.gz) = 683579
diff --git a/math/libqalculate/files/patch-libqalculate-Number.cc b/math/libqalculate/files/patch-libqalculate-Number.cc
new file mode 100644
index 000000000000..c179a9ee8938
--- /dev/null
+++ b/math/libqalculate/files/patch-libqalculate-Number.cc
@@ -0,0 +1,29 @@
+--- libqalculate/Number.cc.orig Thu Nov 3 18:27:14 2005
++++ libqalculate/Number.cc Thu Nov 3 18:28:15 2005
+@@ -2389,7 +2389,7 @@
+ if(po.indicate_infinite_series && !infinite_series) {
+ remainders.push_back(remainder);
+ }
+- remainder *= base;
++ remainder = remainder * base;
+ div = cln::truncate2(remainder, d);
+ remainder2 = div.remainder;
+ remainder = div.quotient;
+@@ -2398,7 +2398,7 @@
+ started = !cln::zerop(remainder);
+ }
+ if(started) {
+- num *= base;
++ num = num * base;
+ num += remainder;
+ }
+ l10++;
+@@ -2417,7 +2417,7 @@
+ }
+ remainders.clear();
+ if(!exact && !infinite_series) {
+- remainder *= base;
++ remainder = remainder * base;
+ div = cln::truncate2(remainder, d);
+ remainder2 = div.remainder;
+ remainder = div.quotient;
diff --git a/math/libqalculate/files/patch-src-Makefile.in b/math/libqalculate/files/patch-src-Makefile.in
deleted file mode 100644
index 34cd1b4a1820..000000000000
--- a/math/libqalculate/files/patch-src-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig Tue Jun 7 10:42:56 2005
-+++ src/Makefile.in Tue Jun 7 10:44:51 2005
-@@ -530,7 +530,7 @@
-
-
- install-exec-local:
-- cd $(DESTDIR)$(bindir) && rm -f qalculate; $(LN_S) @LN_QALCULATE@ qalculate
-+# cd $(DESTDIR)$(bindir) && rm -f qalculate; $(LN_S) @LN_QALCULATE@ qalculate
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/math/libqalculate/pkg-plist b/math/libqalculate/pkg-plist
index 304163f74c6b..e14e8e85351b 100644
--- a/math/libqalculate/pkg-plist
+++ b/math/libqalculate/pkg-plist
@@ -13,7 +13,6 @@ include/libqalculate/Unit.h
include/libqalculate/BuiltinFunctions.h
include/libqalculate/qalculate.h
lib/libqalculate.a
-lib/libqalculate.la
lib/libqalculate.so
lib/libqalculate.so.0
libdata/pkgconfig/libqalculate.pc
@@ -25,5 +24,6 @@ share/qalculate/planets.xml
share/qalculate/prefixes.xml
share/qalculate/units.xml
share/qalculate/variables.xml
+share/qalculate/currencies.xml
@dirrm include/libqalculate
@dirrm share/qalculate