aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-07-24 16:03:40 +0800
committermakc <makc@FreeBSD.org>2010-07-24 16:03:40 +0800
commite76d63e80e5e51811ff991be0aed6bbce0e89746 (patch)
tree2e10d6a6e1efac8ffc0d4947d8707bf592ef994c /math
parentaee17c98e9240855056ee2c730f70c64f3a69ce7 (diff)
downloadfreebsd-ports-gnome-e76d63e80e5e51811ff991be0aed6bbce0e89746.tar.gz
freebsd-ports-gnome-e76d63e80e5e51811ff991be0aed6bbce0e89746.tar.zst
freebsd-ports-gnome-e76d63e80e5e51811ff991be0aed6bbce0e89746.zip
Fix the fix.
PR: ports/148407 Submitted by: Mayo Jordanov (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/lp_solve/Makefile1
-rw-r--r--math/lp_solve/files/patch-shared+commonlib.c2
2 files changed, 2 insertions, 1 deletions
diff --git a/math/lp_solve/Makefile b/math/lp_solve/Makefile
index 6f069250b0a6..3666e858abfa 100644
--- a/math/lp_solve/Makefile
+++ b/math/lp_solve/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lp_solve
PORTVERSION= 5.5.0.15
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= SF/lpsolve/lpsolve/${PORTVERSION}
DISTNAME= ${PORTNAME}_${PORTVERSION}_source
diff --git a/math/lp_solve/files/patch-shared+commonlib.c b/math/lp_solve/files/patch-shared+commonlib.c
index 978f0e153e73..bb4f7edd88a2 100644
--- a/math/lp_solve/files/patch-shared+commonlib.c
+++ b/math/lp_solve/files/patch-shared+commonlib.c
@@ -18,7 +18,7 @@
+ struct timezone tz;
+
+ gettimeofday(&tv, &tz);
-+ return((double)tv.tv_sec+((double)tv.tv_usec)/1000.0);
++ return((double)tv.tv_sec+((double)tv.tv_usec)/1000000.0);
- ftime(&buf);
- return((double)buf.time+((double) buf.millitm)/1000.0);