aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-12-13 15:58:07 +0800
committerbapt <bapt@FreeBSD.org>2012-12-13 15:58:07 +0800
commitfaa8efcccaf8981402e57709d9bc8e06aeb55687 (patch)
tree64b9a898a062d2b520f82f66e8fa011b8a8d9968 /math
parentf699dd2ec4d8149bba003a487998ff2558b57106 (diff)
downloadfreebsd-ports-gnome-faa8efcccaf8981402e57709d9bc8e06aeb55687.tar.gz
freebsd-ports-gnome-faa8efcccaf8981402e57709d9bc8e06aeb55687.tar.zst
freebsd-ports-gnome-faa8efcccaf8981402e57709d9bc8e06aeb55687.zip
Convert to new option framework
Diffstat (limited to 'math')
-rw-r--r--math/jlatexmath/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/math/jlatexmath/Makefile b/math/jlatexmath/Makefile
index 7b38ec511f0d..7241478b2bab 100644
--- a/math/jlatexmath/Makefile
+++ b/math/jlatexmath/Makefile
@@ -22,13 +22,13 @@ USE_ANT= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-OPTIONS= FOP "textproc/fop plugin (required for math/scilab)" ON
+OPTIONS_DEFINE= FOP EXAMPLES
+OPTIONS_DEFAULT= FOP
+FOP_DESC= textproc/fop plugin (required for math/scilab)
.include <bsd.port.options.mk>
-.if defined(WITHOUT_FOP)
-PLIST_SUB+= FOP="@comment "
-.else
+.if ${PORT_OPTIONS:MFOP}
BUILD_DEPENDS= fop:${PORTSDIR}/textproc/fop \
${JAVALIBDIR}/xmlgraphics-commons.jar:${PORTSDIR}/graphics/xmlgraphics-commons \
${JAVASHAREDIR}/batik/batik.jar:${PORTSDIR}/graphics/batik \
@@ -42,6 +42,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
ALL_TARGET+= fop
PLIST_SUB+= FOP=""
+.else
+PLIST_SUB+= FOP="@comment "
.endif
post-patch:
@@ -52,7 +54,7 @@ post-patch:
do-install:
${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-${PORTVERSION}.jar ${JAVAJARDIR}/jlatexmath.jar
${INSTALL_DATA} ${WRKSRC}/dist/jlatexmath-fop-${PORTVERSION}.jar ${JAVAJARDIR}/jlatexmath-fop.jar
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
.endif