aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-03 06:23:52 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-03 06:23:52 +0800
commitff4f37d0245f9d99c9afca18f1be2efc1dccfe62 (patch)
treea98e44517d111062f41e9e6ac4568beb6c72220a /math
parentca35f2f8a90571f9f59e67e286137af6f88f7de0 (diff)
downloadfreebsd-ports-gnome-ff4f37d0245f9d99c9afca18f1be2efc1dccfe62.tar.gz
freebsd-ports-gnome-ff4f37d0245f9d99c9afca18f1be2efc1dccfe62.tar.zst
freebsd-ports-gnome-ff4f37d0245f9d99c9afca18f1be2efc1dccfe62.zip
Mark some ports failing on aarch64, and, in a few cases, other tier-2
archs. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'math')
-rw-r--r--math/algae/Makefile8
-rw-r--r--math/gotoblas/Makefile4
-rw-r--r--math/libtsnnls/Makefile2
-rw-r--r--math/math77/Makefile3
-rw-r--r--math/superlu_mt/Makefile2
5 files changed, 12 insertions, 7 deletions
diff --git a/math/algae/Makefile b/math/algae/Makefile
index 67d5d7733734..e86a0d701495 100644
--- a/math/algae/Makefile
+++ b/math/algae/Makefile
@@ -13,11 +13,9 @@ COMMENT= Programming language for numerical analysis
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc64= Does not build
-
-BROKEN_ia64= does not compile
-BROKEN_powerpc= does not compile
-BROKEN_sparc64= does not compile
+BROKEN_aarch64= does not build: checking for proper floating point exception handling... no
+BROKEN_armv6= does not build: checking for proper floating point exception handling... no
+BROKEN_powerpc64= does not build: configure: error: Cannot handle floating point exceptions
GNU_CONFIGURE= yes
USES= fortran
diff --git a/math/gotoblas/Makefile b/math/gotoblas/Makefile
index 7d54ddebe8fd..8082fad14017 100644
--- a/math/gotoblas/Makefile
+++ b/math/gotoblas/Makefile
@@ -19,7 +19,9 @@ COMMENT= Fast implementation of Basic Linear Algebra Subprograms
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/00License.txt
-BROKEN_powerpc64= does not build
+BROKEN_aarch64= does not build: undefined reference to get_libname
+BROKEN_armv6= does not build: undefined reference to get_libname
+BROKEN_powerpc64= does not build: error: macro names must be identifiers
BROKEN_i386= does not build (terminates with SIGBUS)
GOTOBLAS2VER= 1.13
diff --git a/math/libtsnnls/Makefile b/math/libtsnnls/Makefile
index e50cc2eea958..dbe09b32a57b 100644
--- a/math/libtsnnls/Makefile
+++ b/math/libtsnnls/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= http://www.jasoncantarella.com/downloads/
MAINTAINER= tzhuan@gmail.com
COMMENT= Fast Sparse Nonnegative Least Squares Solver
+BROKEN_aarch64= fails to configure: error: cannot compute sizeof (int)
+
GNU_CONFIGURE= yes
USES= fortran libtool
USE_LDCONFIG= yes
diff --git a/math/math77/Makefile b/math/math77/Makefile
index e5079b0d3922..18a8493188e2 100644
--- a/math/math77/Makefile
+++ b/math/math77/Makefile
@@ -13,7 +13,8 @@ COMMENT= CalTech mathematical subprogram libraries for Fortran 77
LICENSE= BSD3CLAUSE
-BROKEN_powerpc64= Does not build
+BROKEN_aarch64= fails to compile: error: unknown architecture native
+BROKEN_powerpc64= fails to compile: error: unrecognized command line option -march=native
USES= fortran gmake tar:tgz
WRKSRC= ${WRKDIR}/MATH77
diff --git a/math/superlu_mt/Makefile b/math/superlu_mt/Makefile
index b363f2fb10e7..77e545b484d5 100644
--- a/math/superlu_mt/Makefile
+++ b/math/superlu_mt/Makefile
@@ -15,6 +15,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Routines for performing multithreaded sparse factorization
+BROKEN_aarch64= fails to build: undefined reference to sbrk
+
USES= fortran gmake
OPTIONS_DEFINE= DOCS