aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-01-25 00:37:13 +0800
committermat <mat@FreeBSD.org>2017-01-25 00:37:13 +0800
commit0153841609e98197bbc4d79cd18ced18bf61ce98 (patch)
tree3297913adba11d771e5129d038a1ea9ccef8a474 /math
parent20ac2e4b36ad5bd29bee5a1024bd61a427254046 (diff)
downloadfreebsd-ports-gnome-0153841609e98197bbc4d79cd18ced18bf61ce98.tar.gz
freebsd-ports-gnome-0153841609e98197bbc4d79cd18ced18bf61ce98.tar.zst
freebsd-ports-gnome-0153841609e98197bbc4d79cd18ced18bf61ce98.zip
Unbreak after math/pari's latest upgrade by bundeling previous the
previous pari version. Additionnally, update to 2.01080900. Sponsored by: Absolight
Diffstat (limited to 'math')
-rw-r--r--math/p5-Math-Pari/Makefile50
-rw-r--r--math/p5-Math-Pari/distinfo7
-rw-r--r--math/p5-Math-Pari/files/patch-Makefile.PL8
-rw-r--r--math/p5-Math-Pari/pkg-plist2
4 files changed, 53 insertions, 14 deletions
diff --git a/math/p5-Math-Pari/Makefile b/math/p5-Math-Pari/Makefile
index fdbc0c2d22e1..511f71f55539 100644
--- a/math/p5-Math-Pari/Makefile
+++ b/math/p5-Math-Pari/Makefile
@@ -2,26 +2,60 @@
# $FreeBSD$
PORTNAME= Math-Pari
-PORTVERSION= 2.01080800
+PORTVERSION= 2.01080900
CATEGORIES= math perl5
-MASTER_SITES= CPAN
+MASTER_SITES= CPAN \
+ http://pari.math.u-bordeaux.fr/pub/pari/unix/OLD/:pari \
+ http://mirrors.rit.edu/zi/:pari
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-${PORTVERSION:C/00$//}
+DISTFILES= ${DISTNAME}.zip \
+ pari-2.3.5.tar.gz:pari
MAINTAINER= perl@FreeBSD.org
COMMENT= PARI - numerical/scientific/number-theoretic calculations
-BUILD_DEPENDS= ${NONEXISTENT}:math/pari:configure
-LIB_DEPENDS= libpari.so:math/pari
+LIB_DEPENDS= libgmp.so:math/gmp
-USES= perl5 zip
+USES= perl5
USE_PERL5= configure
-CONFIGURE_ARGS= parilib="-L${LOCALBASE}/lib -lpari" \
- paridir=`${MAKE} -C ${PORTSDIR}/math/pari -V WRKSRC`
+PARI_WRKSRC= ${WRKDIR}/pari-2.3.5
+
+CFLAGS+= -I${PARI_WRKSRC}/src/headers -I${PARI_WRKSRC}/build
+
+CONFIGURE_ARGS= parilib="-L${PARI_WRKSRC}/build -lpari" \
+ paridir=${PARI_WRKSRC}
+MAKE_ARGS= LDLOADLIBS="-lm -L${PARI_WRKSRC}/build -Wl,-rpath=${SITE_ARCH}/auto/Math/Pari -lpari"
post-patch:
@${REINPLACE_CMD} -e 's|2001007|2003000|' ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} -E '/^list=/s/(ld|ranlib|perl|emacs)//g' \
+ ${PARI_WRKSRC}/Configure
+ @${REINPLACE_CMD} -e '/^CFLAGS=/s/\$$cflags//' \
+ ${PARI_WRKSRC}/config/get_cc
+
+pre-configure:
+ cd ${PARI_WRKSRC} && ${SETENV} CC="${CC}" CPP="${CPP}" CXX="${CXX}" \
+ CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" LIBS="${LIBS}" \
+ INSTALL="/usr/bin/install -c" \
+ INSTALL_DATA="${INSTALL_DATA}" \
+ INSTALL_LIB="${INSTALL_LIB}" \
+ INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
+ INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
+ ld="${LD}" perl="${PERL}" ranlib="${RANLIB}" \
+ ./Configure --mandir=${MANPREFIX}/man/man1 \
+ --prefix=${PREFIX} \
+ --share-prefix=${PREFIX}/share \
+ --with-gmp=${LOCALBASE}
+
+pre-build:
+ cd ${PARI_WRKSRC} && ${DO_MAKE_BUILD:N-j*} gp
+ cd ${PARI_WRKSRC} && ln -s $$(dirname $$(readlink gp)) build
+
+post-install:
+ ${INSTALL_LIB} ${PARI_WRKSRC}/build/libpari-gmp.so.2.3.5 ${STAGEDIR}${SITE_ARCH}/auto/Math/Pari
+ ${LN} -s libpari-gmp.so.2.3.5 ${STAGEDIR}${SITE_ARCH}/auto/Math/Pari/libpari-gmp.so.2
post-clean:
@${MAKE_CMD} -C ${PORTSDIR}/math/pari -DBATCH clean
diff --git a/math/p5-Math-Pari/distinfo b/math/p5-Math-Pari/distinfo
index 3a658e9b22f2..8bbdd6a09855 100644
--- a/math/p5-Math-Pari/distinfo
+++ b/math/p5-Math-Pari/distinfo
@@ -1,2 +1,5 @@
-SHA256 (Math-Pari-2.010808.zip) = 543633b2984a71e8adee2a6130f740cc1e22aefb95ca3e886338aee9e1ae3c06
-SIZE (Math-Pari-2.010808.zip) = 153838
+TIMESTAMP = 1485271442
+SHA256 (Math-Pari-2.01080900.zip) = 5845d9350fe0cd9d909d71b6d6b88ab67d17da88f4b0df6570938583d6f365fc
+SIZE (Math-Pari-2.01080900.zip) = 166396
+SHA256 (pari-2.3.5.tar.gz) = 47ddae1af73b4476660d2a89338483949067a97ffb8758c82e8189dfa4c89d88
+SIZE (pari-2.3.5.tar.gz) = 2018097
diff --git a/math/p5-Math-Pari/files/patch-Makefile.PL b/math/p5-Math-Pari/files/patch-Makefile.PL
index 7540fe869366..dfbb7bc5335b 100644
--- a/math/p5-Math-Pari/files/patch-Makefile.PL
+++ b/math/p5-Math-Pari/files/patch-Makefile.PL
@@ -1,6 +1,6 @@
---- Makefile.PL.orig 2009-12-25 11:08:17.581369187 +0300
-+++ Makefile.PL 2009-12-25 11:10:35.244866346 +0300
-@@ -119,9 +119,9 @@
+--- Makefile.PL.orig 2016-05-07 03:14:29 UTC
++++ Makefile.PL
+@@ -142,9 +142,9 @@ if ($os eq "solaris") {
}
my %opts;
@@ -11,7 +11,7 @@
make_pod 'libPARI.dumb.pod', '-to_dumb_pod', $paridir;
# ... and paricfg.h
%opts = build_paricfg($paridir, $common::do_configure, $pari_version);
-@@ -176,7 +176,7 @@
+@@ -199,7 +199,7 @@ my $extra_inc = extra_includes($paridir)
# the contents of the Makefile being created.
&WriteMakefile(
LIBS => $libs,
diff --git a/math/p5-Math-Pari/pkg-plist b/math/p5-Math-Pari/pkg-plist
index b132b4400a54..0e310decbf48 100644
--- a/math/p5-Math-Pari/pkg-plist
+++ b/math/p5-Math-Pari/pkg-plist
@@ -4,4 +4,6 @@
%%SITE_ARCH%%/Math/Pari.pm
%%SITE_ARCH%%/Math/PariInit.pm
%%SITE_ARCH%%/Math/libPARI.pod
+%%SITE_ARCH%%/auto/Math/Pari/libpari-gmp.so.2
+%%SITE_ARCH%%/auto/Math/Pari/libpari-gmp.so.2.3.5
%%SITE_ARCH%%/auto/Math/Pari/Pari.so