aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-01-11 07:31:58 +0800
committermiwi <miwi@FreeBSD.org>2008-01-11 07:31:58 +0800
commit0c94ed86314c12ba7b18667d0ba9f3d4faa849b3 (patch)
tree1fc81c1732bcbd6dd00a483a7ac9f8a70e1847f6 /math
parentf09a4695e5c839ac1156602ffc6da8a971340e01 (diff)
downloadfreebsd-ports-gnome-0c94ed86314c12ba7b18667d0ba9f3d4faa849b3.tar.gz
freebsd-ports-gnome-0c94ed86314c12ba7b18667d0ba9f3d4faa849b3.tar.zst
freebsd-ports-gnome-0c94ed86314c12ba7b18667d0ba9f3d4faa849b3.zip
This package lets you create and manipulate complex numbers. By default, Perl
limits itself to real numbers, but an extra use statement brings full complex support, along with a full set of mathematical functions typically associated with and/or extended to complex numbers. WWW: http://search.cpan.org/dist/Math-Complex/ PR: ports/119441 Submitted by: Jin-Shan Tseng <tjs at cdpa.nsysu.edu.tw>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Complex/Makefile22
-rw-r--r--math/p5-Math-Complex/distinfo3
-rw-r--r--math/p5-Math-Complex/pkg-descr6
-rw-r--r--math/p5-Math-Complex/pkg-plist7
5 files changed, 39 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 3364a7d70d45..640d125a84fb 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -204,6 +204,7 @@
SUBDIR += p5-Math-Calc-Units
SUBDIR += p5-Math-Cephes
SUBDIR += p5-Math-Combinatorics
+ SUBDIR += p5-Math-Complex
SUBDIR += p5-Math-ConvexHull
SUBDIR += p5-Math-Currency
SUBDIR += p5-Math-Derivative
diff --git a/math/p5-Math-Complex/Makefile b/math/p5-Math-Complex/Makefile
new file mode 100644
index 000000000000..d0307203af0c
--- /dev/null
+++ b/math/p5-Math-Complex/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Math-Complex
+# Date created: 2008-01-08
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Complex
+PORTVERSION= 1.42
+CATEGORIES= math
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Complex numbers and associated mathematical functions
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= Math::Complex.3 \
+ Math::Trig.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Complex/distinfo b/math/p5-Math-Complex/distinfo
new file mode 100644
index 000000000000..327536294e50
--- /dev/null
+++ b/math/p5-Math-Complex/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Complex-1.42.tar.gz) = d0825ce78ae8c7c9ee89ccca37418f72
+SHA256 (Math-Complex-1.42.tar.gz) = b121e72e6ee198861671fcf933df76a919560e77bd4ff0881359a3f179aa8b0e
+SIZE (Math-Complex-1.42.tar.gz) = 34624
diff --git a/math/p5-Math-Complex/pkg-descr b/math/p5-Math-Complex/pkg-descr
new file mode 100644
index 000000000000..ca7f4436b148
--- /dev/null
+++ b/math/p5-Math-Complex/pkg-descr
@@ -0,0 +1,6 @@
+This package lets you create and manipulate complex numbers. By default, Perl
+limits itself to real numbers, but an extra use statement brings full complex
+support, along with a full set of mathematical functions typically associated
+with and/or extended to complex numbers.
+
+WWW: http://search.cpan.org/dist/Math-Complex/
diff --git a/math/p5-Math-Complex/pkg-plist b/math/p5-Math-Complex/pkg-plist
new file mode 100644
index 000000000000..a983583f1d19
--- /dev/null
+++ b/math/p5-Math-Complex/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Complex/.packlist
+%%SITE_PERL%%/Math/Complex.pm
+%%SITE_PERL%%/Math/Trig.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Complex
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math
+@dirrmtry %%SITE_PERL%%/Math