aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-01-04 07:23:33 +0800
committerwill <will@FreeBSD.org>2001-01-04 07:23:33 +0800
commit1be2b5186ea21231d70e0a206a0f3f287942d93d (patch)
tree53244f308312e2bf4db948b0b46b1139baf9f1db /math
parent05e9f1e923e47ba8b24294f8f907df45e86d7eef (diff)
downloadfreebsd-ports-gnome-1be2b5186ea21231d70e0a206a0f3f287942d93d.tar.gz
freebsd-ports-gnome-1be2b5186ea21231d70e0a206a0f3f287942d93d.tar.zst
freebsd-ports-gnome-1be2b5186ea21231d70e0a206a0f3f287942d93d.zip
Add p5-Bit-Vector 6.0, library of advanced math functions that includes a
Perl OO module.
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Bit-Vector/Makefile23
-rw-r--r--math/p5-Bit-Vector/distinfo1
-rw-r--r--math/p5-Bit-Vector/pkg-comment1
-rw-r--r--math/p5-Bit-Vector/pkg-descr17
-rw-r--r--math/p5-Bit-Vector/pkg-plist9
6 files changed, 52 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 9bdeb55ed9b6..63c289697cef 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -47,6 +47,7 @@
SUBDIR += p5-AI-NeuralNet-Mesh
SUBDIR += p5-AI-Perceptron
SUBDIR += p5-Bit-ShiftReg
+ SUBDIR += p5-Bit-Vector
SUBDIR += p5-Math-Expr
SUBDIR += p5-Math-Logic
SUBDIR += p5-MatrixReal
diff --git a/math/p5-Bit-Vector/Makefile b/math/p5-Bit-Vector/Makefile
new file mode 100644
index 000000000000..bede6dacd461
--- /dev/null
+++ b/math/p5-Bit-Vector/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: Bit-Vector
+# Date created: Mon Jan 1 10:37:30 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Bit-Vector
+PORTVERSION= 6.0
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Bit
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Bit::Vector.3 Bit::Vector::Overload.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Bit-Vector/distinfo b/math/p5-Bit-Vector/distinfo
new file mode 100644
index 000000000000..781149427474
--- /dev/null
+++ b/math/p5-Bit-Vector/distinfo
@@ -0,0 +1 @@
+MD5 (Bit-Vector-6.0.tar.gz) = 3c80d4c40ba89b3270c03386de3949a1
diff --git a/math/p5-Bit-Vector/pkg-comment b/math/p5-Bit-Vector/pkg-comment
new file mode 100644
index 000000000000..06873270423b
--- /dev/null
+++ b/math/p5-Bit-Vector/pkg-comment
@@ -0,0 +1 @@
+Library of advanced math functions that includes a Perl OO module
diff --git a/math/p5-Bit-Vector/pkg-descr b/math/p5-Bit-Vector/pkg-descr
new file mode 100644
index 000000000000..e883982fa7f3
--- /dev/null
+++ b/math/p5-Bit-Vector/pkg-descr
@@ -0,0 +1,17 @@
+Bit::Vector is an efficient C library which allows you to handle
+bit vectors, sets (of integers), "big integer arithmetic" and
+boolean matrices, all of arbitrary sizes.
+
+The library is efficient (in terms of algorithmical complexity)
+and therefore fast (in terms of execution speed) for instance
+through the widespread use of divide-and-conquer algorithms.
+
+The package also includes an object-oriented Perl module for
+accessing the C library from Perl, and optionally features
+overloaded operators for maximum ease of use.
+
+The C library can nevertheless be used stand-alone, without Perl.
+
+Author: Steffen Beyer <sb@engelschall.com>
+
+--will
diff --git a/math/p5-Bit-Vector/pkg-plist b/math/p5-Bit-Vector/pkg-plist
new file mode 100644
index 000000000000..e181e0482a01
--- /dev/null
+++ b/math/p5-Bit-Vector/pkg-plist
@@ -0,0 +1,9 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Bit/Vector.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Bit/Vector.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Bit/Vector/Overload.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Bit/Vector/Overload.pod
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bit/Vector/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bit/Vector/Vector.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bit/Vector/Vector.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Bit/Vector
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Bit/Vector