aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-12-24 03:30:26 +0800
committersteve <steve@FreeBSD.org>1999-12-24 03:30:26 +0800
commit431e57478784d1915c425e3140dd683a5b5a8ef4 (patch)
treebf36dee2b2801aace1458f516526926551949463 /math
parent9fc08c918b78ae1372fc7cc6e458114bffebb232 (diff)
downloadfreebsd-ports-gnome-431e57478784d1915c425e3140dd683a5b5a8ef4.tar.gz
freebsd-ports-gnome-431e57478784d1915c425e3140dd683a5b5a8ef4.tar.zst
freebsd-ports-gnome-431e57478784d1915c425e3140dd683a5b5a8ef4.zip
* Update to version 2.0.
* Modified patches to suppport CC/CFLAGS properly * Updated WWW: line of pkg/DESCR * Fixed pkg/PLIST PR: 15501 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to 'math')
-rw-r--r--math/superlu/Makefile24
-rw-r--r--math/superlu/distinfo2
-rw-r--r--math/superlu/files/patch-aa35
-rw-r--r--math/superlu/files/patch-ab24
-rw-r--r--math/superlu/files/patch-ac14
-rw-r--r--math/superlu/pkg-descr6
-rw-r--r--math/superlu/pkg-plist2
7 files changed, 55 insertions, 52 deletions
diff --git a/math/superlu/Makefile b/math/superlu/Makefile
index 545c4756bb94..145261c7e762 100644
--- a/math/superlu/Makefile
+++ b/math/superlu/Makefile
@@ -1,20 +1,19 @@
# New ports collection makefile for: SuperLU
-# Version required: 1.1
-# Date created: 31 Oct 97
-# Whom: Pedro Giffuni <giffunip@asme.org>
+# Version required: 2.0
+# Date created: 31 Oct 97
+# Whom: Pedro Giffuni <giffunip@asme.org>
#
# $FreeBSD$
#
-DISTNAME= superlu_1.1
-PKGNAME= superlu-1.1
+DISTNAME= superlu_2.0
+PKGNAME= superlu-2.0
CATEGORIES= math
-MASTER_SITES= ftp://ftp.cs.berkeley.edu/pub/lapack/SuperLU/ \
- ftp://ftp.u-aizu.ac.jp/pub/SciEng/numanal/cs.berkeley.edu/lapack/SuperLU/
+MASTER_SITES= http://www.nersc.gov/~xiaoye/SuperLU/
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= ${PREFIX}/lib/libblas.a:${PORTSDIR}/math/blas
+BUILD_DEPENDS= ${LOCALBASE}/lib/libblas.a:${PORTSDIR}/math/blas
WRKSRC= ${WRKDIR}/SuperLU
ALL_TARGET= superlulib
@@ -22,11 +21,12 @@ ALL_TARGET= superlulib
# NOTE: The Matlab interface was not built.
#
-post-install:
- $(INSTALL_DATA) ${WRKSRC}/libsuperlu.* ${PREFIX}/lib
- $(INSTALL_DATA) ${WRKSRC}/SRC/supermatrix.h ${PREFIX}/include
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libsuperlu.* ${PREFIX}/lib
+ ${INSTALL_DATA} ${WRKSRC}/SRC/supermatrix.h ${PREFIX}/include
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/SuperLU
+ @${MKDIR} ${PREFIX}/share/doc/SuperLU
${INSTALL_DATA} ${WRKSRC}/INSTALL/*.ps ${PREFIX}/share/doc/SuperLU
.endif
+
.include <bsd.port.mk>
diff --git a/math/superlu/distinfo b/math/superlu/distinfo
index c342e8fb6a87..9e3b8c6e9322 100644
--- a/math/superlu/distinfo
+++ b/math/superlu/distinfo
@@ -1 +1 @@
-MD5 (superlu_1.1.tar.gz) = 476515c112be637339617bc29aecade7
+MD5 (superlu_2.0.tar.gz) = 4a1b1a193bf409b76b663d94f9a2d64d
diff --git a/math/superlu/files/patch-aa b/math/superlu/files/patch-aa
index ca6dfb50de76..73e92f06ae53 100644
--- a/math/superlu/files/patch-aa
+++ b/math/superlu/files/patch-aa
@@ -1,6 +1,6 @@
---- make.inc.orig Fri Mar 27 07:58:12 1998
-+++ make.inc Mon May 10 01:43:38 1999
-@@ -14,14 +14,14 @@
+--- make.inc.orig Fri Aug 6 15:10:24 1999
++++ make.inc Thu Dec 16 04:00:37 1999
+@@ -16,14 +16,14 @@
#
# The machine (platform) identifier to append to the library names
#
@@ -14,28 +14,31 @@
-SUPERLULIB = superlu$(PLAT).a
-BLASLIB = ../blas$(PLAT).a
+SUPERLULIB = libsuperlu$(PLAT).a
-+BLASLIB = $(PREFIX)/lib/libblas$(PLAT).a
++BLASLIB = ${LOCALBASE}/lib/libblas$(PLAT).a
#
# The archiver and the flag(s) to use when building archive (library)
-@@ -31,10 +31,10 @@
+@@ -33,12 +33,12 @@
ARCHFLAGS = cr
RANLIB = ranlib
--CC = cc
--CFLAGS = -xO3 -xcg92
--LOADER = cc
--LOADOPTS = -xO3
-+CC = gcc
-+CFLAGS = -O3
-+LOADER = gcc
-+LOADOPTS = -O3
+-CC = gcc
++CC ?= gcc
+ #CFLAGS = -xO3 -xcg92
+-CFLAGS = -Wall -O2
+-FORTRAN = f77
+-FFLAGS = -O
+-LOADER = gcc
++CFLAGS ?= -Wall -O2
++FORTRAN = ${FC}
++FFLAGS ?= -O
++LOADER = ${CC}
+ LOADOPTS = #-xO3
#
- # C preprocessor defs for compilation (-DNoChange, -DAdd_, or -DUpCase)
-@@ -43,4 +43,4 @@
+@@ -48,4 +48,4 @@
#
# The directory in which Matlab is installed
#
-MATLAB = /usr/sww/matlab
-+MATLAB = ${PREFIX}/matlab
++MATLAB = ${LOCALBASE}/matlab
diff --git a/math/superlu/files/patch-ab b/math/superlu/files/patch-ab
index 3bf013f88843..991672c33292 100644
--- a/math/superlu/files/patch-ab
+++ b/math/superlu/files/patch-ab
@@ -1,26 +1,14 @@
-*** SRC/util.h.orig Sat Nov 22 22:25:23 1997
---- SRC/util.h Sat Nov 22 22:29:50 1997
+*** SRC/util.h.orig Fri Aug 6 04:21:40 1999
+--- SRC/util.h Thu Dec 16 03:32:32 1999
***************
-*** 2,10 ****
- #define __SUPERLU_UTIL
-
- #include <stdio.h>
- #include <stdlib.h>
-! #include <string.h>
- #include <malloc.h>
- #include <assert.h>
-
- /* Macros */
---- 2,13 ----
- #define __SUPERLU_UTIL
-
+*** 4,10 ****
+--- 4,12 ----
#include <stdio.h>
-+ #ifdef __STDC__
#include <stdlib.h>
-! #else
+ #include <string.h>
++ #ifndef __STDC__
#include <malloc.h>
+ #endif
-+ #include <string.h>
#include <assert.h>
/* Macros */
diff --git a/math/superlu/files/patch-ac b/math/superlu/files/patch-ac
new file mode 100644
index 000000000000..f0a53b9b793e
--- /dev/null
+++ b/math/superlu/files/patch-ac
@@ -0,0 +1,14 @@
+*** SRC/sp_coletree.c.orig Fri Aug 6 05:31:22 1999
+--- SRC/sp_coletree.c Thu Dec 16 03:29:12 1999
+***************
+*** 2,8 ****
+--- 2,10 ----
+ /* Elimination tree computation and layout routines */
+
+ #include <stdio.h>
++ #ifndef __STDC__
+ #include <malloc.h>
++ #endif
+ #include <stdlib.h>
+ #include "util.h"
+
diff --git a/math/superlu/pkg-descr b/math/superlu/pkg-descr
index e40a9d99a630..1bd4aecd3cd0 100644
--- a/math/superlu/pkg-descr
+++ b/math/superlu/pkg-descr
@@ -1,6 +1,6 @@
- SuperLU Version 1.0
- ===================
+ SuperLU (Version 2.0)
+ =====================
SuperLU contains a set of subroutines to solve a sparse linear system
A*X=B. It uses Gaussian elimination with partial pivoting (GEPP).
@@ -19,7 +19,7 @@ for the double-precision complex version start with letter "z"
===================
-WWW: http://www.cs.berkeley.edu/~xiaoye/superlu.html
+WWW: http://www.nersc.gov/~xiaoye/SuperLU/
Authors:
Jim Demmel demmel@cs.berkeley.edu
John Gilbert gilbert@parc.xerox.com
diff --git a/math/superlu/pkg-plist b/math/superlu/pkg-plist
index 5fdc4e4128ef..512b3a8de694 100644
--- a/math/superlu/pkg-plist
+++ b/math/superlu/pkg-plist
@@ -1,6 +1,4 @@
include/supermatrix.h
lib/libsuperlu.a
share/doc/SuperLU/ug.ps
-@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
-@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
@dirrm share/doc/SuperLU
't cause messages toDan Winship2001-02-162-2/+14 * IMAP4 (pre-rev1) doesn't allow BODY.PEEK[], so use RFC822.PEEK instead inDan Winship2001-02-162-3/+14 * Changed this code to match the glibc iconv signature.Christopher James Lahey2001-02-153-5/+11 * (create_folder): Oops, and fix bug involving namespacesDan Winship2001-02-152-5/+5 * New method to create a folder when you don't know its full name.Dan Winship2001-02-154-9/+95 * Add address headers to list that we dont fold when writing. The areNot Zed2001-02-134-8/+73 * mbox, mh, and maildir camel-url's need absolute paths.Jeffrey Stedfast2001-02-133-3/+11 * save, THEN commitDan Winship2001-02-101-4/+6 * Rewrite a bunch. Replace the existing folder cache stuff with much simplerDan Winship2001-02-1015-449/+243 * Oops, include the camel-tcp-stream-ssl header instead of the raw one.Jeffrey Stedfast2001-02-082-1/+6 * Added more test rules.Jeffrey Stedfast2001-02-082-0/+3 * Changed to push the operation into a status stack.Not Zed2001-02-0812-296/+729 * Macro for making comparisons easy. (camel_ustrcasecmp): UseJeffrey Stedfast2001-02-082-6/+20 * Macro for making comparisons easy. (camel_ustrcasecmp): UseJeffrey Stedfast2001-02-082-52/+48 * Rewrote using unicode_get_utf8(). (camel_ustrcasecmp): Use unicode_char_tJeffrey Stedfast2001-02-074-58/+94 * Made these pass char ** as the second parameter to iconv.Christopher James Lahey2001-02-073-5/+11 * Added xml-* files.Jeffrey Stedfast2001-02-061-1/+1 * Removed unwanted header. It was never put in for a reason. Stop fixingNot Zed2001-02-065-11/+229 * Added a missing #include.Christopher James Lahey2001-02-063-0/+9 * Oops. Change this too.Jeffrey Stedfast2001-02-062-2/+5 * Updated.Jeffrey Stedfast2001-02-068-109/+140 * Revert jeff's earlier change, the change below is the more-correct fix.Not Zed2001-02-053-23/+31 * When we drop a fake node, dont skip checking the next in the list.Not Zed2001-02-052-1/+16 * Make do_write loop until the entire buffer is written.Jeffrey Stedfast2001-02-053-6/+15 * Add missing header for cancel check stuff.Not Zed2001-02-024-4/+25 * If we are folding, drop the space at the end of the line.Not Zed2001-02-012-0/+8 * Remvoe the stream locking here. I think this was leading to a deadlockNot Zed2001-01-302-4/+6 * Include the terminating NUL in the calculated string length. This hitNot Zed2001-01-292-1/+7 * Oops.Michael Zucci2001-01-252-0/+321 * Changed the subject search to handle case sensitive when it is mixed case.Not Zed2001-01-257-565/+143 * Added tests to see that invalid match and action rules are properlyNot Zed2001-01-242-0/+59 * Fix for api changes.Not Zed2001-01-242-3/+5 * (camel_filter_driver_filter_message): Remove an accidentallyMichael Zucci2001-01-242-1/+2 * Remove the 'finished message' bit.Not Zed2001-01-242-2/+7 * Add a lock around the delayed loading, so two threads won't try to do itDan Winship2001-01-244-2/+46 * Set the CamelFolder::name to just the base part of the vfolder name (theDan Winship2001-01-232-2/+8 * Perform error checking on parsing/execution.Not Zed2001-01-234-12/+60 * Removed some debug 'warnings', as they should now be displayed at theNot Zed2001-01-234-30/+87 * avoid /0 by updating after we've done the sync. (close_folders): Setup theNot Zed2001-01-232-2/+11 * Change the callbacks in this file to match the callback function types.Christopher James Lahey2001-01-232-1/+6 * Added profiling temp files.Not Zed2001-01-2215-2/+55 * When removing phantom nodes, check for the end node too.Not Zed2001-01-224-18/+26 * Make the output a little prettier. Okay, so I'm anal...Jeffrey Stedfast2001-01-223-17/+10 * Added an exception to CamelFilterGetFolderFunc.Not Zed2001-01-213-19/+48 * (subscribe_folder): add a missing UNLOCKDan Winship2001-01-202-0/+2 * Set the deleted bit *before* copying to the default folder, this way ifJeffrey Stedfast2001-01-202-4/+11 * If LISTing a subscribed folder doesn't return a LIST response, just ignoreDan Winship2001-01-202-3/+13 * Mark strings for translation.Kjartan Maraas2001-01-192-2/+6 * Add a percentage complete indicator to the status thing.Not Zed2001-01-193-18/+33 * More tweaking... skip separator characters after the namespace character.Dan Winship2001-01-193-3/+19 * Oops. Somewhere in one of the reorgs, the code to add new messages to theDan Winship2001-01-192-1/+8 * Add some g_warnings() to help debug later if I ever get the segfaults IJeffrey Stedfast2001-01-183-4/+16 * Make sure that the message-info is non-null before we go accessing innerJeffrey Stedfast2001-01-182-1/+10 * New smtp error-code to string mapping function. (smtp_connect): Use theJeffrey Stedfast2001-01-182-10/+106 * Add an int i so this code will compile. Should I be worried about how wellJeffrey Stedfast2001-01-172-1/+8 * Index: ChangeLogMichael Zucci2001-01-1717-28/+1896 * Delayed loading of IMAP message parts.Dan Winship2001-01-1713-183/+996 * fcntl(fd, F_GETFL) returns the flags as the return value, not via a passedDan Winship2001-01-174-14/+31 * set to nntp if ENABLE_NNTP (SUBDIRS): use $(NNTP_DIR)Chris Toshok2001-01-172-1/+10 * Don't check errno as it's not being set. Fixes bug #1150.Jeffrey Stedfast2001-01-172-2/+6 * Ugh, this design is ugly like my butt.Jeffrey Stedfast2001-01-166-5/+121 * Chganged len back to be unsigned. And do a simple range check on theNot Zed2001-01-168-17/+114 * If the close() is successful, set the fd to -1.Jeffrey Stedfast2001-01-166-50/+34 * Updated to be able to get the CAMEL_SOCKOPT_NONBLOCKING socket opt.Jeffrey Stedfast2001-01-162-2/+35 * Lock around the imap_rescan, which needs it.Peter Williams2001-01-162-0/+7 * A cancellable connection routine. (remote_send_string): Return cancelledNot Zed2001-01-155-24/+434 * Uses an SSL socket now although there's still a few things missing (likeJeffrey Stedfast2001-01-153-13/+55 * Implemented. (stream_setsockopt): Implemented.Jeffrey Stedfast2001-01-155-2/+227 * New CamelTcpStream class that implements nspr sockets and eventually willJeffrey Stedfast2001-01-146-14/+557 * New abstract class for TCP streams. The next step is to write childJeffrey Stedfast2001-01-143-0/+202 * New stream for handling SSL/TLS connections.Jeffrey Stedfast2001-01-143-0/+321 * (camel_folder_thread_messages_new): Added casts to rmeove someMichael Zucci2001-01-122-3/+5 * Perform a final pass, removing any pseudo nodes we added earlier. QuickNot Zed2001-01-122-0/+33 * (imap_copy_message_to): Fix this up: sync flags to the serverDan Winship2001-01-122-33/+57 * Fix a bug in previous commit: don't check for deleted messages if thereDan Winship2001-01-122-30/+40 * New function to check for added/deleted messages when re-selecting aDan Winship2001-01-124-4/+93 * Fix a locking problem. (One branch of an if statement was returning withDan Winship2001-01-122-6/+8 * Changed the descriptions for mh, mbox, and maildir to be moreJeffrey Stedfast2001-01-112-3/+8 * New header to prevent recursive #include problemsDan Winship2001-01-111-0/+39 * New header to prevent recursive #include problemsDan Winship2001-01-119-9/+29 * New class function, parallel to camel_folder_sync. (The defaultDan Winship2001-01-114-1/+72 * Mostly IMAP changes. Use the NAMESPACE extension (whereDan Winship2001-01-10