aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-03-14 22:24:24 +0800
committersobomax <sobomax@FreeBSD.org>2002-03-14 22:24:24 +0800
commit4d56d8aa787eb1999e7411a1aaf4c14211385364 (patch)
tree3afa2e6aa3af39f056a6042b414b60cc12c3f4bd /math
parentf53d3f9ec374d200fa6002a415de8a89a773b068 (diff)
downloadfreebsd-ports-gnome-4d56d8aa787eb1999e7411a1aaf4c14211385364.tar.gz
freebsd-ports-gnome-4d56d8aa787eb1999e7411a1aaf4c14211385364.tar.zst
freebsd-ports-gnome-4d56d8aa787eb1999e7411a1aaf4c14211385364.zip
Remove Gnumeric from RUN_DEPENDS. It is still needed at the build phase, but
only to take few files from the distribution. For example, this should allow to use Gnucash without installing Gnumeric as well as to use Guppi in Gnumeric's RUN_DEPENDS to make graph plotting features working OOB. Bump PORTREVISION.
Diffstat (limited to 'math')
-rw-r--r--math/guppi/Makefile7
-rw-r--r--math/guppi/files/patch-configure21
2 files changed, 23 insertions, 5 deletions
diff --git a/math/guppi/Makefile b/math/guppi/Makefile
index 0ba332bf9ab4..5f77170e9c6a 100644
--- a/math/guppi/Makefile
+++ b/math/guppi/Makefile
@@ -7,6 +7,7 @@
PORTNAME= guppi
PORTVERSION= 0.40.3
+PORTREVISION= 1
CATEGORIES= math gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/Guppi
@@ -14,9 +15,8 @@ DISTNAME= Guppi-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
-BUILD_DEPENDS= gnumeric:${PORTSDIR}/math/gnumeric
+BUILD_DEPENDS= /nonexistent:${PORTSDIR}/math/gnumeric:patch
LIB_DEPENDS= guile.9:${PORTSDIR}/lang/guile
-RUN_DEPENDS= gnumeric:${PORTSDIR}/math/gnumeric
USE_X_PREFIX= yes
USE_GMAKE= yes
@@ -26,7 +26,8 @@ INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-explicit-python-linking
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include/libglade-1.0" \
- LIBS="-L${LOCALBASE}/lib -pthread"
+ LIBS="-L${LOCALBASE}/lib -pthread" \
+ GNUMERIC_IDLDIR="`cd ${PORTSDIR}/math/gnumeric && ${MAKE} -V WRKSRC`/idl"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
PLIST_SUB= VERSION="${PORTVERSION}"
diff --git a/math/guppi/files/patch-configure b/math/guppi/files/patch-configure
index 637b445f09c0..6892d3b7c251 100644
--- a/math/guppi/files/patch-configure
+++ b/math/guppi/files/patch-configure
@@ -1,8 +1,8 @@
$FreeBSD$
---- configure 2002/01/23 15:05:45 1.1
-+++ configure 2002/01/23 15:06:08
+--- configure.orig Thu Mar 14 15:27:59 2002
++++ configure Thu Mar 14 15:30:18 2002
@@ -1259,10 +1259,10 @@
# The aliases save the names the user supplied, while $host etc.
@@ -18,3 +18,20 @@ $FreeBSD$
ac_config_headers="$ac_config_headers config.h"
+@@ -11158,15 +11158,13 @@
+
+ gnumeric_msg="not enabled"
+ gnumeric_enabled=no
+-GNUMERIC_IDLDIR=""
+ GUPPI_GNUMERIC_LIBS=""
+ GUPPI_GNUMERIC_CFLAGS=""
+ GUPPI_GNUMERIC_GRAPH_VERSION=Graph_v2
+ if test x"$enable_gnumeric" = xyes; then
+ echo "$as_me:11166: checking Gnumeric is installed" >&5
+ echo $ECHO_N "checking Gnumeric is installed... $ECHO_C" >&6
+- if gnome-config --moddatadir gnumeric > /dev/null 2>&1; then
+- GNUMERIC_IDLDIR=`gnome-config --moddatadir gnumeric`/idl
++ if /usr/bin/true; then
+
+ echo "$as_me:11171: result: yes" >&5
+ echo "${ECHO_T}yes" >&6