aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2017-11-24 08:05:20 +0800
committerglewis <glewis@FreeBSD.org>2017-11-24 08:05:20 +0800
commit5e17375d688df90d3aa2ff260854aee3e0e83662 (patch)
tree9aaf47890462e6fc99285610df3a27ed4c04bb3e /math
parent249e993a62f198e2b14e95310d7003336d9af24a (diff)
downloadfreebsd-ports-gnome-5e17375d688df90d3aa2ff260854aee3e0e83662.tar.gz
freebsd-ports-gnome-5e17375d688df90d3aa2ff260854aee3e0e83662.tar.zst
freebsd-ports-gnome-5e17375d688df90d3aa2ff260854aee3e0e83662.zip
. Update to 5.2.2.
. Remove most options and configure unconditional support for them. This is now a full featured port of gnuplot. If there is enough interest then I'll creating a 'gnuplot-lite' port for a minimalist version.
Diffstat (limited to 'math')
-rw-r--r--math/gnuplot/Makefile52
-rw-r--r--math/gnuplot/distinfo6
-rw-r--r--math/gnuplot/files/patch-configure117
-rw-r--r--math/gnuplot/files/patch-docs-Makefile.in29
-rw-r--r--math/gnuplot/files/patch-src-command.c10
-rw-r--r--math/gnuplot/pkg-plist74
6 files changed, 193 insertions, 95 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 946ec3389bfe..cb0b058deff2 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= gnuplot
-PORTVERSION= 5.0.7
+PORTVERSION= 5.2.2
CATEGORIES= math graphics
MASTER_SITES= SF
@@ -13,17 +13,25 @@ LICENSE_NAME= Gnuplot license
LICENSE_FILE= ${WRKSRC}/Copyright
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept
-USES= groff iconv lua pkgconfig readline
+USES+= groff iconv jpeg lua:53 pkgconfig readline
USE_TEX= kpathsea
+USE_GNOME+= atk cairo gtk20 gdkpixbuf2
+USE_WX= 2.8
+USE_XORG+= x11
+LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libgd.so:graphics/gd \
+ libpng16.so:graphics/png \
+ libtiff.so:graphics/tiff
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
-CONFIGURE_ENV= LUA_VER="${LUA_VER}"
CONFIGURE_ARGS+=--with-readline=gnu \
--with-kpsexpand \
--without-linux-vga \
--without-lisp-files \
--without-tutorial \
--with-bitmap-terminals \
+ --with-gd=${LOCALBASE} \
--with-gpic \
--with-mif \
--with-latex \
@@ -35,45 +43,13 @@ CONFIGURE_ARGS+=--with-readline=gnu \
PORTDOCS= *
PORTEXAMPLES= *
-# MAKE_JOBS_UNSAFE=yes
-
-OPTIONS_DEFINE= CAIRO DOCS EXAMPLES GD GRIDBOX PDF THINSPLINES WX X11
+OPTIONS_DEFINE= DOCS EXAMPLES GRIDBOX
GRIDBOX_DESC= Use the gridbox optimization for hidden3d
-THINSPLINES_DESC= Enable thin plate splines for grids in dgrid3d
-WX_DESC= wxWidgets (formerly wxWindows) support
-
-OPTIONS_DEFAULT=CAIRO GD WX X11
-OPTIONS_SUB= yes
-
-CAIRO_LIB_DEPENDS= libcairo.so:graphics/cairo
-CAIRO_USE= GNOME=pango
-CAIRO_CONFIGURE_WITH= cairo
-
-GD_LIB_DEPENDS= libgd.so:graphics/gd
-GD_CONFIGURE_ON= --with-gd=${LOCALBASE}
-GD_CONFIGURE_OFF+= --without-gd
GRIDBOX_CONFIGURE_OFF= --disable-h3d-quadtree --enable-h3d-gridbox
-PDF_LIB_DEPENDS= libpdf.so:print/pdflib
-PDF_CONFIGURE_ON= --with-pdf=${LOCALBASE}
-PDF_CONFIGURE_OFF= --without-pdf
-
-THINSPLINES_CONFIGURE_ENABLE= thin-splines
-
-X11_USE= XORG=x11
-
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MWX}
-# Version 3.x of WX currently cause gnuplot to crash.
-# Do not update without this without testing.
-USE_WX= 2.8
-WX_CONF_ARGS= absolute
-.else
-CONFIGURE_ARGS+= --disable-wxwidgets
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
'/^install:/s/install-am//' ${WRKSRC}/share/LaTeX/Makefile.in
@@ -88,9 +64,9 @@ post-build:
.endif
pre-install:
- ${MKDIR} ${STAGEDIR}${DATADIR}/5.0 ; \
+ ${MKDIR} ${STAGEDIR}${DATADIR}/5.2 ; \
${INSTALL_DATA} ${WRKSRC}/share/gnuplotrc \
- ${STAGEDIR}${DATADIR}/5.0/gnuplotrc.sample
+ ${STAGEDIR}${DATADIR}/5.2/gnuplotrc.sample
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
diff --git a/math/gnuplot/distinfo b/math/gnuplot/distinfo
index db81c404807d..f5371435aaf3 100644
--- a/math/gnuplot/distinfo
+++ b/math/gnuplot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1503808331
-SHA256 (gnuplot-5.0.7.tar.gz) = 0ad760ff013b4a9cf29853fa9b50c50030a33cd8fb86220a23abb466655136fc
-SIZE (gnuplot-5.0.7.tar.gz) = 5100186
+TIMESTAMP = 1511117899
+SHA256 (gnuplot-5.2.2.tar.gz) = a416d22f02bdf3873ef82c5eb7f8e94146795811ef808e12b035ada88ef7b1a1
+SIZE (gnuplot-5.2.2.tar.gz) = 5282973
diff --git a/math/gnuplot/files/patch-configure b/math/gnuplot/files/patch-configure
new file mode 100644
index 000000000000..246bcdf65f8b
--- /dev/null
+++ b/math/gnuplot/files/patch-configure
@@ -0,0 +1,117 @@
+--- configure.orig 2017-11-23 11:59:30.644837000 -0800
++++ configure 2017-11-23 12:01:09.450617000 -0800
+@@ -11246,12 +11246,12 @@
+ pkg_cv_LUA_CFLAGS="$LUA_CFLAGS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua5.3\""; } >&5
+- ($PKG_CONFIG --exists --print-errors "lua5.3") 2>&5
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua-5.3\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "lua-5.3") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+- pkg_cv_LUA_CFLAGS=`$PKG_CONFIG --cflags "lua5.3" 2>/dev/null`
++ pkg_cv_LUA_CFLAGS=`$PKG_CONFIG --cflags "lua-5.3" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -11264,12 +11264,12 @@
+ pkg_cv_LUA_LIBS="$LUA_LIBS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua5.3\""; } >&5
+- ($PKG_CONFIG --exists --print-errors "lua5.3") 2>&5
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua-5.3\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "lua-5.3") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+- pkg_cv_LUA_LIBS=`$PKG_CONFIG --libs "lua5.3" 2>/dev/null`
++ pkg_cv_LUA_LIBS=`$PKG_CONFIG --libs "lua-5.3" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -11288,9 +11288,9 @@
+ _pkg_short_errors_supported=no
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+- LUA_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "lua5.3"`
++ LUA_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "lua-5.3"`
+ else
+- LUA_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "lua5.3"`
++ LUA_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "lua-5.3"`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$LUA_PKG_ERRORS" >&5
+@@ -11739,7 +11739,7 @@
+ LUA_LIBS=$pkg_cv_LUA_LIBS
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+ $as_echo "yes" >&6; }
+- LUA=lua5.3
++ LUA=lua53
+ fi
+ elif test $pkg_failed = untried; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+@@ -11754,12 +11754,12 @@
+ pkg_cv_LUA_CFLAGS="$LUA_CFLAGS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua5.3\""; } >&5
+- ($PKG_CONFIG --exists --print-errors "lua5.3") 2>&5
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua-5.3\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "lua-5.3") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+- pkg_cv_LUA_CFLAGS=`$PKG_CONFIG --cflags "lua5.3" 2>/dev/null`
++ pkg_cv_LUA_CFLAGS=`$PKG_CONFIG --cflags "lua-5.3" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -11772,12 +11772,12 @@
+ pkg_cv_LUA_LIBS="$LUA_LIBS"
+ else
+ if test -n "$PKG_CONFIG" && \
+- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua5.3\""; } >&5
+- ($PKG_CONFIG --exists --print-errors "lua5.3") 2>&5
++ { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"lua-5.3\""; } >&5
++ ($PKG_CONFIG --exists --print-errors "lua-5.3") 2>&5
+ ac_status=$?
+ $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
+ test $ac_status = 0; }; then
+- pkg_cv_LUA_LIBS=`$PKG_CONFIG --libs "lua5.3" 2>/dev/null`
++ pkg_cv_LUA_LIBS=`$PKG_CONFIG --libs "lua-5.3" 2>/dev/null`
+ else
+ pkg_failed=yes
+ fi
+@@ -11796,9 +11796,9 @@
+ _pkg_short_errors_supported=no
+ fi
+ if test $_pkg_short_errors_supported = yes; then
+- LUA_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "lua5.3"`
++ LUA_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "lua-5.3"`
+ else
+- LUA_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "lua5.3"`
++ LUA_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "lua-5.3"`
+ fi
+ # Put the nasty error message in config.log where it belongs
+ echo "$LUA_PKG_ERRORS" >&5
+@@ -12247,7 +12247,7 @@
+ LUA_LIBS=$pkg_cv_LUA_LIBS
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
+ $as_echo "yes" >&6; }
+- LUA=lua5.3
++ LUA=lua53
+ fi
+ else
+ LUA_CFLAGS=$pkg_cv_LUA_CFLAGS
+@@ -12290,7 +12290,7 @@
+ return 0;
+ }
+ _ACEOF
+-for ac_lib in '' lua lua5.3 lua5.2 lua5.1; do
++for ac_lib in '' lua lua53 lua5.2 lua5.1; do
+ if test -z "$ac_lib"; then
+ ac_res="none required"
+ else
diff --git a/math/gnuplot/files/patch-docs-Makefile.in b/math/gnuplot/files/patch-docs-Makefile.in
index e509815ac6bc..e74d90814353 100644
--- a/math/gnuplot/files/patch-docs-Makefile.in
+++ b/math/gnuplot/files/patch-docs-Makefile.in
@@ -1,6 +1,15 @@
---- docs/Makefile.in.orig 2016-10-09 17:24:51 UTC
-+++ docs/Makefile.in
-@@ -927,15 +927,15 @@ groff: grotxt grodvi grops
+--- docs/Makefile.in.orig 2017-11-06 10:23:52.000000000 -0800
++++ docs/Makefile.in 2017-11-23 12:14:18.710252000 -0800
+@@ -907,7 +907,7 @@
+ $(GNUPLOT_EXE):
+ ( cd ../src ; $(MAKE) gnuplot$(EXEEXT) )
+ @BUILD_LUA_TRUE@$(LUA_HELP): $(top_srcdir)/term/lua/gnuplot-tikz.lua
+-@BUILD_LUA_TRUE@ $(AM_V_GEN) $(LUA) $< termhelp > $@
++@BUILD_LUA_TRUE@ $(AM_V_GEN) $(LUA) $(top_srcdir)/term/lua/gnuplot-tikz.lua termhelp > $@
+
+ allterm.h: $(CORETERM) $(LUA_HELP)
+ $(AM_V_GEN) for e in `egrep "^[ ]*START_HELP" $(CORETERM) |\
+@@ -933,15 +933,15 @@
grotxt: gnuplot.txt
gnuplot.txt: gnuplot.ms $(srcdir)/titlepag.ms
@@ -19,17 +28,3 @@
### doc2xxx dependencies
gnuplot.ms: doc2ms$(EXEEXT) $(srcdir)/gnuplot.doc
-@@ -1077,11 +1077,11 @@ wxhelp/wgnuplot.html: doc2wxhtml$(EXEEXT
- $(AM_V_GEN) ./doc2wxhtml$(EXEEXT) $(srcdir)/gnuplot.doc wxhelp/
-
- doc2wxhtml$(EXEEXT): wxhelp/doc2html.o termdoc.o xref.o $(SRC_VERSION_O)
-- $(AM_V_CCLD) $(LINK) $^
-+ $(AM_V_CCLD) $(LINK) wxhelp/doc2html.o termdoc.o xref.o $(SRC_VERSION_O)
-
- wxhelp/doc2html.o: $(srcdir)/windows/doc2html.c $(BUILT_SOURCES)
- $(AM_V_AT)[ -d wxhelp ] || mkdir wxhelp
-- $(AM_V_CC) $(COMPILE) -c -o $@ -I.. -DALL_TERM_DOC -DWXHELP $<
-+ $(AM_V_CC) $(COMPILE) -c -o $@ -I.. -DALL_TERM_DOC -DWXHELP $(srcdir)/windows/doc2html.c
-
- # HBB FIXME 2015-06-28: this is how the above really should be handled, but it causes
- # problems with the way automake handles its 'subdir-objects' option.
diff --git a/math/gnuplot/files/patch-src-command.c b/math/gnuplot/files/patch-src-command.c
new file mode 100644
index 000000000000..1f55428c3b1c
--- /dev/null
+++ b/math/gnuplot/files/patch-src-command.c
@@ -0,0 +1,10 @@
+--- src/command.c.orig 2017-11-01 18:12:31.201708000 -0700
++++ src/command.c 2017-11-01 18:13:03.695758000 -0700
+@@ -119,6 +119,7 @@
+
+ #ifndef _Windows
+ # include "help.h"
++# include <sys/wait.h>
+ #endif /* _Windows */
+
+ #ifdef _Windows
diff --git a/math/gnuplot/pkg-plist b/math/gnuplot/pkg-plist
index 7ff700bad8be..260c83e124d9 100644
--- a/math/gnuplot/pkg-plist
+++ b/math/gnuplot/pkg-plist
@@ -1,40 +1,40 @@
bin/gnuplot
-%%X11%%libexec/gnuplot/5.0/gnuplot_x11
+libexec/gnuplot/5.2/gnuplot_x11
man/man1/gnuplot-ja.1.gz
man/man1/gnuplot.1.gz
-%%DATADIR%%/5.0/PostScript/8859-1.ps
-%%DATADIR%%/5.0/PostScript/8859-15.ps
-%%DATADIR%%/5.0/PostScript/8859-2.ps
-%%DATADIR%%/5.0/PostScript/8859-9.ps
-%%DATADIR%%/5.0/PostScript/aglfn.txt
-%%DATADIR%%/5.0/PostScript/cp1250.ps
-%%DATADIR%%/5.0/PostScript/cp1251.ps
-%%DATADIR%%/5.0/PostScript/cp1252.ps
-%%DATADIR%%/5.0/PostScript/cp437.ps
-%%DATADIR%%/5.0/PostScript/cp850.ps
-%%DATADIR%%/5.0/PostScript/cp852.ps
-%%DATADIR%%/5.0/PostScript/koi8r.ps
-%%DATADIR%%/5.0/PostScript/koi8u.ps
-%%DATADIR%%/5.0/PostScript/prologue.ps
-%%DATADIR%%/5.0/PostScript/utf-8.ps
-%%X11%%%%DATADIR%%/5.0/app-defaults/Gnuplot
-%%DATADIR%%/5.0/colors_default.gp
-%%DATADIR%%/5.0/colors_mono.gp
-%%DATADIR%%/5.0/colors_podo.gp
-%%DATADIR%%/5.0/gnuplot.gih
-@sample %%DATADIR%%/5.0/gnuplotrc.sample
-%%DATADIR%%/5.0/js/README
-%%DATADIR%%/5.0/js/canvasmath.js
-%%DATADIR%%/5.0/js/canvastext.js
-%%DATADIR%%/5.0/js/gnuplot_common.js
-%%DATADIR%%/5.0/js/gnuplot_dashedlines.js
-%%DATADIR%%/5.0/js/gnuplot_mouse.css
-%%DATADIR%%/5.0/js/gnuplot_mouse.js
-%%DATADIR%%/5.0/js/gnuplot_svg.js
-%%DATADIR%%/5.0/js/grid.png
-%%DATADIR%%/5.0/js/help.png
-%%DATADIR%%/5.0/js/nextzoom.png
-%%DATADIR%%/5.0/js/previouszoom.png
-%%DATADIR%%/5.0/js/return.png
-%%DATADIR%%/5.0/js/textzoom.png
-%%DATADIR%%/5.0/lua/gnuplot-tikz.lua
+%%DATADIR%%/5.2/PostScript/8859-1.ps
+%%DATADIR%%/5.2/PostScript/8859-15.ps
+%%DATADIR%%/5.2/PostScript/8859-2.ps
+%%DATADIR%%/5.2/PostScript/8859-9.ps
+%%DATADIR%%/5.2/PostScript/aglfn.txt
+%%DATADIR%%/5.2/PostScript/cp1250.ps
+%%DATADIR%%/5.2/PostScript/cp1251.ps
+%%DATADIR%%/5.2/PostScript/cp1252.ps
+%%DATADIR%%/5.2/PostScript/cp437.ps
+%%DATADIR%%/5.2/PostScript/cp850.ps
+%%DATADIR%%/5.2/PostScript/cp852.ps
+%%DATADIR%%/5.2/PostScript/koi8r.ps
+%%DATADIR%%/5.2/PostScript/koi8u.ps
+%%DATADIR%%/5.2/PostScript/prologue.ps
+%%DATADIR%%/5.2/PostScript/utf-8.ps
+%%DATADIR%%/5.2/app-defaults/Gnuplot
+%%DATADIR%%/5.2/colors_default.gp
+%%DATADIR%%/5.2/colors_mono.gp
+%%DATADIR%%/5.2/colors_podo.gp
+%%DATADIR%%/5.2/gnuplot.gih
+@sample %%DATADIR%%/5.2/gnuplotrc.sample
+%%DATADIR%%/5.2/js/README
+%%DATADIR%%/5.2/js/canvasmath.js
+%%DATADIR%%/5.2/js/canvastext.js
+%%DATADIR%%/5.2/js/gnuplot_common.js
+%%DATADIR%%/5.2/js/gnuplot_dashedlines.js
+%%DATADIR%%/5.2/js/gnuplot_mouse.css
+%%DATADIR%%/5.2/js/gnuplot_mouse.js
+%%DATADIR%%/5.2/js/gnuplot_svg.js
+%%DATADIR%%/5.2/js/grid.png
+%%DATADIR%%/5.2/js/help.png
+%%DATADIR%%/5.2/js/nextzoom.png
+%%DATADIR%%/5.2/js/previouszoom.png
+%%DATADIR%%/5.2/js/return.png
+%%DATADIR%%/5.2/js/textzoom.png
+%%DATADIR%%/5.2/lua/gnuplot-tikz.lua