aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
committeralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
commit7d749db4cf14f30613e9a53a08ffa3d3b4575146 (patch)
treead9062005432bbf28f5cce4ad3a1cd32a59dba69 /math
parent8e2da239f74a82ad1c98b69bd27abb3f4e40ecf3 (diff)
downloadfreebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.gz
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.zst
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Diffstat (limited to 'math')
-rw-r--r--math/biggles/Makefile1
-rw-r--r--math/gracetmpl/Makefile4
-rw-r--r--math/py-bitvector/Makefile1
-rw-r--r--math/py-gato/Makefile3
-rw-r--r--math/py-gnuplot/Makefile1
-rw-r--r--math/py-gsl/Makefile1
-rw-r--r--math/py-mpz/Makefile1
-rw-r--r--math/py-numeric/Makefile2
-rw-r--r--math/py-numeric17/Makefile6
-rw-r--r--math/py-probstat/Makefile1
-rw-r--r--math/py-scientific/Makefile1
-rw-r--r--math/vtk-python/Makefile1
12 files changed, 23 insertions, 0 deletions
diff --git a/math/biggles/Makefile b/math/biggles/Makefile
index 01dce83dceb2..2cdd0e2b8521 100644
--- a/math/biggles/Makefile
+++ b/math/biggles/Makefile
@@ -22,6 +22,7 @@ LIB_DEPENDS= plot:${PORTSDIR}/graphics/plotutils
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= python2-biggles
USE_LDCONFIG= yes
post-patch:
diff --git a/math/gracetmpl/Makefile b/math/gracetmpl/Makefile
index 903ab6e2b613..239d174eb1bb 100644
--- a/math/gracetmpl/Makefile
+++ b/math/gracetmpl/Makefile
@@ -34,6 +34,10 @@ MAKE_ARGS= PREFIX="${PREFIX}" \
ALL_TARGET= all pythonwrap
INSTALL_TARGET= install pythonwrap_install
+INSTALLS_EGGINFO= yes
+PYDISTUTILS_PKGNAME= graceTMPL
+PYDISTUTILS_EGGINFODIR= ${PYTHON_SITELIBDIR}/graceTMPL
+
post-extract:
@${ECHO_CMD} -n > ${WRKSRC}/Makefile.defs
diff --git a/math/py-bitvector/Makefile b/math/py-bitvector/Makefile
index e4b2eccad81a..9ca0e5eea122 100644
--- a/math/py-bitvector/Makefile
+++ b/math/py-bitvector/Makefile
@@ -18,6 +18,7 @@ COMMENT= A pure-Python memory-efficient packed representation for bit arrays
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= BitVector
PLIST_FILES= %%PYTHON_SITELIBDIR%%/BitVector.py \
%%PYTHON_SITELIBDIR%%/BitVector.pyc \
diff --git a/math/py-gato/Makefile b/math/py-gato/Makefile
index 791a5b7f6790..d4acdc123fe0 100644
--- a/math/py-gato/Makefile
+++ b/math/py-gato/Makefile
@@ -24,6 +24,9 @@ WRKSRC= ${WRKDIR}/Gato
GATO_DIR= ${PREFIX}/lib/${PYTHON_VERSION}/site-packages/Gato
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
+post-patch:
+ @ ${REINPLACE_CMD} -e 's,^.*__future__.*$$,,' ${WRKSRC}/DataStructures.py
+
pre-build:
@ ${TOUCH} ${WRKSRC}/__init__.py
diff --git a/math/py-gnuplot/Makefile b/math/py-gnuplot/Makefile
index 6dbdfb191fee..f4781f2f64db 100644
--- a/math/py-gnuplot/Makefile
+++ b/math/py-gnuplot/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS= gnuplot:${PORTSDIR}/math/gnuplot \
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= gnuplot-py
post-install:
.if !defined(NOPORTDOCS)
diff --git a/math/py-gsl/Makefile b/math/py-gsl/Makefile
index 7ba44612f8bb..404bfc3e25fe 100644
--- a/math/py-gsl/Makefile
+++ b/math/py-gsl/Makefile
@@ -25,5 +25,6 @@ LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= pygsl
.include <bsd.port.mk>
diff --git a/math/py-mpz/Makefile b/math/py-mpz/Makefile
index 10da01e33334..51e736f15c06 100644
--- a/math/py-mpz/Makefile
+++ b/math/py-mpz/Makefile
@@ -24,6 +24,7 @@ PLIST_FILES= lib/%%PYTHON_VERSION%%/site-packages/mpz.so
DIST_SUBDIR= python
USE_PYTHON= -2.3
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGVERSION= 0.0.0
WRKSRC= ${PYTHON_WRKSRC}/Modules
MD5_FILE= ${PORTSDIR}/lang/python/distinfo
diff --git a/math/py-numeric/Makefile b/math/py-numeric/Makefile
index 4e04b77be2c8..e7a2d3e89db1 100644
--- a/math/py-numeric/Makefile
+++ b/math/py-numeric/Makefile
@@ -21,6 +21,8 @@ COMMENT= The Numeric Extension to Python
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= Numeric
+PYDISTUTILS_EGGINFODIR= ${PYTHONPREFIX_SITELIBDIR}/Numeric
WRKSRC= ${WRKDIR}/Numeric-${PORTVERSION}
diff --git a/math/py-numeric17/Makefile b/math/py-numeric17/Makefile
index 968f8b248a19..83a67834e55b 100644
--- a/math/py-numeric17/Makefile
+++ b/math/py-numeric17/Makefile
@@ -18,6 +18,12 @@ COMMENT= The Numeric Extension to Python
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PYDISTUTILS_EGGINFO= Numeric/Numeric-0.0.0-py${PYTHON_VER}.egg-info \
+ Numeric/Numeric-${PORTVERSION}-py${PYTHON_VER}.egg-info \
+ RNG-3.0-py${PYTHON_VER}.egg-info \
+ MA-4.1.0-py${PYTHON_VER}.egg-info \
+ FFTPACK-1.0-py${PYTHON_VER}.egg-info
+
PYSETUP= setup_all.py
NO_LATEST_LINK= yes
diff --git a/math/py-probstat/Makefile b/math/py-probstat/Makefile
index 1864c43e6afc..753f6c3b0e40 100644
--- a/math/py-probstat/Makefile
+++ b/math/py-probstat/Makefile
@@ -22,5 +22,6 @@ PLIST_FILES= %%PYTHON_SITELIBDIR%%/probstat.so
PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGVERSION= 0.9
.include <bsd.port.mk>
diff --git a/math/py-scientific/Makefile b/math/py-scientific/Makefile
index 13d568aed54c..a14a075ee3b5 100644
--- a/math/py-scientific/Makefile
+++ b/math/py-scientific/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS= ${PYNUMERIC}
USE_PYTHON= yes
USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= ScientificPython
DOCDIR= ${PREFIX}/share/doc/py-scientific
EXAMPLEDIR= ${PREFIX}/share/examples/py-scientific
diff --git a/math/vtk-python/Makefile b/math/vtk-python/Makefile
index e08e7c04b1c3..0785d527de95 100644
--- a/math/vtk-python/Makefile
+++ b/math/vtk-python/Makefile
@@ -39,6 +39,7 @@ CMAKE_DEFS= -DVTK_WRAP_PYTHON:BOOL=ON \
-DEXPAT_INCLUDE_DIR:PATH=${LOCALBASE}/include \
-DCMAKE_BACKWARDS_COMPATIBILITY:STRING=2.2
+EXTRA_PATCHES+= ${.CURDIR}/files/extra-patch-Common-vtkPythonUtil.cxx
PLIST_SUB+= VTK_PTH_LOCATION_DIR=${PYTHON_SITELIBDIR}
.include "${MASTERDIR}/Makefile"