aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-11 16:40:15 +0800
committermaho <maho@FreeBSD.org>2007-01-11 16:40:15 +0800
commit82c92b9d6d0a8d4cd71e9e84802724123c3e5b5e (patch)
treef1075bdbd6c1e9ffbdfceb4d17898b019bcf0cfe /math
parentd69629158a933676d2641db78bf35ac41bad7725 (diff)
downloadfreebsd-ports-gnome-82c92b9d6d0a8d4cd71e9e84802724123c3e5b5e.tar.gz
freebsd-ports-gnome-82c92b9d6d0a8d4cd71e9e84802724123c3e5b5e.tar.zst
freebsd-ports-gnome-82c92b9d6d0a8d4cd71e9e84802724123c3e5b5e.zip
* Migrate to gfortran.
* bump portrevision.
Diffstat (limited to 'math')
-rw-r--r--math/fftw/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/math/fftw/Makefile b/math/fftw/Makefile
index 15b0f5db68e8..8de499bc6b2c 100644
--- a/math/fftw/Makefile
+++ b/math/fftw/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fftw
PORTVERSION= 2.1.5
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES= math
MASTER_SITES= ftp://ftp.fftw.org/pub/fftw/ \
ftp://ftp.fftw.org/pub/fftw/old/ \
@@ -22,10 +22,14 @@ COMMENT?= Fast C routines to compute the Discrete Fourier Transform
FFTW_FLAVOR?= default
FFTW_SUFIX=
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
+CONFIGURE_ENV= MAKEINFO="makeinfo --no-split" FC="${FC}" F77="${F77}"
CONFIGURE_ARGS= --enable-shared
USE_LDCONFIG= yes
PLIST_SUB= FFTW_SUFX="${FFTW_SUFX}"