aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-08-28 02:58:59 +0800
committerbf <bf@FreeBSD.org>2011-08-28 02:58:59 +0800
commita959187a113c7ca61068986f129be4ab078aab75 (patch)
treed7d15a5db3918761fe5cc30c8dff1173b882241d /math
parente757de1cd54ebe7e80d9773197d504cbceee2605 (diff)
downloadfreebsd-ports-gnome-a959187a113c7ca61068986f129be4ab078aab75.tar.gz
freebsd-ports-gnome-a959187a113c7ca61068986f129be4ab078aab75.tar.zst
freebsd-ports-gnome-a959187a113c7ca61068986f129be4ab078aab75.zip
- narrow the scope of BROKEN: the build problems were caused by
the update of devel/pcre to version 8.13 - use the bundled pcre by default
Diffstat (limited to 'math')
-rw-r--r--math/R/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index 49dee5d31690..63d654930914 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -8,6 +8,7 @@
PORTNAME?= R
PORTVERSION= 2.13.1
+PORTREVISION= 1
CATEGORIES= math lang
MASTER_SITES= http://cran.r-project.org/src/base/R-2/ \
ftp://cran.r-project.org/pub/R/src/base/R-2/ \
@@ -31,8 +32,6 @@ DISTNAME= R-${PORTVERSION}
MAINTAINER= bf@FreeBSD.org
COMMENT?= A language for statistical computing and graphics
-BROKEN= fails to package
-
.if defined(LIBRMATH_SLAVEPORT)
BUILD_WRKSRC= ${WRKSRC}/src/nmath/standalone
CONFIGURE_ARGS = --disable-nls --with-ICU=no --with-cairo=no --with-iconv=no \
@@ -51,7 +50,7 @@ CONFIGURE_ENV= FCFLAGS="${FFLAGS}" \
OPTIONS= ATLAS "Use ATLAS instead of BLAS/LAPACK" off \
ICU "Improve collation in multibyte locales with ICU" on \
NLS "Build with NLS support" on \
- PCRE_PORT "Use PCRE port instead of bundled source" on \
+ PCRE_PORT "Use PCRE port instead of bundled source" off \
THREADS "Build a multithreaded R" on
.if !defined(LIBR_SLAVEPORT)
OPTIONS+= GHOSTSCRIPT "Enable the [dev2]bitmap() graphics devices" on \
@@ -131,6 +130,7 @@ PLIST_SUB+= NLS="@comment "
.if defined(WITHOUT_PCRE_PORT)
CONFIGURE_ARGS+= --without-system-pcre
.else
+BROKEN = WITH_PCRE_PORT breaks document generation with pcre 8.13
LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
CONFIGURE_ARGS+= --with-system-pcre
.endif