aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2005-11-13 23:35:04 +0800
committerarved <arved@FreeBSD.org>2005-11-13 23:35:04 +0800
commita9b0bff0da930a083fe9a2f1c6606e07f3c8b364 (patch)
treeedb6f53c1fcf330bec8238cce59391cf5e7f8b17 /math
parent7d6ce5c1e8aa3157257f956ca5f15a575788af3e (diff)
downloadfreebsd-ports-gnome-a9b0bff0da930a083fe9a2f1c6606e07f3c8b364.tar.gz
freebsd-ports-gnome-a9b0bff0da930a083fe9a2f1c6606e07f3c8b364.tar.zst
freebsd-ports-gnome-a9b0bff0da930a083fe9a2f1c6606e07f3c8b364.zip
Fix build on FreeBSD7
Diffstat (limited to 'math')
-rw-r--r--math/py-matplotlib/Makefile4
-rw-r--r--math/py-matplotlib/files/patch-setupext.py18
2 files changed, 15 insertions, 7 deletions
diff --git a/math/py-matplotlib/Makefile b/math/py-matplotlib/Makefile
index ec006817aa85..0bd7ec1c2e02 100644
--- a/math/py-matplotlib/Makefile
+++ b/math/py-matplotlib/Makefile
@@ -48,10 +48,6 @@ PLISTDIR+= ${EXAMPLESDIR}
USE_GCC= 3.4
.endif
-.if ${OSVERSION} >= 700000
-BROKEN= "Does not build on FreeBSD >= 7.0"
-.endif
-
post-patch:
@${GREP} -lR "share/matplotlib" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} \
-e "s,share/matplotlib,share/py-matplotlib,g"
diff --git a/math/py-matplotlib/files/patch-setupext.py b/math/py-matplotlib/files/patch-setupext.py
index 0030563cf3da..abf177dac2e4 100644
--- a/math/py-matplotlib/files/patch-setupext.py
+++ b/math/py-matplotlib/files/patch-setupext.py
@@ -1,6 +1,18 @@
---- setupext.py.orig Tue Apr 12 16:09:32 2005
-+++ setupext.py Tue Apr 12 16:10:28 2005
-@@ -308,7 +308,7 @@
+--- setupext.py.orig Tue Mar 29 19:25:37 2005
++++ setupext.py Sat Nov 5 20:26:49 2005
+@@ -38,7 +38,8 @@
+ 'darwin' : ['/usr/local', '/usr', '/sw', '/usr/X11R6'],
+ 'freebsd4' : ['/usr/local', '/usr'],
+ 'freebsd5' : ['/usr/local', '/usr'],
+- 'freebsd6' : ['/usr/local', '/usr'],
++ 'freebsd6' : ['/usr/local', '/usr'],
++ 'freebsd7' : ['/usr/local', '/usr'],
+ 'sunos5' : [os.getenv('MPLIB_BASE') or '/usr/local',],
+ }
+
+@@ -306,9 +307,9 @@
+
+ # you're still here? ok we'll try it this way
o = find_tcltk() # todo: try/except
- module.include_dirs.extend([o.tcl_inc, o.tk_inc])
+ module.include_dirs.extend(["/usr/local/include/tcl8.4", "/usr/local/include/tk8.4"])