aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2002-10-25 16:32:12 +0800
committerkris <kris@FreeBSD.org>2002-10-25 16:32:12 +0800
commitb0134cc26038d400fa00e5ecdc30eab2b9dc30ce (patch)
tree14d80c7fbc2628ad9878838e7c755947e6b89049 /math
parentba21d9acb2504ddcd64075b6b8c97548cf9e7e69 (diff)
downloadfreebsd-ports-gnome-b0134cc26038d400fa00e5ecdc30eab2b9dc30ce.tar.gz
freebsd-ports-gnome-b0134cc26038d400fa00e5ecdc30eab2b9dc30ce.tar.zst
freebsd-ports-gnome-b0134cc26038d400fa00e5ecdc30eab2b9dc30ce.zip
Remove #include <values.h> to partially fix build on -current (still
badly broken). Mark BROKEN on 5.x.
Diffstat (limited to 'math')
-rw-r--r--math/linalg/Makefile8
-rw-r--r--math/linalg/files/patch-ab11
2 files changed, 18 insertions, 1 deletions
diff --git a/math/linalg/Makefile b/math/linalg/Makefile
index e4a25153f7ed..f0f89d583117 100644
--- a/math/linalg/Makefile
+++ b/math/linalg/Makefile
@@ -18,6 +18,12 @@ ALL_TARGET= lib
INSTALL_TARGET= lib
USE_GMAKE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 500035
+BROKEN= "Does not compile under 5.x"
+.endif
+
post-patch:
@( cd ${WRKSRC}; ${SED} -e 's|%%CXXFLAGS%%|${CXXFLAGS}|g' \
-e 's|%%CXX%%|${CXX}|g' c++ > c++.sed; mv c++.sed c++; ${CHMOD} +x c++ )
@@ -38,4 +44,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/LinAlg
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/linalg/files/patch-ab b/math/linalg/files/patch-ab
new file mode 100644
index 000000000000..418af0efe021
--- /dev/null
+++ b/math/linalg/files/patch-ab
@@ -0,0 +1,11 @@
+--- LinAlg.h.orig Fri Oct 25 01:30:42 2002
++++ LinAlg.h Fri Oct 25 01:30:53 2002
+@@ -73,7 +73,7 @@
+
+ #include "myenv.h"
+ #include "std.h"
+-#if defined(__GNUC__) && __GNUC_MINOR__ < 90
++#if defined(__GNUC__) && __GNUC_MINOR__ < 90 && !defined(__FreeBSD__)
+ #include <values.h>
+ #else
+ #include <limits.h>