aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2007-04-14 14:19:59 +0800
committerglewis <glewis@FreeBSD.org>2007-04-14 14:19:59 +0800
commitb3b1bc09e882af5fae1be01d4ef37697df0bab31 (patch)
treef870f1910d745c75ead53faafa16e01b1d912f6b /math
parentea405c5e6f34915e7f4355923e8dd4deac5ad250 (diff)
downloadfreebsd-ports-gnome-b3b1bc09e882af5fae1be01d4ef37697df0bab31.tar.gz
freebsd-ports-gnome-b3b1bc09e882af5fae1be01d4ef37697df0bab31.tar.zst
freebsd-ports-gnome-b3b1bc09e882af5fae1be01d4ef37697df0bab31.zip
. Since we're depending on teTeX-base anyway, add --with-kpsexpand to
CONFIGURE_ARGS. . Add support for plotutils. This is based on the diffs in the referenced PR, but is done somewhat differently and the merge isn't complete (yet). PR: 111548 Submitted by: bf<bf2006a@yahoo.com>
Diffstat (limited to 'math')
-rw-r--r--math/gnuplot/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/math/gnuplot/Makefile b/math/gnuplot/Makefile
index 7c4ca65ca6cb..72f76f7ff231 100644
--- a/math/gnuplot/Makefile
+++ b/math/gnuplot/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnuplot
PORTVERSION= 4.2.0
+PORTREVISION= 1
CATEGORIES= math graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,16 +17,18 @@ COMMENT= A command-driven interactive function plotting program
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ARGS= --without-tutorial \
- --without-linux-vga \
+CONFIGURE_ARGS= --with-kpsexpand \
--with-lasergnu \
+ --with-readline=gnu \
+ --without-linux-vga \
--without-lisp-files \
- --with-readline=gnu
+ --without-tutorial
BUILD_DEPENDS+=latex:${PORTSDIR}/print/teTeX-base
OPTIONS= GD "Enable GD support" on \
- PDF "Enable PDF support" on
+ PDF "Enable PDF support" on \
+ PLOT "Enable plot support" on
MAN1= gnuplot.1 lasergnu.1
INFO= gnuplot
@@ -52,6 +55,13 @@ LIB_DEPENDS+= pdf.8:${PORTSDIR}/print/pdflib
CONFIGURE_ARGS+= --with-pdf=${LOCALBASE}
.endif
+.if defined(WITHOUT_PLOT)
+CONFIGURE_ARGS+= --without-plot
+.else
+LIB_DEPENDS+= plot.4:${PORTSDIR}/graphics/plotutils
+CONFIGURE_ARGS+= --with-plot=${LOCALBASE}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
's|)/@PACKAGE@/@PKG_MAJOR@|)|g' ${WRKSRC}/src/Makefile.in