aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-03-12 04:35:25 +0800
committerpav <pav@FreeBSD.org>2005-03-12 04:35:25 +0800
commitb883dd3b1bbab5cfc83b5276821d3fe5b14d207f (patch)
treee81cc8ad2947e666be7e616a42e5ab192b9bd7ae /math
parent92e2e71cee671410a1c28b91f043a0573c289b17 (diff)
downloadfreebsd-ports-gnome-b883dd3b1bbab5cfc83b5276821d3fe5b14d207f.tar.gz
freebsd-ports-gnome-b883dd3b1bbab5cfc83b5276821d3fe5b14d207f.tar.zst
freebsd-ports-gnome-b883dd3b1bbab5cfc83b5276821d3fe5b14d207f.zip
PEAR::Structures_Graph is a package for creating and manipulating graph
datastructures. It allows building of directed and undirected graphs, with data and metadata stored in nodes. The library provides functions for graph traversing as well as for characteristic extraction from the graph topology. PR: ports/78624 Submitted by: Antonio Carlos Venancio Junior <antonio@php.net>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/pear-Structures_Graph/Makefile29
-rw-r--r--math/pear-Structures_Graph/distinfo2
-rw-r--r--math/pear-Structures_Graph/pkg-descr6
4 files changed, 38 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 1fac1c463a82..49249db056ff 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -181,6 +181,7 @@
SUBDIR += pari
SUBDIR += pari-devel
SUBDIR += parmetis
+ SUBDIR += pear-Structures_Graph
SUBDIR += petsc
SUBDIR += petsc-mpich
SUBDIR += php4-bcmath
diff --git a/math/pear-Structures_Graph/Makefile b/math/pear-Structures_Graph/Makefile
new file mode 100644
index 000000000000..ca84cafa65ec
--- /dev/null
+++ b/math/pear-Structures_Graph/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: pear-Structures_Graph
+# Date created: 09 March 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Structures_Graph
+PORTVERSION= 1.0.1
+CATEGORIES= math devel pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR graph datastructure manipulation library
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Structures
+FILES= Graph/Manipulator/TopologicalSorter.php \
+ Graph/Manipulator/AcyclicTest.php Graph/Node.php Graph.php
+DOCS= Structures_Graph.pkg
+_DOCSDIR= docs/tutorials/Structures_Graph
+
+post-extract:
+ @${MV} ${WRKSRC}/Structures/* ${WRKSRC}/
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/math/pear-Structures_Graph/distinfo b/math/pear-Structures_Graph/distinfo
new file mode 100644
index 000000000000..0a9a36e79b31
--- /dev/null
+++ b/math/pear-Structures_Graph/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Structures_Graph-1.0.1.tgz) = 97baf9bf892a6a54213d193767f97a09
+SIZE (PEAR/Structures_Graph-1.0.1.tgz) = 7060
diff --git a/math/pear-Structures_Graph/pkg-descr b/math/pear-Structures_Graph/pkg-descr
new file mode 100644
index 000000000000..82fcd07111d6
--- /dev/null
+++ b/math/pear-Structures_Graph/pkg-descr
@@ -0,0 +1,6 @@
+PEAR::Structures_Graph is a package for creating and manipulating graph
+datastructures. It allows building of directed and undirected graphs, with
+data and metadata stored in nodes. The library provides functions for graph
+traversing as well as for characteristic extraction from the graph topology.
+
+WWW: http://pear.php.net/package/Structures_Graph/