aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2016-11-19 04:57:51 +0800
committerthierry <thierry@FreeBSD.org>2016-11-19 04:57:51 +0800
commitc0cd55e9ad45b0e36201b14bd958bfaf2a4fa3d5 (patch)
tree39f8b46b886d87b948691fb3b6cee7e664a1b35c /math
parent0c91f83ccd9ea51e9855c55876379ab671533138 (diff)
downloadfreebsd-ports-gnome-c0cd55e9ad45b0e36201b14bd958bfaf2a4fa3d5.tar.gz
freebsd-ports-gnome-c0cd55e9ad45b0e36201b14bd958bfaf2a4fa3d5.tar.zst
freebsd-ports-gnome-c0cd55e9ad45b0e36201b14bd958bfaf2a4fa3d5.zip
- Simplify Makefile with USE=qmake
- Since I'm there fix USE_GL. PR: 214627 Submitted by: tcberner
Diffstat (limited to 'math')
-rw-r--r--math/mathmod/Makefile10
-rw-r--r--math/mathmod/files/patch-MathMod.pro15
2 files changed, 16 insertions, 9 deletions
diff --git a/math/mathmod/Makefile b/math/mathmod/Makefile
index 23f02b1e7194..3b8072b9fc88 100644
--- a/math/mathmod/Makefile
+++ b/math/mathmod/Makefile
@@ -12,8 +12,8 @@ COMMENT= Mathematical modeling software
LICENSE= GPLv2
-USES= dos2unix zip
-USE_GL= yes
+USES= dos2unix qmake zip
+USE_GL= gl
USE_QT5= buildtools_build core gui opengl qmake_build widgets
BRANCHE= 246
@@ -24,10 +24,4 @@ PLIST_FILES= bin/MathMod
# LL / ULL suffix would be needed for integer constants
BROKEN_FreeBSD_9_i386= YES
-pre-build:
- cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${QMAKE}
-
-post-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/ARGET/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
-
.include <bsd.port.mk>
diff --git a/math/mathmod/files/patch-MathMod.pro b/math/mathmod/files/patch-MathMod.pro
index a74e07fc4ead..69e13655a816 100644
--- a/math/mathmod/files/patch-MathMod.pro
+++ b/math/mathmod/files/patch-MathMod.pro
@@ -1,4 +1,4 @@
---- MathMod.pro.orig 2016-03-03 21:15:56 UTC
+--- MathMod.pro.orig 2016-11-18 12:53:17 UTC
+++ MathMod.pro
@@ -58,7 +58,6 @@ FORMS = ui_forms/drawingoptions.ui \
@@ -8,3 +8,16 @@
QT += opengl widgets
OTHER_FILES += \
+@@ -67,10 +66,10 @@ OTHER_FILES += \
+ mathmodconfig.js
+
+ # install
+-target.path = $TARGET
++target.path = $$INSTALL_ROOT/$$PREFIX/bin/
+ sources.files = $$SOURCES $$HEADERS $$RESOURCES $$FORMS mathmod.pro
+ sources.path = $TARGET
+-INSTALLS += target sources
++INSTALLS += target
+
+ DISTFILES += \
+ advancedmodels.js