aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>1999-07-05 05:18:17 +0800
committersteve <steve@FreeBSD.org>1999-07-05 05:18:17 +0800
commitc49aacd72fe5a56d8492dee554b9c4af778eb8ea (patch)
tree7d4f36d196ef96a34204aec52cd1ddf039121039 /math
parentaece62b1cb9a3bc77a520dca1875e0e179fe0e74 (diff)
downloadfreebsd-ports-gnome-c49aacd72fe5a56d8492dee554b9c4af778eb8ea.tar.gz
freebsd-ports-gnome-c49aacd72fe5a56d8492dee554b9c4af778eb8ea.tar.zst
freebsd-ports-gnome-c49aacd72fe5a56d8492dee554b9c4af778eb8ea.zip
Call ldconfig correctly so this has a fighting chance of working for
both ELF and a.out builds.
Diffstat (limited to 'math')
-rw-r--r--math/librandlib/Makefile4
-rw-r--r--math/libranlib/Makefile4
-rw-r--r--math/randlib/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/math/librandlib/Makefile b/math/librandlib/Makefile
index 427dbe91cabf..9d60f6e96c7e 100644
--- a/math/librandlib/Makefile
+++ b/math/librandlib/Makefile
@@ -3,7 +3,7 @@
# Date created: 06 April 1997
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.3 1998/10/26 07:45:01 asami Exp $
+# $Id: Makefile,v 1.4 1998/11/14 09:43:24 asami Exp $
#
DISTNAME= ranlib.c
@@ -28,6 +28,6 @@ post-install:
.if ${PORTOBJFORMAT} == "aout"
${LN} -sf libranlib.so.1.0 ${PREFIX}/lib/libranlib.so
.endif
- @${LDCONFIG} -m ${PREFIX}/lib
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.post.mk>
diff --git a/math/libranlib/Makefile b/math/libranlib/Makefile
index 427dbe91cabf..9d60f6e96c7e 100644
--- a/math/libranlib/Makefile
+++ b/math/libranlib/Makefile
@@ -3,7 +3,7 @@
# Date created: 06 April 1997
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.3 1998/10/26 07:45:01 asami Exp $
+# $Id: Makefile,v 1.4 1998/11/14 09:43:24 asami Exp $
#
DISTNAME= ranlib.c
@@ -28,6 +28,6 @@ post-install:
.if ${PORTOBJFORMAT} == "aout"
${LN} -sf libranlib.so.1.0 ${PREFIX}/lib/libranlib.so
.endif
- @${LDCONFIG} -m ${PREFIX}/lib
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.post.mk>
diff --git a/math/randlib/Makefile b/math/randlib/Makefile
index 427dbe91cabf..9d60f6e96c7e 100644
--- a/math/randlib/Makefile
+++ b/math/randlib/Makefile
@@ -3,7 +3,7 @@
# Date created: 06 April 1997
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.3 1998/10/26 07:45:01 asami Exp $
+# $Id: Makefile,v 1.4 1998/11/14 09:43:24 asami Exp $
#
DISTNAME= ranlib.c
@@ -28,6 +28,6 @@ post-install:
.if ${PORTOBJFORMAT} == "aout"
${LN} -sf libranlib.so.1.0 ${PREFIX}/lib/libranlib.so
.endif
- @${LDCONFIG} -m ${PREFIX}/lib
+ @${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.include <bsd.port.post.mk>