aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2001-09-18 05:47:14 +0800
committertobez <tobez@FreeBSD.org>2001-09-18 05:47:14 +0800
commitcd902c1f6ca5f73f89978b60dc523496599a55e7 (patch)
treeb277ccae98016b8cb19d8dc56f8f7465cdea2dc4 /math
parent7fa5cb25ace571c43c5f361120e2896f6324a0c2 (diff)
downloadfreebsd-ports-gnome-cd902c1f6ca5f73f89978b60dc523496599a55e7.tar.gz
freebsd-ports-gnome-cd902c1f6ca5f73f89978b60dc523496599a55e7.tar.zst
freebsd-ports-gnome-cd902c1f6ca5f73f89978b60dc523496599a55e7.zip
Add p5-Math-Base85, a perl extension for base 85 numbers, as referenced
by RFC 1924.
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Base85/Makefile26
-rw-r--r--math/p5-Math-Base85/distinfo1
-rw-r--r--math/p5-Math-Base85/pkg-comment1
-rw-r--r--math/p5-Math-Base85/pkg-descr14
-rw-r--r--math/p5-Math-Base85/pkg-plist5
6 files changed, 48 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index afb42039dd70..de49fa14c323 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -63,6 +63,7 @@
SUBDIR += p5-Bit-ShiftReg
SUBDIR += p5-Bit-Vector
SUBIDR += p5-Date-Handler
+ SUBDIR += p5-Math-Base85
SUBDIR += p5-Math-Bezier
SUBDIR += p5-Math-BigIntFast
SUBDIR += p5-Math-Currency
diff --git a/math/p5-Math-Base85/Makefile b/math/p5-Math-Base85/Makefile
new file mode 100644
index 000000000000..2f80094c5f3c
--- /dev/null
+++ b/math/p5-Math-Base85/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: math/p5-Math-Base85
+# Date created: 17 Sep 2001
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Base85
+PORTVERSION= 0.1
+CATEGORIES= math perl5 converters net
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MAN3= Math::Base85.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+# workaround the bug in 5.005_03 and 5.6.0 :-(
+post-patch:
+ ${PERL} -pi -e 's|^use constant\s*(.*?)\s*=>.s*(.*)$$|sub $$1 { $$2 }|' ${WRKSRC}/Base85.pm
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Base85/distinfo b/math/p5-Math-Base85/distinfo
new file mode 100644
index 000000000000..db55fd17c58f
--- /dev/null
+++ b/math/p5-Math-Base85/distinfo
@@ -0,0 +1 @@
+MD5 (Math-Base85-0.1.tar.gz) = b5354a29f8272b8d57b7e54f0d6204da
diff --git a/math/p5-Math-Base85/pkg-comment b/math/p5-Math-Base85/pkg-comment
new file mode 100644
index 000000000000..16ac1dc49e07
--- /dev/null
+++ b/math/p5-Math-Base85/pkg-comment
@@ -0,0 +1 @@
+Perl extension for base 85 numbers, as referenced by RFC 1924
diff --git a/math/p5-Math-Base85/pkg-descr b/math/p5-Math-Base85/pkg-descr
new file mode 100644
index 000000000000..bab64ed1e24b
--- /dev/null
+++ b/math/p5-Math-Base85/pkg-descr
@@ -0,0 +1,14 @@
+RFC 1924 describes a compact, fixed-size representation of IPv6
+addresses which uses a base 85 number system. This module handles some
+of the uglier details of it.
+
+The base 85 numbers (from 0 to 84) are as follows:
+
+ 0..9 A..Z a..z ! # $ % & ( ) * + - ; < = > ? @ ^ _ ` { | } ~
+
+At the moment, there's not much in this module. But it should be
+sufficient for the purposes of RFC 1924.
+
+WWW: http://search.cpan.org/search?dist=Math::Base85
+
+-Anton
diff --git a/math/p5-Math-Base85/pkg-plist b/math/p5-Math-Base85/pkg-plist
new file mode 100644
index 000000000000..18a8d827d407
--- /dev/null
+++ b/math/p5-Math-Base85/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Base85/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Math/Base85.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Base85
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Math 2>/dev/null || true