aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2004-11-10 19:33:48 +0800
committerahze <ahze@FreeBSD.org>2004-11-10 19:33:48 +0800
commitd20ef49225fd104081d138c9f168ba7f3440528f (patch)
treeec323a60109b1c75f721fd93a21eefc5d2948deb /math
parentfb3772dd452d18b028fb08c97b94b7ad15c387b1 (diff)
downloadfreebsd-ports-gnome-d20ef49225fd104081d138c9f168ba7f3440528f.tar.gz
freebsd-ports-gnome-d20ef49225fd104081d138c9f168ba7f3440528f.tar.zst
freebsd-ports-gnome-d20ef49225fd104081d138c9f168ba7f3440528f.zip
Add slave port fftw-float
Fast C routines (Single Percision) FFTW is a C subroutine library for computing the Discrete Fourier Transform (DFT) in one or more dimensions, of both real and complex data, and of arbitrary input size. We believe that FFTW, which is free software, should become the FFT library of choice for most applications. Our benchmarks, performed on a variety of platforms, show that FFTW's performance is typically superior to that of other publicly available FFT software. Moreover, FFTW's performance is portable: the program will perform well on most architectures without modification. The FFTW package was developed at MIT by Matteo Frigo and Steven G. Johnson. Please send email to fftw@theory.lcs.mit.edu so that we can keep track of users and send you information about new releases. The latest version of FFTW, benchmarks, links, and other information can be found at the FFTW home page PR: ports/71271 Approved by: pav (co mentor)
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/fftw-float/Makefile15
2 files changed, 16 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 51e5c47a2837..87ca4eb7eedf 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -44,6 +44,7 @@
SUBDIR += fbm
SUBDIR += femlab
SUBDIR += fftw
+ SUBDIR += fftw-float
SUBDIR += fftw3
SUBDIR += fftw3-float
SUBDIR += fftw3-long
diff --git a/math/fftw-float/Makefile b/math/fftw-float/Makefile
new file mode 100644
index 000000000000..054c8ce1544d
--- /dev/null
+++ b/math/fftw-float/Makefile
@@ -0,0 +1,15 @@
+# New ports collection makefile for: fftw-float
+# Date created: 2004-09-02
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+
+COMMENT= Fast C routines (Single Percision)
+
+FFTW_FLAVOR= float
+MASTERDIR= ${.CURDIR}/../../math//fftw
+
+.include "${MASTERDIR}/Makefile"