aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2002-06-11 18:12:58 +0800
committernaddy <naddy@FreeBSD.org>2002-06-11 18:12:58 +0800
commite61474d9d0ceb46c300ad5a1d00365a79dd2be4d (patch)
treebfb19212facfbf5d1e8d1d5afa5c12a644244824 /math
parent710d4909f077dea7e43e09259fea23ac7f1d759e (diff)
downloadfreebsd-ports-gnome-e61474d9d0ceb46c300ad5a1d00365a79dd2be4d.tar.gz
freebsd-ports-gnome-e61474d9d0ceb46c300ad5a1d00365a79dd2be4d.tar.zst
freebsd-ports-gnome-e61474d9d0ceb46c300ad5a1d00365a79dd2be4d.zip
Update to 1.3.9. Notable changes in this release:
* An option for output rounding has been added.
Diffstat (limited to 'math')
-rw-r--r--math/calcoo/Makefile3
-rw-r--r--math/calcoo/distinfo2
-rw-r--r--math/calcoo/files/patch-src_c__input.c23
3 files changed, 2 insertions, 26 deletions
diff --git a/math/calcoo/Makefile b/math/calcoo/Makefile
index 69d378fa0c90..480bf70c8308 100644
--- a/math/calcoo/Makefile
+++ b/math/calcoo/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= calcoo
-PORTVERSION= 1.3.8
-PORTREVISION= 1
+PORTVERSION= 1.3.9
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.physics.umn.edu/~kaminski/calcoo/
diff --git a/math/calcoo/distinfo b/math/calcoo/distinfo
index 048d7965753b..367dcea3b73f 100644
--- a/math/calcoo/distinfo
+++ b/math/calcoo/distinfo
@@ -1 +1 @@
-MD5 (calcoo-1.3.8.tar.gz) = f37f868e2533a3fdecad8e68903cc5c5
+MD5 (calcoo-1.3.9.tar.gz) = 5241c3b9e36c46b9ef42f5f01008e4c3
diff --git a/math/calcoo/files/patch-src_c__input.c b/math/calcoo/files/patch-src_c__input.c
deleted file mode 100644
index 754c26e65658..000000000000
--- a/math/calcoo/files/patch-src_c__input.c
+++ /dev/null
@@ -1,23 +0,0 @@
-
-$FreeBSD$
-
---- src/c_input.c.orig Sun Jun 2 20:50:25 2002
-+++ src/c_input.c Tue Jun 4 23:28:14 2002
-@@ -118,10 +118,15 @@
-
- void call_dot(void)
- {
-- if(cpu->last_action != ACTION_INPUT) {
-- cpu->y = cpu->x;
-+ if (cpu->last_action != ACTION_INPUT) {
-+ if ((cpu->rpn_mode)
-+ && (cpu->last_action == ACTION_ENTER)) {
-+ push_stack();
-+ cpu->y = cpu->x;
-+ }
- reset_input();
- cpu->last_action = ACTION_INPUT;
-+ cpu_to_output();
- }
-
- if (cpu->d->input_field == INPUT_FIELD_INT) {