aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2016-12-30 20:02:56 +0800
committerhrs <hrs@FreeBSD.org>2016-12-30 20:02:56 +0800
commitf14d7d5b6a47be25c8acd53db3572d9448cb21dd (patch)
treed120bc1d75d596fe9c7784b929647004e32941ae /math
parent613b39a4e4d419db8a4a3dd6903c1cf8f1a40e19 (diff)
downloadfreebsd-ports-gnome-f14d7d5b6a47be25c8acd53db3572d9448cb21dd.tar.gz
freebsd-ports-gnome-f14d7d5b6a47be25c8acd53db3572d9448cb21dd.tar.zst
freebsd-ports-gnome-f14d7d5b6a47be25c8acd53db3572d9448cb21dd.zip
- Add LICENSE.
- Strip installed binaries. - Build "bistellar" binary.
Diffstat (limited to 'math')
-rw-r--r--math/gap/Makefile17
-rw-r--r--math/gap/files/patch-pkg-simpcomp-configure29
2 files changed, 44 insertions, 2 deletions
diff --git a/math/gap/Makefile b/math/gap/Makefile
index 0a7d8f031036..adc7824b4b0c 100644
--- a/math/gap/Makefile
+++ b/math/gap/Makefile
@@ -3,15 +3,18 @@
PORTNAME= gap
PORTVERSION= 4.8.6.${GAP_DISTDATE}
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ftp://ftp.gap-system.org/pub/gap/gap48/tar.bz2/ \
ftp://ftp.stack.nl/pub/users/johans/gap/ \
ftp://ftp.gap-system.org/pub/gap/gap48/old/
DISTNAME= ${GAP_VERSION}p${PORTVERSION:R:E}_${GAP_DISTTIME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= hrs@FreeBSD.org
COMMENT= GAP is a system for computational discrete algebra
+LICENSE= GPLv2+
+
LIB_DEPENDS= libgmp.so:math/gmp
USES= gmake shebangfix tar:bzip2
@@ -28,6 +31,7 @@ SHEBANG_FILES= configure \
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-gmp=${LOCALBASE}
ALL_TARGET= default
+INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE=yes
@@ -41,7 +45,16 @@ PLIST_FILES= bin/gap
BROKEN_aarch64= Fails to link: undefined reference to SyAllocBags
post-patch:
- @${REINPLACE_CMD} -i '' -e '1s|/usr/bin/sh|/bin/sh|' ${WRKSRC}/pkg/happrime/make_tarball
+ @${REINPLACE_CMD} -i '' -e '1s|/usr/bin/sh|/bin/sh|' \
+ ${WRKSRC}/pkg/happrime/make_tarball
+
+post-build:
+ cd ${WRKSRC}/pkg/simpcomp && \
+ ${SETENV} ${CONFIGURE_ENV} ${SH} configure \
+ ${CONFIGURE_ARGS:N--with-*} && \
+ ${MAKE} ${MAKEFLAGS} && \
+ ${MAKE} ${MAKEFLAGS} install-strip && \
+ ${RM} bistellar
do-install:
${SED} -e "s:GAP_DIR=.*:GAP_DIR=${GAP_LIBDIR}:g" \
diff --git a/math/gap/files/patch-pkg-simpcomp-configure b/math/gap/files/patch-pkg-simpcomp-configure
new file mode 100644
index 000000000000..661c5622b072
--- /dev/null
+++ b/math/gap/files/patch-pkg-simpcomp-configure
@@ -0,0 +1,29 @@
+--- pkg/simpcomp/configure.orig 2016-11-12 14:25:17 UTC
++++ pkg/simpcomp/configure
+@@ -2235,7 +2235,7 @@ if test -z "$CXX"; then
+ CXX=$CCC
+ else
+ if test -n "$ac_tool_prefix"; then
+- for ac_prog in g++ c++ gpp aCC CC cxx cc++ cl.exe FCC KCC RCC xlC_r xlC
++ for ac_prog in c++ g++ gpp aCC CC cxx cc++ cl.exe FCC KCC RCC xlC_r xlC
+ do
+ # Extract the first word of "$ac_tool_prefix$ac_prog", so it can be a program name with args.
+ set dummy $ac_tool_prefix$ac_prog; ac_word=$2
+@@ -2279,7 +2279,7 @@ fi
+ fi
+ if test -z "$CXX"; then
+ ac_ct_CXX=$CXX
+- for ac_prog in g++ c++ gpp aCC CC cxx cc++ cl.exe FCC KCC RCC xlC_r xlC
++ for ac_prog in c++ g++ gpp aCC CC cxx cc++ cl.exe FCC KCC RCC xlC_r xlC
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+ set dummy $ac_prog; ac_word=$2
+@@ -2322,7 +2322,7 @@ fi
+ done
+
+ if test "x$ac_ct_CXX" = x; then
+- CXX="g++"
++ CXX="c++"
+ else
+ case $cross_compiling:$ac_tool_warned in
+ yes:)