aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-01-16 10:58:51 +0800
committermaho <maho@FreeBSD.org>2007-01-16 10:58:51 +0800
commit507d1b967a80bc590c4709be98670b4baed27989 (patch)
tree2fd66ba30f59d259403075ac38a95e7afa1e59f8 /math
parent76cdeac66269944bdc6a793b10e33eea5b7cfa05 (diff)
downloadfreebsd-ports-gnome-507d1b967a80bc590c4709be98670b4baed27989.tar.gz
freebsd-ports-gnome-507d1b967a80bc590c4709be98670b4baed27989.tar.zst
freebsd-ports-gnome-507d1b967a80bc590c4709be98670b4baed27989.zip
* Fix build [1]
* Now atlas/blas/lapack are detected correctly. Reported by: kris via pointyhat [1]
Diffstat (limited to 'math')
-rw-r--r--math/taucs/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/math/taucs/Makefile b/math/taucs/Makefile
index 11e35727e941..e19477f255b6 100644
--- a/math/taucs/Makefile
+++ b/math/taucs/Makefile
@@ -16,12 +16,20 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= C library of sparse linear solvers
+WANT_FORTRAN= yes #dummy but future use
+BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
+FC= gfortran42
+F77= gfortran42
+
+.include <bsd.port.pre.mk>
+
+LIB_DEPENDS+= metis.1:${PORTSDIR}/math/metis
.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
WITH_ATLAS= yes
.endif
.if defined(WITH_ATLAS)
LIB_DEPENDS+= atlas.2:${PORTSDIR}/math/atlas
-BLAS= -lf77blas -latlas
+BLAS= -lf77blas -lcblas -latlas
LAPACK= -lalapack
.else
LIB_DEPENDS+= lapack.4:${PORTSDIR}/math/lapack
@@ -29,19 +37,12 @@ LIB_DEPENDS+= blas.2:${PORTSDIR}/math/blas
BLAS= -lblas
LAPACK= -llapack
.endif
-LIB_DEPENDS= metis.1:${PORTSDIR}/math/metis
-
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
HAS_CONFIGURE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
MAKEFILE= makefile
ALL_TARGET=
-.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
PICFLAG?= -fPIC
.else