aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-08-21 14:18:49 +0800
committerrafan <rafan@FreeBSD.org>2008-08-21 14:18:49 +0800
commitc8007265d81e778bec43e1f7b073b196887b3604 (patch)
treea30fd3dc7b50670b88ce6f8cf28e0ccf2b1e599a /math
parent9f3176cd391ec72812d7f37e93b881faa3648b45 (diff)
downloadfreebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.tar.gz
freebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.tar.zst
freebsd-ports-gnome-c8007265d81e778bec43e1f7b073b196887b3604.zip
Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.
Specifically, newer autoconf (> 2.13) has different semantic of the configure target. In short, one should use --build=CONFIGURE_TARGET instead of CONFIGURE_TARGET directly. Otherwise, you will get a warning and the old semantic may be removed in later autoconf releases. To workaround this issue, many ports hack the CONFIGURE_TARGET variable so that it contains the ``--build='' prefix. To solve this issue, under the fact that some ports still have configure script generated by the old autoconf, we use runtime detection in the do-configure target so that the proper argument can be used. Changes to Mk/*: - Add runtime detection magic in bsd.port.mk - Remove CONFIGURE_TARGET hack in various bsd.*.mk - USE_GNOME=gnometarget is now an no-op Changes to individual ports, other than removing the CONFIGURE_TARGET hack: = pkg-plist changed (due to the ugly CONFIGURE_TARGET prefix in * executables) - comms/gnuradio - science/abinit - science/elmer-fem - science/elmer-matc - science/elmer-meshgen2d - science/elmerfront - science/elmerpost = use x86_64 as ARCH - devel/g-wrap = other changes - print/magicfilter GNU_CONFIGURE -> HAS_CONFIGURE since it's not generated by autoconf Total # of ports modified: 1,027 Total # of ports affected: ~7,000 (set GNU_CONFIGURE to yes) PR: 126524 (obsoletes 52917) Submitted by: rafan Tested on: two pointyhat 7-amd64 exp runs (by pav) Approved by: portmgr (pav)
Diffstat (limited to 'math')
-rw-r--r--math/R/Makefile1
-rw-r--r--math/asymptote/Makefile1
-rw-r--r--math/fann/Makefile1
-rw-r--r--math/fftw/Makefile1
-rw-r--r--math/freefem++/Makefile1
-rw-r--r--math/freemat/Makefile1
-rw-r--r--math/gsl/Makefile1
-rw-r--r--math/guppi/Makefile1
-rw-r--r--math/kaskade/Makefile2
-rw-r--r--math/libRmath/Makefile1
-rw-r--r--math/ltl/Makefile1
-rw-r--r--math/orpie/Makefile1
-rw-r--r--math/plplot/Makefile1
-rw-r--r--math/qhull/Makefile1
-rw-r--r--math/qhull5/Makefile1
-rw-r--r--math/tablix/Makefile2
-rw-r--r--math/tvmet/Makefile1
-rw-r--r--math/yacas/Makefile1
18 files changed, 0 insertions, 20 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
index 36d24f99058f..ae083f276144 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -50,7 +50,6 @@ USE_FORTRAN= yes
INSTALL_TARGET= install install-libR
ALL_TARGET= all
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_ICONV= yes
USE_PERL5= yes
USE_GETTEXT= yes
diff --git a/math/asymptote/Makefile b/math/asymptote/Makefile
index d2b204a97b45..d7abe052910a 100644
--- a/math/asymptote/Makefile
+++ b/math/asymptote/Makefile
@@ -41,7 +41,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gc=system --with-latex=${LOCALBASE}/share/texmf-local/tex/latex
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include $${CPPFLAGS}" LFLAGS="-L${LOCALBASE}/lib $${LFLAGS}" CFLAGS="-I${LOCALBASE}/include $${CFLAGS}" LDFLAGS="-L${LOCALBASE}/lib $${LDFLAGS}"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAKE_ENV+= ${CONFIGURE_ENV}
MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
diff --git a/math/fann/Makefile b/math/fann/Makefile
index 132e59f2e6c7..414ca9e77e7b 100644
--- a/math/fann/Makefile
+++ b/math/fann/Makefile
@@ -19,6 +19,5 @@ WRKSRC= ${WRKDIR}/fann-2.1.0
USE_ZIP= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.mk>
diff --git a/math/fftw/Makefile b/math/fftw/Makefile
index 3856ca8c5419..f48f8bc6a96f 100644
--- a/math/fftw/Makefile
+++ b/math/fftw/Makefile
@@ -26,7 +26,6 @@ USE_AUTOTOOLS= libtool:15
USE_FORTRAN= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split" FC="${FC}" F77="${F77}"
CONFIGURE_ARGS= --enable-shared
USE_LDCONFIG= yes
diff --git a/math/freefem++/Makefile b/math/freefem++/Makefile
index 01c33f1f6e32..1caeb97972d2 100644
--- a/math/freefem++/Makefile
+++ b/math/freefem++/Makefile
@@ -34,7 +34,6 @@ USE_BISON= build
USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --disable-download \
--without-cadna \
--with-blas="${BLAS}" \
diff --git a/math/freemat/Makefile b/math/freemat/Makefile
index 7878d566f18c..1237b08975b3 100644
--- a/math/freemat/Makefile
+++ b/math/freemat/Makefile
@@ -34,7 +34,6 @@ USE_QT_VER= 4
USE_GMAKE= yes
QT_COMPONENTS= gui network opengl moc_build rcc_build uic_build xml svg
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-blas="${BLAS}" --without-llvm
CPPFLAGS= ${CXXFLAGS} -I${LOCALBASE}/include ${AMDINC}
CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" \
diff --git a/math/gsl/Makefile b/math/gsl/Makefile
index 2d72a0129e27..638cbd3dab6f 100644
--- a/math/gsl/Makefile
+++ b/math/gsl/Makefile
@@ -22,7 +22,6 @@ COMMENT= The GNU Scientific Library - mathematical libs
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= MAKEINFO='makeinfo --no-split'
MAN1= gsl-config.1 gsl-randist.1 gsl-histogram.1
diff --git a/math/guppi/Makefile b/math/guppi/Makefile
index e86842aca101..08611bdab1dc 100644
--- a/math/guppi/Makefile
+++ b/math/guppi/Makefile
@@ -29,7 +29,6 @@ CONFIGURE_ARGS= --enable-gnumeric --enable-explicit-python-linking
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/libglade-1.0" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
GNUMERIC_IDLDIR="${WRKDIR}/gnumeric"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PLIST_SUB= VERSION="${PORTVERSION}"
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
diff --git a/math/kaskade/Makefile b/math/kaskade/Makefile
index 3f1deb77700e..7d4aea153fac 100644
--- a/math/kaskade/Makefile
+++ b/math/kaskade/Makefile
@@ -22,8 +22,6 @@ GCCLIBDIR= -L`${CAT} ${WRKSRC}/LIBDIR` -L`${CAT} ${WRKSRC}/LIBDIR`/../../..
USE_XORG= x11
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
DIST_SUBDIR= kaskade
WRKSRC= ${WRKDIR}/3.2.1
diff --git a/math/libRmath/Makefile b/math/libRmath/Makefile
index a24c7ae2957f..c0cb3f3691f5 100644
--- a/math/libRmath/Makefile
+++ b/math/libRmath/Makefile
@@ -36,7 +36,6 @@ COMMENT= The standalone math library from R
USE_FORTRAN= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+=--without-x
CONFIGURE_ENV+= F77="${F77}"
diff --git a/math/ltl/Makefile b/math/ltl/Makefile
index 8c218ac7191a..330f1e2fce9e 100644
--- a/math/ltl/Makefile
+++ b/math/ltl/Makefile
@@ -17,7 +17,6 @@ COMMENT= A C++ class SSE library for scientific computing
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool:15
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-cxx=gcc --disable-doxygen --prefix=${PREFIX} --includedir=${PREFIX}/include/LTL
MAKE_ENV= prefix=${PREFIX} exec_prefix=${PREFIX}
MAKE_ARGS+= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
diff --git a/math/orpie/Makefile b/math/orpie/Makefile
index 599bff348895..fb14b9abf820 100644
--- a/math/orpie/Makefile
+++ b/math/orpie/Makefile
@@ -18,7 +18,6 @@ LIB_DEPENDS= gsl.12:${PORTSDIR}/math/gsl
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index f50519a09f09..e1f3ce9f4d92 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -24,7 +24,6 @@ USE_FORTRAN= yes
USE_AUTOTOOLS= libltdl:15
USE_PERL5_BUILD=yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
M4="${LOCALBASE}/bin/gm4" \
diff --git a/math/qhull/Makefile b/math/qhull/Makefile
index a4662c83ef5e..46a45edd7fc7 100644
--- a/math/qhull/Makefile
+++ b/math/qhull/Makefile
@@ -18,7 +18,6 @@ USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.if !defined(NOPORTDOCS)
MAN1= qhull.1 rbox.1
diff --git a/math/qhull5/Makefile b/math/qhull5/Makefile
index a4662c83ef5e..46a45edd7fc7 100644
--- a/math/qhull5/Makefile
+++ b/math/qhull5/Makefile
@@ -18,7 +18,6 @@ USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.if !defined(NOPORTDOCS)
MAN1= qhull.1 rbox.1
diff --git a/math/tablix/Makefile b/math/tablix/Makefile
index 84394af37483..71b70fa8ff70 100644
--- a/math/tablix/Makefile
+++ b/math/tablix/Makefile
@@ -25,8 +25,6 @@ USE_GNOME= libxml2
GNU_CONFIGURE= yes
USE_GETTEXT= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-
CONFIGURE_ENV= CPPFLAGS=-I${PREFIX}/include LIBS=-L${PREFIX}/lib \
LDFLAGS=-L${PREFIX}/lib \
PVM_ROOT=${PVM_ROOT} PVM_LIB=${PREFIX}/lib
diff --git a/math/tvmet/Makefile b/math/tvmet/Makefile
index 0955a95f36c8..2701b59324c3 100644
--- a/math/tvmet/Makefile
+++ b/math/tvmet/Makefile
@@ -17,7 +17,6 @@ COMMENT= Tiny Vector and Matrix template library
USE_BZIP2= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAKE_ARGS= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}"
MAN1= tvmet-config.1
diff --git a/math/yacas/Makefile b/math/yacas/Makefile
index fe6263c8c94b..76b10dfa51a5 100644
--- a/math/yacas/Makefile
+++ b/math/yacas/Makefile
@@ -21,7 +21,6 @@ USE_AUTOTOOLS= libtool:15
USE_PERL5_BUILD= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes