aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2010-01-03 06:53:14 +0800
committerpgj <pgj@FreeBSD.org>2010-01-03 06:53:14 +0800
commit1712099db6dfb284f6554561546f6c7b9b98ce4a (patch)
treea3abf33780dda5450b0da465c6c842bd2ebc2455 /math
parent5ba14f825298fb7bbda5b95a7b796ca0a49b4397 (diff)
downloadfreebsd-ports-gnome-1712099db6dfb284f6554561546f6c7b9b98ce4a.tar.gz
freebsd-ports-gnome-1712099db6dfb284f6554561546f6c7b9b98ce4a.tar.zst
freebsd-ports-gnome-1712099db6dfb284f6554561546f6c7b9b98ce4a.zip
A vastly expanded collection of Haskell modules implementing various
ideas from category theory. Notable bits include: comonads, adjunctions, and various recursion schemes a'la the research paper "Functional Programming with Bananas, Lenses, Envelopes and Barbed Wire". WWW: http://comonad.com/reader/ PR: ports/142142 Submitted by: Jacula Modyun <jacula(at)gmail.com>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/hs-category-extras/Makefile75
-rw-r--r--math/hs-category-extras/distinfo3
-rw-r--r--math/hs-category-extras/pkg-descr7
-rw-r--r--math/hs-category-extras/pkg-plist130
5 files changed, 216 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 98923678a7d8..8d2c0301c8dd 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -112,6 +112,7 @@
SUBDIR += gsl
SUBDIR += guppi
SUBDIR += hexcalc
+ SUBDIR += hs-category-extras
SUBDIR += igraph
SUBDIR += isabelle
SUBDIR += itl
diff --git a/math/hs-category-extras/Makefile b/math/hs-category-extras/Makefile
new file mode 100644
index 000000000000..658eadddbebb
--- /dev/null
+++ b/math/hs-category-extras/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: hs-category-extras
+# Date created: December 20 2009
+# Whom: Giuseppe Pilichi aka Jacula Modyun <jacula@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= category-extras
+PORTVERSION= 0.53.5
+CATEGORIES= math haskell
+MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= hs-
+
+MAINTAINER= jacula@gmail.com
+COMMENT= Various Haskell modules and constructs inspired by category theory
+
+BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
+RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
+
+GHC_VERSION= 6.10.4
+CATEGORYEXTRAS_VERSION= ${PORTVERSION}
+
+GHC_CMD= ${LOCALBASE}/bin/ghc
+SETUP_CMD= ./setup
+
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+CATEGORYEXTRAS_LIBDIR_REL= lib/${DISTNAME}
+
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ CATEGORYEXTRAS_VERSION=${CATEGORYEXTRAS_VERSION} \
+ CATEGORYEXTRAS_LIBDIR_REL=${CATEGORYEXTRAS_LIBDIR_REL}
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= NOPORTDOCS=""
+.else
+PLIST_SUB+= NOPORTDOCS="@comment "
+.endif
+
+.if !defined(NOPORTDOCS)
+
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if !empty(PORT_HADDOCK:M?0)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
+
+HSCOLOUR_VERSION= 1.15
+HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
+
+PORTDOCS= *
+.endif
+
+.SILENT:
+
+do-configure:
+ cd ${WRKSRC} && ${GHC_CMD} --make Setup.lhs -o setup -package Cabal \
+ && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
+
+do-build:
+ cd ${WRKSRC} && ${SETUP_CMD} build \
+ && ${SETUP_CMD} register --gen-script
+
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
+ --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${SETUP_CMD} install \
+ && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${CATEGORYEXTRAS_LIBDIR_REL}/register.sh
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
+
+.include <bsd.port.mk>
diff --git a/math/hs-category-extras/distinfo b/math/hs-category-extras/distinfo
new file mode 100644
index 000000000000..e120e5c8ca9b
--- /dev/null
+++ b/math/hs-category-extras/distinfo
@@ -0,0 +1,3 @@
+MD5 (category-extras-0.53.5.tar.gz) = a44a7a7993d85e437fbd5aea20feeb5c
+SHA256 (category-extras-0.53.5.tar.gz) = 43053026a8737342c16a976ea1c4f568c882919de2b1ea42148dc28d0eb452c2
+SIZE (category-extras-0.53.5.tar.gz) = 45039
diff --git a/math/hs-category-extras/pkg-descr b/math/hs-category-extras/pkg-descr
new file mode 100644
index 000000000000..96a7e3526b51
--- /dev/null
+++ b/math/hs-category-extras/pkg-descr
@@ -0,0 +1,7 @@
+A vastly expanded collection of Haskell modules implementing various
+ideas from category theory. Notable bits include: comonads,
+adjunctions, and various recursion schemes a'la the research paper
+"Functional Programming with Bananas, Lenses, Envelopes and
+Barbed Wire".
+
+WWW: http://comonad.com/reader/
diff --git a/math/hs-category-extras/pkg-plist b/math/hs-category-extras/pkg-plist
new file mode 100644
index 000000000000..24926fa8a247
--- /dev/null
+++ b/math/hs-category-extras/pkg-plist
@@ -0,0 +1,130 @@
+@comment $FreeBSD$
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Allegory.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Applicative/Parameterized.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Arrow/BiKleisli.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Arrow/CoKleisli.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Category/Associative.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Category/Braided.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Category/Cartesian.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Category/Cartesian/Closed.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Category/Discrete.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Category/Distributive.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Category/Dual.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Category/Hask.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Category/Monoidal.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Category/Object.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Comonad.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Comonad/Cofree.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Comonad/Coideal.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Comonad/Context.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Comonad/Density.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Comonad/Exponent.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Comonad/Fix.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Comonad/HigherOrder.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Comonad/Indexed.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Comonad/Parameterized.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Comonad/Pointer.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Comonad/Reader.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Comonad/Stream.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Comonad/Supply.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Comonad/Trans.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Dyad.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Adjunction.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Adjunction/HigherOrder.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Algebra.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Algebra/Elgot.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Categorical.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Combinators/Biff.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Combinators/Const.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Combinators/Flip.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Combinators/Join.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Combinators/Lift.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Combinators/Of.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Composition.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Cone.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Contra.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Exponential.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Extras.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Fix.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Full.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/HigherOrder.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/HigherOrder/Composition.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Indexed.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Internal/Adjunction.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Internal/Ideal.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/KanExtension.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/KanExtension/Interpreter.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Lambek.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Limit.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Pointed.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Pointed/Composition.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Representable.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Strong.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Yoneda.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Zap.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Zip.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Monad/Categorical.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Monad/Codensity.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Monad/Either.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Monad/Free.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Monad/HigherOrder.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Monad/Hyper.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Monad/Ideal.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Monad/Indexed.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Monad/Indexed/Cont.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Monad/Indexed/Fix.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Monad/Indexed/State.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Monad/Indexed/Trans.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Monad/Parameterized.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Ana.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Apo.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Build.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Cata.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Chrono.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Destroy.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Dyna.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Exo.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Futu.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Histo.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Hylo.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Meta/Erwig.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Meta/Gibbons.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Para.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Postpro.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Prepro.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Span.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Synchro.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Universal.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Zygo.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Void.hi
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HScategory-extras-%%CATEGORYEXTRAS_VERSION%%.o
+%%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHScategory-extras-%%CATEGORYEXTRAS_VERSION%%.a
+%%CATEGORYEXTRAS_LIBDIR_REL%%/register.sh
+%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
+%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism/Meta
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Morphism
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Monad/Indexed
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Monad
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Pointed
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/KanExtension
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Internal
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/HigherOrder
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Combinators
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Algebra
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor/Adjunction
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Functor
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Comonad
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Category/Cartesian
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Category
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Arrow
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control/Applicative
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Control
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%/ghc-%%GHC_VERSION%%
+@dirrm %%CATEGORYEXTRAS_LIBDIR_REL%%
+@exec /bin/sh %D/%%CATEGORYEXTRAS_LIBDIR_REL%%/register.sh
+@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
+@unexec %D/bin/ghc-pkg unregister category-extras
+@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old