aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorsylvio <sylvio@FreeBSD.org>2010-07-26 19:33:35 +0800
committersylvio <sylvio@FreeBSD.org>2010-07-26 19:33:35 +0800
commit2471adfeb14e9f2ceb3e55adff092c6cfbb9c66d (patch)
treee9e8069defbce2a0df048441967d4b727dc2747e /math
parente800025667a9add2b5365d861f66642f182eac79 (diff)
downloadfreebsd-ports-gnome-2471adfeb14e9f2ceb3e55adff092c6cfbb9c66d.tar.gz
freebsd-ports-gnome-2471adfeb14e9f2ceb3e55adff092c6cfbb9c66d.tar.zst
freebsd-ports-gnome-2471adfeb14e9f2ceb3e55adff092c6cfbb9c66d.zip
- Fix problem build with -lgmp
PR: ports/144406 Submitted by: Kimo <kimor79@yahoo.com> Approved by: wen@ (He is on vacation, I've his permission for commit your PR)
Diffstat (limited to 'math')
-rw-r--r--math/p5-Math-BigInt-GMP/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/math/p5-Math-BigInt-GMP/Makefile b/math/p5-Math-BigInt-GMP/Makefile
index 4ce2ccf2687c..9085ca0efd0f 100644
--- a/math/p5-Math-BigInt-GMP/Makefile
+++ b/math/p5-Math-BigInt-GMP/Makefile
@@ -24,4 +24,9 @@ CONFIGURE_ARGS+= INC="-I${LOCALBASE}/include"
MAN3= Math::BigInt::GMP.3
+post-patch:
+ @${PERL} -pi -e "s!-lgmp!-L${LOCALBASE}/lib $$&!;" \
+ -e "if (/'LIBS'/) { print qq!'INC' => '-I${LOCALBASE}/include',!; }" \
+ ${WRKSRC}/Makefile.PL
+
.include <bsd.port.mk>