aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-04-29 11:21:23 +0800
committerjbeich <jbeich@FreeBSD.org>2015-04-29 11:21:23 +0800
commit2e8cccf64aad1f9c1d232c675554ac4aa9e9260d (patch)
treefa8166a385180a652bb6c80fbca2ba27d5f0edb9 /math
parent8f67ed66b4dfa9a4e8bc13b3432f87e7e529e5ba (diff)
downloadfreebsd-ports-gnome-2e8cccf64aad1f9c1d232c675554ac4aa9e9260d.tar.gz
freebsd-ports-gnome-2e8cccf64aad1f9c1d232c675554ac4aa9e9260d.tar.zst
freebsd-ports-gnome-2e8cccf64aad1f9c1d232c675554ac4aa9e9260d.zip
math/abacus: respect ARFLAGS/LDFLAGS (-D/-fstack-protector)
Diffstat (limited to 'math')
-rw-r--r--math/abacus/Makefile4
-rw-r--r--math/abacus/files/patch-Makefile2
2 files changed, 3 insertions, 3 deletions
diff --git a/math/abacus/Makefile b/math/abacus/Makefile
index 06c527899248..539016a40119 100644
--- a/math/abacus/Makefile
+++ b/math/abacus/Makefile
@@ -3,7 +3,7 @@
PORTNAME= abacus
DISTVERSION= 3.2betaU1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= math
MASTER_SITES= http://www.informatik.uni-koeln.de/abacus/
@@ -21,7 +21,7 @@ USE_PERL5= build
USE_LDCONFIG= yes
ALL_TARGET= abacus
MAKE_ARGS= CCC="${CXX}" PERL="${PERL5}" STRIP="${STRIP_CMD} -x" \
- CCFLAG_DEBOPT="${CXXFLAGS}" \
+ ARCHIVE="${AR} ${ARFLAGS}" CCFLAG_DEBOPT="${CXXFLAGS}" \
OSI_INCLUDE="${LOCALBASE}/include/coin"
do-install:
diff --git a/math/abacus/files/patch-Makefile b/math/abacus/files/patch-Makefile
index dae9fc7fd6cd..0354c57b9018 100644
--- a/math/abacus/files/patch-Makefile
+++ b/math/abacus/files/patch-Makefile
@@ -27,7 +27,7 @@
+$(LIBDIR)/stuff/abacus-base.so.1: $(ABACUS_O:%.o=%.So)
+ rm -f $@
-+ $(CXX) -shared -o $@ $(ABACUS_O:%.o=%.So)
++ $(CCC) $(LDFLAGS) -shared -o $@ $(ABACUS_O:%.o=%.So)
+
# Build the library distribution directory (lib and lib/stuff)
-lib-all: subdirs abacus-base lpif interface $(ADDITIONAL_LIB_ALL)