aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-07-26 14:38:59 +0800
committerdanfe <danfe@FreeBSD.org>2013-07-26 14:38:59 +0800
commit8e8c0ff2cfbb82f02ce7565116af71e2bd25dec6 (patch)
tree72d5ae8d2389d793f49d9265aa92029518127aa5 /math
parent023fc255e2265e4f077ea16f6714d81c8a53940c (diff)
downloadfreebsd-ports-gnome-8e8c0ff2cfbb82f02ce7565116af71e2bd25dec6.tar.gz
freebsd-ports-gnome-8e8c0ff2cfbb82f02ce7565116af71e2bd25dec6.tar.zst
freebsd-ports-gnome-8e8c0ff2cfbb82f02ce7565116af71e2bd25dec6.zip
- Fix parallel build by telling make(1) that binary depends on a library
- Reword COMMENT text while I am here (pkg-descr is still a mess though; Makefile also needs some love and cleaning) Reported by: pointyhat-west
Diffstat (limited to 'math')
-rw-r--r--math/sdpa/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/math/sdpa/Makefile b/math/sdpa/Makefile
index 2d66971d1fab..cc146816559a 100644
--- a/math/sdpa/Makefile
+++ b/math/sdpa/Makefile
@@ -10,7 +10,7 @@ DISTNAME= ${PORTNAME}.${PORTVERSION}.src-${SRCDATE}
DIST_SUBDIR= sdpa
MAINTAINER= maho@FreeBSD.org
-COMMENT= SDPA(SemiDefinite Programming Algorithm) Very efficient SDP Solver
+COMMENT= Very efficient SDP (semidefinite programming) solver
USES= gmake
@@ -50,6 +50,11 @@ CONFIGURE_ARGS+=--with-blas="-L${LOCALBASE}/lib ${BLAS}" --with-lapack="-L${LOCA
PLIST_SUB+= MANUALFILE=${MANUALFILE}
+post-patch:
+# Register missing target dependency to unbreak parallel builds
+ @${REINPLACE_CMD} -e 's,^sdpa_DEPENDENCIES =,& $$(lib_LIBRARIES),' \
+ ${WRKSRC}/Makefile.in
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/sdpa ${PREFIX}/bin
@${MKDIR} ${DATADIR}