aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2009-12-31 06:50:25 +0800
committerthierry <thierry@FreeBSD.org>2009-12-31 06:50:25 +0800
commitac053de51af8f7006bc8af6d1a0b47c3e1708f2d (patch)
treed9266190f2dd61dd12dbecfcbf86e8847d8a427c /math
parent9e19c2a3068f38210442a86b65114369cc328b0c (diff)
downloadfreebsd-ports-gnome-ac053de51af8f7006bc8af6d1a0b47c3e1708f2d.tar.gz
freebsd-ports-gnome-ac053de51af8f7006bc8af6d1a0b47c3e1708f2d.tar.zst
freebsd-ports-gnome-ac053de51af8f7006bc8af6d1a0b47c3e1708f2d.zip
Trying to fix on amd64/FreeBSD-6:
- Teach about amd64, to detect Not a Number flag, thus enabling Qhull support with CSA; - Disable detection of f77 by cmake unless WITH_FORTRAN is defined. Reported by: pointyhat via Pav
Diffstat (limited to 'math')
-rw-r--r--math/plplot/Makefile2
-rw-r--r--math/plplot/files/patch-cmake_modules_csiro.cmake13
2 files changed, 14 insertions, 1 deletions
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 17c959c706aa..3da63eb4fe6f 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -58,7 +58,7 @@ USE_FORTRAN= yes
CONFIGURE_ENV+= CMAKE_Fortran_COMPILER=${FC}
PLIST_SUB+= FORTRAN=""
.else
-CMAKE_ARGS+= -DENABLE_f95:BOOL=OFF
+CMAKE_ARGS+= -DENABLE_f95:BOOL=OFF -DENABLE_f77:BOOL=OFF
PLIST_SUB+= FORTRAN="@comment "
.endif
diff --git a/math/plplot/files/patch-cmake_modules_csiro.cmake b/math/plplot/files/patch-cmake_modules_csiro.cmake
new file mode 100644
index 000000000000..ab1d76d810a6
--- /dev/null
+++ b/math/plplot/files/patch-cmake_modules_csiro.cmake
@@ -0,0 +1,13 @@
+--- cmake/modules/csiro.cmake.orig 2009-09-06 21:04:43.000000000 +0200
++++ cmake/modules/csiro.cmake 2009-12-30 21:10:58.000000000 +0100
+@@ -36,6 +36,10 @@
+ else(CMAKE_C_COMPILER MATCHES "gcc")
+ set(NAN_CFLAGS "${NAN_CFLAGS} -ieee")
+ endif(CMAKE_C_COMPILER MATCHES "gcc")
++ else(CMAKE_SYSTEM_PROCESSOR MATCHES "alpha.*")
++ if(CMAKE_SYSTEM_PROCESSOR MATCHES "amd64")
++ set(NAN_CFLAGS "${NAN_CFLAGS} -mieee-fp")
++ endif(CMAKE_SYSTEM_PROCESSOR MATCHES "amd64")
+ endif(CMAKE_SYSTEM_PROCESSOR MATCHES "alpha.*")
+ endif(CMAKE_SYSTEM_PROCESSOR MATCHES "i[0-9]86")
+ if(NOT DEFINED NaNAwareCCompiler)