aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-09-03 01:13:09 +0800
committermiwi <miwi@FreeBSD.org>2009-09-03 01:13:09 +0800
commitb1e39a3672af379330efc712b4d5b7003f30b057 (patch)
tree32a6bd06fda476012b9c34847d9459576987c7da /math
parent60f6c366f0fda3421c6b3176a0dc60e38e635040 (diff)
downloadfreebsd-ports-gnome-b1e39a3672af379330efc712b4d5b7003f30b057.tar.gz
freebsd-ports-gnome-b1e39a3672af379330efc712b4d5b7003f30b057.tar.zst
freebsd-ports-gnome-b1e39a3672af379330efc712b4d5b7003f30b057.zip
- Update to 2.0
PR: 138437 Submitted by: Wen Heping <wenheping@gmail.com> (maintainer)
Diffstat (limited to 'math')
-rw-r--r--math/jakarta-commons-math/Makefile12
-rw-r--r--math/jakarta-commons-math/distinfo6
-rw-r--r--math/jakarta-commons-math/files/patch-build.xml14
3 files changed, 10 insertions, 22 deletions
diff --git a/math/jakarta-commons-math/Makefile b/math/jakarta-commons-math/Makefile
index f1b50c85b322..a263cef9e981 100644
--- a/math/jakarta-commons-math/Makefile
+++ b/math/jakarta-commons-math/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= commons-math
-PORTVERSION= 1.2
+PORTVERSION= 2.0
CATEGORIES= math java
MASTER_SITES= ${MASTER_SITE_APACHE_COMMONS_SOURCE}
MASTER_SITE_SUBDIR= ${PORTNAME:S,commons-,,}
@@ -29,10 +29,12 @@ ALL_TARGET= jar
MAKE_ARGS= -Dlibdir=${WRKDIR} -Dnoget=true \
-Dcommons-logging.jar="file://${JAVAJARDIR}/commons-logging.jar" \
-Dcommons-discovery.jar="file://${JAVAJARDIR}/commons-discovery.jar"
+
COMMONS_LOGGING_API= ${LOCALBASE}/share/doc/commons-logging/api
.if exists(${COMMONS_LOGGING_API})
MAKE_ARGS+= -Dcommons-logging.api=${COMMONS_LOGGING_API}
.endif
+
COMMONS_DISCOVERY_API= ${LOCALBASE}/share/doc/commons-discovery/api
.if exists(${COMMONS_DISCOVERY_API})
MAKE_ARGS+= -Dcommons-logging.api=${COMMONS_DISCOVERY_API}
@@ -41,7 +43,7 @@ MAKE_ARGS+= -Dcommons-logging.api=${COMMONS_DISCOVERY_API}
.if !defined(NOPORTDOCS)
ALL_TARGET+= javadoc
OTHERDOCS= LICENSE.txt NOTICE.txt
-PORTDOCS= api ${OTHERDOCS}
+PORTDOCS= apidocs ${OTHERDOCS}
.endif
JARFILE= ${PORTNAME}-${PORTVERSION}.jar
DESTJARFILE= ${PORTNAME}.jar
@@ -63,9 +65,9 @@ do-install:
.if !defined(NOPORTDOCS)
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
@${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC}/dist/docs \
- && ${FIND} -s api -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
- && ${FIND} -s api -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
+ @cd ${WRKSRC}/target \
+ && ${FIND} -s apidocs -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} -s apidocs -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
@${INSTALL_DATA} ${OTHERDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
@${ECHO_MSG} " [ DONE ]"
.endif
diff --git a/math/jakarta-commons-math/distinfo b/math/jakarta-commons-math/distinfo
index 21148d846031..5a1f3eb8df09 100644
--- a/math/jakarta-commons-math/distinfo
+++ b/math/jakarta-commons-math/distinfo
@@ -1,3 +1,3 @@
-MD5 (commons-math-1.2-src.tar.gz) = d1c24d181e4ec8233ad164db371aa2c5
-SHA256 (commons-math-1.2-src.tar.gz) = 7ce779da04546b29f5b5401c327ff317879808ce0c228796240c6265a36aea4b
-SIZE (commons-math-1.2-src.tar.gz) = 602243
+MD5 (commons-math-2.0-src.tar.gz) = 0572a2e542c0e138328466ff2c8dafce
+SHA256 (commons-math-2.0-src.tar.gz) = 5c40855b63e5614fd68f77a45588c92ccd4af2e8162d9ebee3e33e225b04b802
+SIZE (commons-math-2.0-src.tar.gz) = 1044286
diff --git a/math/jakarta-commons-math/files/patch-build.xml b/math/jakarta-commons-math/files/patch-build.xml
deleted file mode 100644
index 5327f059f3c3..000000000000
--- a/math/jakarta-commons-math/files/patch-build.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-$FreeBSD$
-
---- build.xml.orig Sun Dec 18 20:37:46 2005
-+++ build.xml Tue Jun 20 11:16:15 2006
-@@ -179,6 +179,9 @@
- <property name="title" value="Math 1.1 API">
- </property>
- <javadoc use="true" private="true" destdir="${javadocdir}" author="true" version="true" sourcepath="${basedir}/src/java" packagenames="org.apache.commons.math.*">
-+ <link offline="true" packagelistLoc="${commons-discovery.api}" href="${commons-discovery.api}"/>
-+ <link offline="true" packagelistLoc="${commons-discovery.api}" href="${commons-discovery.api}"/>
-+ <link offline="true" packagelistLoc="${jdk.api}" href="${jdk.api}"/>
- <classpath>
- <path refid="build.classpath">
- </path>