aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-11-15 20:49:46 +0800
committersobomax <sobomax@FreeBSD.org>2000-11-15 20:49:46 +0800
commitc66bbe27a48808aca53f1afab7b1a2d292478a57 (patch)
treefd9fe6bad04aed4b4043a745e7a7771b2c95a297 /math
parent57f53ebe414ebbfe6cc20f24f4be6303dd54e4ab (diff)
downloadfreebsd-ports-gnome-c66bbe27a48808aca53f1afab7b1a2d292478a57.tar.gz
freebsd-ports-gnome-c66bbe27a48808aca53f1afab7b1a2d292478a57.tar.zst
freebsd-ports-gnome-c66bbe27a48808aca53f1afab7b1a2d292478a57.zip
Fix pkg-plist breakage on systems with perl < 5.6.0.
Submitted by: bento
Diffstat (limited to 'math')
-rw-r--r--math/PDL/Makefile6
-rw-r--r--math/PDL/pkg-plist6
2 files changed, 10 insertions, 2 deletions
diff --git a/math/PDL/Makefile b/math/PDL/Makefile
index 9df813e058c1..aa37ed3429ff 100644
--- a/math/PDL/Makefile
+++ b/math/PDL/Makefile
@@ -43,6 +43,12 @@ pre-extract:
BROKEN= test script t/flexraw.t fails all 26 tests
.endif
+.if ${OSVERSION} >= 500007
+PLIST_SUB+= NEW_PERL:="" OLD_PERL:="@comment "
+.else
+PLIST_SUB+= NEW_PERL:="@comment " OLD_PERL:=""
+.endif
+
MAN1= PDL::Philosophy.1 PDL::Internals.1 PDL::PP.1 PDL::Tips.1 \
PDL::Dataflow.1 PDL::Indexing.1 PDL::FAQ.1 PDL::Delta.1 \
PDL::Objects.1 PDL::Impatient.1 pdl.1 perldl.1
diff --git a/math/PDL/pkg-plist b/math/PDL/pkg-plist
index fe6175be0f1f..c7a2e50f7cec 100644
--- a/math/PDL/pkg-plist
+++ b/math/PDL/pkg-plist
@@ -187,8 +187,10 @@ lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/PDL/HtmlDocs/PDL/Slices.html
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/PDL/HtmlDocs/PDL/Tests.html
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/PDL/HtmlDocs/PDL/Tips.html
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/PDL/HtmlDocs/PDL/Types.html
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/PDL/HtmlDocs/PDL/pod2htmd.x~~
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/PDL/HtmlDocs/PDL/pod2htmi.x~~
+%%OLD_PERL:%%lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/PDL/HtmlDocs/PDL/pod2html-dircache
+%%OLD_PERL:%%lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/PDL/HtmlDocs/PDL/pod2html-itemcache
+%%NEW_PERL:%%lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/PDL/HtmlDocs/PDL/pod2htmd.x~~
+%%NEW_PERL:%%lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/PDL/HtmlDocs/PDL/pod2htmi.x~~
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/PDL/IO/Browser.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/PDL/IO/FastRaw.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/PDL/IO/FlexRaw.pm