aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2005-08-28 15:32:03 +0800
committerkuriyama <kuriyama@FreeBSD.org>2005-08-28 15:32:03 +0800
commitf675ecec1735fe3cf28265bd289e75581e3042cd (patch)
treeed5210d2ffd9e14f29785a5f1692a9771cc4c53c /math
parentb30589b431df7603485fdfc1b4d2dbadfaa6ae68 (diff)
downloadfreebsd-ports-gnome-f675ecec1735fe3cf28265bd289e75581e3042cd.tar.gz
freebsd-ports-gnome-f675ecec1735fe3cf28265bd289e75581e3042cd.tar.zst
freebsd-ports-gnome-f675ecec1735fe3cf28265bd289e75581e3042cd.zip
Add p5-Math-Vec 0.02, object-Oriented Vector Math Methods in Perl.
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Vec/Makefile22
-rw-r--r--math/p5-Math-Vec/distinfo2
-rw-r--r--math/p5-Math-Vec/pkg-descr11
-rw-r--r--math/p5-Math-Vec/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 81d9ddf80e81..429b146e09b1 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -173,6 +173,7 @@
SUBDIR += p5-Math-SimpleVariable
SUBDIR += p5-Math-Spline
SUBDIR += p5-Math-TrulyRandom
+ SUBDIR += p5-Math-Vec
SUBDIR += p5-Math-VecStat
SUBDIR += p5-MatrixReal
SUBDIR += p5-NetCDF
diff --git a/math/p5-Math-Vec/Makefile b/math/p5-Math-Vec/Makefile
new file mode 100644
index 000000000000..08de82f2bffe
--- /dev/null
+++ b/math/p5-Math-Vec/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Math::Vec
+# Date created: 6 May 2005
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Vec
+PORTVERSION= 0.02
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/E/EW/EWILHELM/Math
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Object-Oriented Vector Math Methods in Perl
+
+PERL_CONFIGURE= yes
+MAN3= Math::Vec.3
+
+.include <bsd.port.pre.mk>
+
+.include <bsd.port.post.mk>
diff --git a/math/p5-Math-Vec/distinfo b/math/p5-Math-Vec/distinfo
new file mode 100644
index 000000000000..fa6d78556f3d
--- /dev/null
+++ b/math/p5-Math-Vec/distinfo
@@ -0,0 +1,2 @@
+MD5 (Math-Vec-0.02.tar.gz) = d6fd4ccf1a76f23d798beab7a1843ef2
+SIZE (Math-Vec-0.02.tar.gz) = 6454
diff --git a/math/p5-Math-Vec/pkg-descr b/math/p5-Math-Vec/pkg-descr
new file mode 100644
index 000000000000..a306f9b736d4
--- /dev/null
+++ b/math/p5-Math-Vec/pkg-descr
@@ -0,0 +1,11 @@
+This module was adapted from Math::Vector.
+
+It uses most of the same algorithms, and currently preserves the same
+names as the original functions, though some aliases have been added
+to make the interface more natural.
+
+The "object" for the object oriented calling style is a blessed array
+reference which contains a vector of the form [x,y,z]. Methods will
+typically return a list.
+
+WWW: http://search.cpan.org/dist/Math-Vec/
diff --git a/math/p5-Math-Vec/pkg-plist b/math/p5-Math-Vec/pkg-plist
new file mode 100644
index 000000000000..3fa0ccce7cf0
--- /dev/null
+++ b/math/p5-Math-Vec/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Math/Vec.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Vec/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Vec
+@unexec rmdir %D/%%SITE_PERL%%/Math 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math 2>/dev/null || true