aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2016-10-13 17:12:46 +0800
committerwen <wen@FreeBSD.org>2016-10-13 17:12:46 +0800
commit000e18aa7b28c99b2e2f3c56e4430eb3860e8c4d (patch)
tree6485c431e6a153b02426857d40399a67ef0d8b12 /math
parent96ee3c88369795a5b527e6892c180b34d77ab817 (diff)
downloadfreebsd-ports-gnome-000e18aa7b28c99b2e2f3c56e4430eb3860e8c4d.tar.gz
freebsd-ports-gnome-000e18aa7b28c99b2e2f3c56e4430eb3860e8c4d.tar.zst
freebsd-ports-gnome-000e18aa7b28c99b2e2f3c56e4430eb3860e8c4d.zip
- Update to 4.9
- Remove GUI option but always build libCGAL_ImageIO and libCGAL_Qt
Diffstat (limited to 'math')
-rw-r--r--math/cgal/Makefile15
-rw-r--r--math/cgal/distinfo6
-rw-r--r--math/cgal/files/patch-CMakeLists.txt28
-rw-r--r--math/cgal/files/patch-include_CGAL_config.h4
-rw-r--r--math/cgal/pkg-plist96
5 files changed, 91 insertions, 58 deletions
diff --git a/math/cgal/Makefile b/math/cgal/Makefile
index 58b5ed67b77f..eedb3f2d4ac8 100644
--- a/math/cgal/Makefile
+++ b/math/cgal/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= cgal
-PORTVERSION= 4.8.1
+PORTVERSION= 4.9
CATEGORIES= math
-MASTER_SITES= https://github.com/CGAL/cgal/releases/download/releases%2FCGAL-4.8.1/
+MASTER_SITES= https://github.com/CGAL/cgal/releases/download/releases%2FCGAL-4.9/
DISTNAME= CGAL-${PORTVERSION}
MAINTAINER= wen@FreeBSD.org
@@ -22,18 +22,9 @@ BROKEN_sparc64: Does not build: fails to compile all_files.cpp
USE_LDCONFIG= yes
USES= cmake shebangfix tar:xz
-USE_QT5= buildtools_build core qmake_build widgets
+USE_QT5= buildtools_build core gui opengl qmake_build widgets
SHEBANG_FILES= scripts/cgal_create_CMakeLists \
scripts/cgal_create_cmake_script
-HAS_CONFIGURE= yes
-
-OPTIONS_DEFINE= GUI
-OPTIONS_DEFAULT= GUI
-OPTIONS_SUB= yes
-
-GUI_DESC= Build libCGAL_ImageIO and libCGAL_Qt4
-GUI_USE= GL=glu,gl QT5=gui,opengl
-GUI_CMAKE_OFF= -DWITH_CGAL_Qt4=OFF -DWITH_CGAL_ImageIO=OFF
.include <bsd.port.options.mk>
diff --git a/math/cgal/distinfo b/math/cgal/distinfo
index 13d95b2780d5..b90a6efec33c 100644
--- a/math/cgal/distinfo
+++ b/math/cgal/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1467676126
-SHA256 (CGAL-4.8.1.tar.xz) = fa2036e0a53cc54eee3dffe4763028e9aec831672c8259fa376d3c29e8f781b0
-SIZE (CGAL-4.8.1.tar.xz) = 13492048
+TIMESTAMP = 1476253394
+SHA256 (CGAL-4.9.tar.xz) = 63ac5df71f912f34f2f0f2e54a303578df51f4ec2627db593a65407d791f9039
+SIZE (CGAL-4.9.tar.xz) = 13749292
diff --git a/math/cgal/files/patch-CMakeLists.txt b/math/cgal/files/patch-CMakeLists.txt
index a86adc697c92..c6501cff60b7 100644
--- a/math/cgal/files/patch-CMakeLists.txt
+++ b/math/cgal/files/patch-CMakeLists.txt
@@ -1,20 +1,18 @@
---- CMakeLists.txt.orig 2016-06-13 12:37:16 UTC
+--- CMakeLists.txt.orig 2016-09-16 19:00:17 UTC
+++ CMakeLists.txt
-@@ -729,7 +729,7 @@ set ( CGAL_INSTALL_DOC_DIR "share/doc/${
- CACHE STRING "The folder where CGAL documentation and license files will be installed, relative to CMAKE_INSTALL_PREFIX"
+@@ -759,11 +759,11 @@ set ( CGAL_INSTALL_CMAKE_DIR "${CGAL_INS
+ CACHE STRING "The folder where CGAL CMake modules will be installed, relative to CMAKE_INSTALL_PREFIX"
)
--set ( CGAL_INSTALL_MAN_DIR "share/man/man1"
-+set ( CGAL_INSTALL_MAN_DIR "man/man1"
- CACHE STRING "The folder where manual pages for CGAL scripts will be installed, relative to CMAKE_INSTALL_PREFIX"
- )
-
-@@ -816,7 +816,7 @@ create_CGALconfig_files()
- # DESTINATION option is mandatory; skipping it breaks CPack!
+-set ( CGAL_INSTALL_DOC_DIR "${CMAKE_INSTALL_FULL_DATAROOTDIR}/doc/${CGAL_VERSION_DIR}"
+- CACHE STRING "The folder where CGAL documentation and license files will be installed, relative to CMAKE_INSTALL_PREFIX"
+- )
++# set ( CGAL_INSTALL_DOC_DIR "${CMAKE_INSTALL_FULL_DATAROOTDIR}/doc/${CGAL_VERSION_DIR}"
++# CACHE STRING "The folder where CGAL documentation and license files will be installed, relative to CMAKE_INSTALL_PREFIX"
++# )
- if(CGAL_INSTALL_DOC_DIR)
-- install(FILES AUTHORS CHANGES LICENSE LICENSE.FREE_USE LICENSE.GPL LICENSE.LGPL DESTINATION ${CGAL_INSTALL_DOC_DIR} )
-+# install(FILES AUTHORS CHANGES LICENSE LICENSE.FREE_USE LICENSE.GPL LICENSE.LGPL DESTINATION ${CGAL_INSTALL_DOC_DIR} )
- endif()
+-set ( CGAL_INSTALL_MAN_DIR "${CMAKE_INSTALL_FULL_DATAROOTDIR}/man/man1"
++set ( CGAL_INSTALL_MAN_DIR "man/man1"
+ CACHE STRING "The folder where manual pages for CGAL scripts will be installed, relative to CMAKE_INSTALL_PREFIX"
+ )
- #install all includes collected in trunk et cetera
diff --git a/math/cgal/files/patch-include_CGAL_config.h b/math/cgal/files/patch-include_CGAL_config.h
index ca0562243359..98b0a25856ee 100644
--- a/math/cgal/files/patch-include_CGAL_config.h
+++ b/math/cgal/files/patch-include_CGAL_config.h
@@ -1,6 +1,6 @@
---- include/CGAL/config.h.orig 2016-07-05 08:44:07 UTC
+--- include/CGAL/config.h.orig 2016-09-16 19:00:17 UTC
+++ include/CGAL/config.h
-@@ -296,7 +296,8 @@
+@@ -300,7 +300,8 @@
|| defined(__x86_64) || defined(__x86_64__) \
|| defined(__ia64) || defined(__ia64__) \
|| defined(_M_IX86) || defined(_M_IA64) \
diff --git a/math/cgal/pkg-plist b/math/cgal/pkg-plist
index 90a1b37e382d..e15596992dc0 100644
--- a/math/cgal/pkg-plist
+++ b/math/cgal/pkg-plist
@@ -109,7 +109,6 @@ include/CGAL/Apollonius_graph_2/check_filter.h
include/CGAL/Apollonius_graph_2/comparator_profiler.h
include/CGAL/Apollonius_graph_2/compare_quadratic.h
include/CGAL/Apollonius_graph_2/predicate_profiler.h
-include/CGAL/Apollonius_graph_2/uncertain/Apollonius_graph_uncertain_filtered_traits_2.h
include/CGAL/Apollonius_graph_2/uncertain/Uncertain_is_hidden_C2.h
include/CGAL/Apollonius_graph_2/uncertain/Uncertain_oriented_side_of_bisector_C2.h
include/CGAL/Apollonius_graph_2/uncertain/Uncertain_vertex_conflict_2.h
@@ -534,8 +533,12 @@ include/CGAL/Complex_2_in_triangulation_cell_base_3.h
include/CGAL/Complex_2_in_triangulation_vertex_base_3.h
include/CGAL/Complexity_tags.h
include/CGAL/Compute_anchor_3.h
+include/CGAL/Compute_cone_boundaries_2.h
include/CGAL/Concatenate_iterator.h
include/CGAL/Concurrent_compact_container.h
+include/CGAL/Cone_spanners_2/Less_by_direction_2.h
+include/CGAL/Cone_spanners_2/Plane_scan_tree.h
+include/CGAL/Cone_spanners_2/Plane_scan_tree_impl.h
include/CGAL/ConicCPA2.h
include/CGAL/ConicHPA2.h
include/CGAL/Conic_2.h
@@ -547,6 +550,8 @@ include/CGAL/Constrained_triangulation_face_base_2.h
include/CGAL/Constrained_triangulation_plus_2.h
include/CGAL/Constrained_voronoi_diagram_2.h
include/CGAL/Constraint_hierarchy_2.h
+include/CGAL/Construct_theta_graph_2.h
+include/CGAL/Construct_yao_graph_2.h
include/CGAL/Convertible_circulator_project.h
include/CGAL/Convertible_filter_iterator.h
include/CGAL/Convertible_iterator_project.h
@@ -688,7 +693,6 @@ include/CGAL/FPU_extension.h
include/CGAL/FPU_gcc_i386.h
include/CGAL/FPU_gcc_i386_sse2.h
include/CGAL/FPU_msvc.h
-include/CGAL/FaceGraph_to_Polyhedron_3.h
include/CGAL/Filter_circulator.h
include/CGAL/Filtered_bbox_circular_kernel_2.h
include/CGAL/Filtered_bbox_circular_kernel_2/bbox_filtered_predicates.h
@@ -854,9 +858,8 @@ include/CGAL/IO/Gps_iostream.h
include/CGAL/IO/Inventor_ostream.h
include/CGAL/IO/Istream_iterator.h
include/CGAL/IO/Nef_polyhedron_2_PS_stream.h
-include/CGAL/IO/Nef_polyhedron_S2_OGLUT_stream.h
include/CGAL/IO/Nef_polyhedron_iostream_3.h
-include/CGAL/IO/Nef_polyhedron_iostream_S2.h
+include/CGAL/IO/OBJ_reader.h
include/CGAL/IO/OFF_reader.h
include/CGAL/IO/Ostream_iterator.h
include/CGAL/IO/Polyhedron_VRML_1_ostream.h
@@ -899,6 +902,38 @@ include/CGAL/IO/write_ply_points.h
include/CGAL/IO/write_xyz_points.h
include/CGAL/Identity_policy_2.h
include/CGAL/ImageIO.h
+include/CGAL/ImageIO/analyze.h
+include/CGAL/ImageIO/analyze_impl.h
+include/CGAL/ImageIO/bmp.h
+include/CGAL/ImageIO/bmp_impl.h
+include/CGAL/ImageIO/bmpendian.h
+include/CGAL/ImageIO/bmpendian_impl.h
+include/CGAL/ImageIO/bmpread.h
+include/CGAL/ImageIO/bmpread_impl.h
+include/CGAL/ImageIO/bmptypes.h
+include/CGAL/ImageIO/convert.h
+include/CGAL/ImageIO/convert_impl.h
+include/CGAL/ImageIO/fgetns.h
+include/CGAL/ImageIO/fgetns_impl.h
+include/CGAL/ImageIO/gif.h
+include/CGAL/ImageIO/gif_impl.h
+include/CGAL/ImageIO/gis.h
+include/CGAL/ImageIO/gis_impl.h
+include/CGAL/ImageIO/inr.h
+include/CGAL/ImageIO/inr_impl.h
+include/CGAL/ImageIO/iris.h
+include/CGAL/ImageIO/iris_impl.h
+include/CGAL/ImageIO/mincio.h
+include/CGAL/ImageIO/mincio_impl.h
+include/CGAL/ImageIO/pnm.h
+include/CGAL/ImageIO/pnm_impl.h
+include/CGAL/ImageIO/recbuffer.h
+include/CGAL/ImageIO/recbuffer_impl.h
+include/CGAL/ImageIO/recline.h
+include/CGAL/ImageIO/recline_impl.h
+include/CGAL/ImageIO/reech4x4.h
+include/CGAL/ImageIO/reech4x4_impl.h
+include/CGAL/ImageIO/typedefs.h
include/CGAL/ImageIO_impl.h
include/CGAL/Image_3.h
include/CGAL/Image_3_impl.h
@@ -982,8 +1017,6 @@ include/CGAL/Kernel_d/Line_d_impl.h
include/CGAL/Kernel_d/Linear_algebraCd_impl.h
include/CGAL/Kernel_d/Linear_algebraHd_impl.h
include/CGAL/Kernel_d/Matrix__.h
-include/CGAL/Kernel_d/PVDHACd_impl.h
-include/CGAL/Kernel_d/PVDHAHd_impl.h
include/CGAL/Kernel_d/Pair_d.h
include/CGAL/Kernel_d/PointCd.h
include/CGAL/Kernel_d/PointCd_impl.h
@@ -1055,7 +1088,6 @@ include/CGAL/Kinetic/Simulator_objects_listener.h
include/CGAL/Kinetic/Sort.h
include/CGAL/Kinetic/Sort_event_log_visitor.h
include/CGAL/Kinetic/Sort_visitor_base.h
-include/CGAL/Kinetic/Triangulation_2.h
include/CGAL/Kinetic/Two_list_pointer_event_queue.h
include/CGAL/Kinetic/basic.h
include/CGAL/Kinetic/internal/Delaunay_triangulation_base_3.h
@@ -1192,6 +1224,7 @@ include/CGAL/Mesh_3/Worksharing_data_structures.h
include/CGAL/Mesh_3/config.h
include/CGAL/Mesh_3/dihedral_angle_3.h
include/CGAL/Mesh_3/global_parameters.h
+include/CGAL/Mesh_3/initialize_triangulation_from_labeled_image.h
include/CGAL/Mesh_3/io_signature.h
include/CGAL/Mesh_3/mesh_standard_cell_criteria.h
include/CGAL/Mesh_3/mesh_standard_criteria.h
@@ -1201,6 +1234,7 @@ include/CGAL/Mesh_3/parameters_defaults.h
include/CGAL/Mesh_3/polyhedral_to_labeled_function_wrapper.h
include/CGAL/Mesh_3/polylines_to_protect.h
include/CGAL/Mesh_3/radius_ratio.h
+include/CGAL/Mesh_3/search_for_connected_components_in_labeled_image.h
include/CGAL/Mesh_3/sliver_criteria.h
include/CGAL/Mesh_3/squared_distance_Point_3_Triangle_3.h
include/CGAL/Mesh_3/utilities.h
@@ -1554,7 +1588,6 @@ include/CGAL/Periodic_2_triangulation_traits_2.h
include/CGAL/Periodic_2_triangulation_vertex_base_2.h
include/CGAL/Periodic_3_Delaunay_triangulation_3.h
include/CGAL/Periodic_3_Delaunay_triangulation_filtered_traits_3.h
-include/CGAL/Periodic_3_Delaunay_triangulation_statically_filtered_traits_3.h
include/CGAL/Periodic_3_Delaunay_triangulation_traits_3.h
include/CGAL/Periodic_3_construct_point_3.h
include/CGAL/Periodic_3_offset_3.h
@@ -1562,11 +1595,8 @@ include/CGAL/Periodic_3_triangulation_3.h
include/CGAL/Periodic_3_triangulation_ds_cell_base_3.h
include/CGAL/Periodic_3_triangulation_ds_vertex_base_3.h
include/CGAL/Periodic_3_triangulation_dummy_36.h
-include/CGAL/Periodic_3_triangulation_filtered_traits_3.h
include/CGAL/Periodic_3_triangulation_hierarchy_3.h
include/CGAL/Periodic_3_triangulation_iterators_3.h
-include/CGAL/Periodic_3_triangulation_remove_traits_3.h
-include/CGAL/Periodic_3_triangulation_statically_filtered_traits_3.h
include/CGAL/Periodic_3_triangulation_traits_3.h
include/CGAL/Plane_3.h
include/CGAL/Plane_separator.h
@@ -1633,6 +1663,7 @@ include/CGAL/Polygon_mesh_processing/stitch_borders.h
include/CGAL/Polygon_mesh_processing/triangulate_faces.h
include/CGAL/Polygon_mesh_processing/triangulate_hole.h
include/CGAL/Polygon_mesh_slicer.h
+include/CGAL/Polygon_nop_decomposition_2.h
include/CGAL/Polygon_offset_builder_2.h
include/CGAL/Polygon_offset_builder_traits_2.h
include/CGAL/Polygon_set_2.h
@@ -1699,7 +1730,6 @@ include/CGAL/Polynomial/internal/Filtered_kernel.h
include/CGAL/Polynomial/internal/Filtered_kernel/Filtered_Descartes_has_root.h
include/CGAL/Polynomial/internal/Filtered_kernel/Filtered_Descartes_root_counter.h
include/CGAL/Polynomial/internal/Filtered_kernel/Filtered_are_negations.h
-include/CGAL/Polynomial/internal/Filtered_kernel/Filtered_polynomial_rational_kernel.h
include/CGAL/Polynomial/internal/Filtered_kernel/Filtered_root_bound_evaluator.h
include/CGAL/Polynomial/internal/Filtered_kernel/Filtered_root_multiplicity.h
include/CGAL/Polynomial/internal/Filtered_kernel/Filtered_sign_at.h
@@ -2245,6 +2275,8 @@ include/CGAL/Three/Scene_group_item.h
include/CGAL/Three/Scene_interface.h
include/CGAL/Three/Scene_item.h
include/CGAL/Three/Scene_item_config.h
+include/CGAL/Three/Scene_print_interface_item.h
+include/CGAL/Three/TextRenderer.h
include/CGAL/Three/Viewer_config.h
include/CGAL/Three/Viewer_interface.h
include/CGAL/Threetuple.h
@@ -2310,9 +2342,6 @@ include/CGAL/Triangulation_ds_vertex_2.h
include/CGAL/Triangulation_ds_vertex_base_2.h
include/CGAL/Triangulation_ds_vertex_base_3.h
include/CGAL/Triangulation_euclidean_traits_2.h
-include/CGAL/Triangulation_euclidean_traits_xy_3.h
-include/CGAL/Triangulation_euclidean_traits_xz_3.h
-include/CGAL/Triangulation_euclidean_traits_yz_3.h
include/CGAL/Triangulation_face.h
include/CGAL/Triangulation_face_base_2.h
include/CGAL/Triangulation_face_base_with_info_2.h
@@ -2425,7 +2454,7 @@ include/CGAL/boost/graph/Dual.h
include/CGAL/boost/graph/Euler_operations.h
include/CGAL/boost/graph/Graph_geometry.h
include/CGAL/boost/graph/backward_compatibility_functions.h
-include/CGAL/boost/graph/convert_surface_mesh.h
+include/CGAL/boost/graph/copy_face_graph.h
include/CGAL/boost/graph/dijkstra_shortest_paths.h
include/CGAL/boost/graph/dijkstra_shortest_paths.hpp
include/CGAL/boost/graph/graph_concepts.h
@@ -2480,6 +2509,7 @@ include/CGAL/compiler_config.h
include/CGAL/compute_average_spacing.h
include/CGAL/compute_outer_frame_margin.h
include/CGAL/config.h
+include/CGAL/config.h.orig
include/CGAL/connect_holes.h
include/CGAL/constant.h
include/CGAL/constructions/Polygon_offset_cons_ftC2.h
@@ -2543,12 +2573,14 @@ include/CGAL/glu.h
include/CGAL/gmp.h
include/CGAL/gmpxx.h
include/CGAL/gmpxx_coercion_traits.h
+include/CGAL/gnuplot_output_2.h
include/CGAL/grabbers.h
include/CGAL/graph_traits_Arrangement_2.h
include/CGAL/graph_traits_Dual_Arrangement_2.h
include/CGAL/grid_simplify_point_set.h
include/CGAL/halfedgeDS_cut_component.h
include/CGAL/halfedgeds_connected_components.h
+include/CGAL/hash_openmesh.h
include/CGAL/hierarchy_simplify_point_set.h
include/CGAL/hilbert_sort.h
include/CGAL/hilbert_sort_on_sphere.h
@@ -2556,10 +2588,12 @@ include/CGAL/in_place_edge_list.h
include/CGAL/int.h
include/CGAL/internal/AABB_tree/AABB_drawing_traits.h
include/CGAL/internal/AABB_tree/AABB_node.h
+include/CGAL/internal/AABB_tree/AABB_ray_intersection.h
include/CGAL/internal/AABB_tree/AABB_search_tree.h
include/CGAL/internal/AABB_tree/AABB_traversal_traits.h
include/CGAL/internal/AABB_tree/Halfedge_and_face_graph_property_maps.h
include/CGAL/internal/AABB_tree/Has_nested_type_Shared_data.h
+include/CGAL/internal/AABB_tree/Is_ray_intersection_geomtraits.h
include/CGAL/internal/AABB_tree/Primitive_helper.h
include/CGAL/internal/AABB_tree/nearest_point_segment_3.h
include/CGAL/internal/AABB_tree/nearest_point_triangle_3.h
@@ -2581,6 +2615,7 @@ include/CGAL/internal/Delaunay_triangulation_hierarchy_3.h
include/CGAL/internal/Dummy_tds_3.h
include/CGAL/internal/Exact_type_selector.h
include/CGAL/internal/Get_dimension_tag.h
+include/CGAL/internal/Has_boolean_tags.h
include/CGAL/internal/Intersections_3/Bbox_3_Bbox_3_do_intersect.h
include/CGAL/internal/Intersections_3/Bbox_3_Line_3_do_intersect.h
include/CGAL/internal/Intersections_3/Bbox_3_Plane_3_do_intersect.h
@@ -2596,9 +2631,14 @@ include/CGAL/internal/Lazy_alpha_nt_2.h
include/CGAL/internal/Lazy_alpha_nt_3.h
include/CGAL/internal/Mesh_3/Boundary_of_subdomain_of_complex_3_in_triangulation_3_to_off.h
include/CGAL/internal/Mesh_3/Graph_manipulations.h
+include/CGAL/internal/Mesh_3/Handle_IO_for_pair_of_int.h
include/CGAL/internal/Mesh_3/check_weights.h
include/CGAL/internal/Mesh_3/get_index.h
-include/CGAL/internal/Mesh_3/split_in_polylines.h
+include/CGAL/internal/Periodic_3_Delaunay_triangulation_filtered_traits_3.h
+include/CGAL/internal/Periodic_3_Delaunay_triangulation_statically_filtered_traits_3.h
+include/CGAL/internal/Periodic_3_triangulation_filtered_traits_3.h
+include/CGAL/internal/Periodic_3_triangulation_remove_traits_3.h
+include/CGAL/internal/Periodic_3_triangulation_statically_filtered_traits_3.h
include/CGAL/internal/Polyhedron_plane_clipping_3.h
include/CGAL/internal/Projection_traits_3.h
include/CGAL/internal/Regular_triangulation_filtered_traits_3.h
@@ -2606,10 +2646,13 @@ include/CGAL/internal/Rich_grid.h
include/CGAL/internal/Static_filters/Angle_3.h
include/CGAL/internal/Static_filters/Compare_squared_radius_3.h
include/CGAL/internal/Static_filters/Compare_weighted_squared_radius_3.h
+include/CGAL/internal/Static_filters/Compare_x_2.h
+include/CGAL/internal/Static_filters/Compare_y_2.h
include/CGAL/internal/Static_filters/Compare_y_at_x_2.h
include/CGAL/internal/Static_filters/Coplanar_orientation_3.h
include/CGAL/internal/Static_filters/Coplanar_side_of_bounded_circle_3.h
include/CGAL/internal/Static_filters/Do_intersect_3.h
+include/CGAL/internal/Static_filters/Equal_2.h
include/CGAL/internal/Static_filters/Equal_3.h
include/CGAL/internal/Static_filters/Is_degenerate_3.h
include/CGAL/internal/Static_filters/Orientation_2.h
@@ -2639,11 +2682,12 @@ include/CGAL/internal/Surface_mesh_segmentation/Surface_mesh_segmentation.h
include/CGAL/internal/Surface_mesh_skeletonization/Curve_skeleton.h
include/CGAL/internal/Surface_mesh_skeletonization/Debug.h
include/CGAL/internal/Surface_mesh_skeletonization/Detect_degeneracy.h
-include/CGAL/internal/Surface_mesh_skeletonization/get_normal.h
include/CGAL/internal/Transform_coordinates_traits_3.h
include/CGAL/internal/Triangulation/Dummy_TDS.h
include/CGAL/internal/Triangulation/Triangulation_ds_iterators.h
include/CGAL/internal/Triangulation/utilities.h
+include/CGAL/internal/Triangulation_2_filtered_projection_traits_3.h
+include/CGAL/internal/Triangulation_2_projection_traits_base_3.h
include/CGAL/internal/Triangulation_ds_circulators_3.h
include/CGAL/internal/Triangulation_ds_iterators_3.h
include/CGAL/internal/Voronoi_covariance_3/voronoi_covariance_3.h
@@ -2652,7 +2696,6 @@ include/CGAL/internal/auxiliary/graph.h
include/CGAL/internal/boost/array_binary_tree.hpp
include/CGAL/internal/boost/mutable_heap.hpp
include/CGAL/internal/boost/mutable_queue.hpp
-include/CGAL/internal/boost/property_map.h
include/CGAL/internal/bounded_priority_queue.h
include/CGAL/internal/container_fwd_fixed.hpp
include/CGAL/internal/corefinement/Combinatorial_map_for_corefinement.h
@@ -2779,7 +2822,6 @@ include/CGAL/predicates_on_lines_2.h
include/CGAL/predicates_on_points_2.h
include/CGAL/predicates_on_points_3.h
include/CGAL/primes.h
-include/CGAL/primes_impl.h
include/CGAL/property_map.h
include/CGAL/radial_orient_normals.h
include/CGAL/random_convex_hull_in_disc_2.h
@@ -2794,6 +2836,7 @@ include/CGAL/rectangular_3_center_2.h
include/CGAL/rectangular_p_center_2.h
include/CGAL/refine_mesh_3.h
include/CGAL/regular_neighbor_coordinates_2.h
+include/CGAL/regularize_planes.h
include/CGAL/remove_far_points_in_mesh_3.h
include/CGAL/remove_outliers.h
include/CGAL/representation_tags.h
@@ -2913,14 +2956,15 @@ lib/CGAL/UseESBTL.cmake
lib/CGAL/UseEigen3.cmake
lib/CGAL/UseOpenMesh.cmake
lib/CGAL/UseTBB.cmake
+lib/CGAL/Use_CGAL_Qt5_headers.cmake
lib/CGAL/test_MPFI.cpp
lib/libCGAL.so
-lib/libCGAL.so.11
-lib/libCGAL.so.11.0.2
+lib/libCGAL.so.12
+lib/libCGAL.so.12.0.0
lib/libCGAL_Core.so
-lib/libCGAL_Core.so.11
-lib/libCGAL_Core.so.11.0.2
+lib/libCGAL_Core.so.12
+lib/libCGAL_Core.so.12.0.0
lib/libCGAL_ImageIO.so
-lib/libCGAL_ImageIO.so.11
-lib/libCGAL_ImageIO.so.11.0.2
+lib/libCGAL_ImageIO.so.12
+lib/libCGAL_ImageIO.so.12.0.0
man/man1/cgal_create_cmake_script.1.gz