aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-09-08 14:30:15 +0800
committerwen <wen@FreeBSD.org>2011-09-08 14:30:15 +0800
commit03293fc97c4a78ef00f8ce9753611191091f91f5 (patch)
treebf6eee292d3d532ba57edc48c8c88514efc6e1ef /math
parent9fcdbdac14ad05625dcfd48009133bdcb691d808 (diff)
downloadfreebsd-ports-gnome-03293fc97c4a78ef00f8ce9753611191091f91f5.tar.gz
freebsd-ports-gnome-03293fc97c4a78ef00f8ce9753611191091f91f5.tar.zst
freebsd-ports-gnome-03293fc97c4a78ef00f8ce9753611191091f91f5.zip
Supports base-2, base-10, base-16, and base-256 numbers.
Uses the GMP or BCMath extensions, if available, and an internal implementation, otherwise. WWW: http://pear.php.net/package/Math_BigInteger/ PR: ports/160211 Submitted by: Piotr Rybicki <meritus@innervision.pl>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/pear-Math_BigInteger/Makefile28
-rw-r--r--math/pear-Math_BigInteger/distinfo2
-rw-r--r--math/pear-Math_BigInteger/pkg-descr5
4 files changed, 36 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 7b08add79293..9bfca9d5a0a7 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -443,6 +443,7 @@
SUBDIR += pari
SUBDIR += parmetis
SUBDIR += parmgridgen
+ SUBDIR += pear-Math_BigInteger
SUBDIR += pear-Math_Combinatorics
SUBDIR += pecl-big_int
SUBDIR += pecl-bitset
diff --git a/math/pear-Math_BigInteger/Makefile b/math/pear-Math_BigInteger/Makefile
new file mode 100644
index 000000000000..002441a2a8a9
--- /dev/null
+++ b/math/pear-Math_BigInteger/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: pear-Math_BigInteger
+# Date created: 26 July 2011
+# Whom: Piotr Rybicki <meritus@innervision.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math_BigInteger
+PORTVERSION= 1.0.0
+CATEGORIES= math pear
+
+MAINTAINER= meritus@innervision.pl
+COMMENT= Pure-PHP arbitrary precission integer arithmetic library
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Math
+FILES= BigInteger.php
+
+USE_PHP= pcre
+
+EXAMPLES= demo/benchmark.php demo/demo.php
+_EXAMPLESDIR=
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/math/pear-Math_BigInteger/distinfo b/math/pear-Math_BigInteger/distinfo
new file mode 100644
index 000000000000..875e6249af35
--- /dev/null
+++ b/math/pear-Math_BigInteger/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PEAR/Math_BigInteger-1.0.0.tgz) = ce37c3c7287bc5734f2545454e29e0152e4e8a3ccfd2ec83cddc7d08aff9c67e
+SIZE (PEAR/Math_BigInteger-1.0.0.tgz) = 26138
diff --git a/math/pear-Math_BigInteger/pkg-descr b/math/pear-Math_BigInteger/pkg-descr
new file mode 100644
index 000000000000..10ac39dc5ac9
--- /dev/null
+++ b/math/pear-Math_BigInteger/pkg-descr
@@ -0,0 +1,5 @@
+Supports base-2, base-10, base-16, and base-256 numbers.
+Uses the GMP or BCMath extensions, if available,
+and an internal implementation, otherwise.
+
+WWW: http://pear.php.net/package/Math_BigInteger/