aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-12-28 06:56:50 +0800
committermarino <marino@FreeBSD.org>2013-12-28 06:56:50 +0800
commit0ade769b5c4cfd8ad11a2468eba93a5f61c51b32 (patch)
tree2fad524a3850a76b505d35ade725c15d20178746 /math
parent2231a8ac7997727bc7681eb1187e654d56b6b603 (diff)
downloadfreebsd-ports-gnome-0ade769b5c4cfd8ad11a2468eba93a5f61c51b32.tar.gz
freebsd-ports-gnome-0ade769b5c4cfd8ad11a2468eba93a5f61c51b32.tar.zst
freebsd-ports-gnome-0ade769b5c4cfd8ad11a2468eba93a5f61c51b32.zip
math/parmetis: Unbreak on FreeBSD 10+
ParMetis requires both cmake and gmake. Apparently gmake sets ${MAKE} to value of "make" if undefined, and this causes the bmake to be launched for subdirectories rather than gmake. That's the cause of the build failure for FreeBSD 10+. The eventual fix using MAKE_ARGS took me hours to figure out, this drove me crazy! Fix covered by portmgr general blanket for ports modernization (bmake).
Diffstat (limited to 'math')
-rw-r--r--math/parmetis/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/math/parmetis/Makefile b/math/parmetis/Makefile
index a4c455cda986..baeb0e6ac833 100644
--- a/math/parmetis/Makefile
+++ b/math/parmetis/Makefile
@@ -10,7 +10,7 @@ MASTER_SITE_SUBDIR= . OLD
DISTNAME= ${PORTNAME:L}-${PORTVERSION}
MAINTAINER= bf@FreeBSD.org
-COMMENT= A package for parallel (mpi) unstructured graph partitioning
+COMMENT= Package for parallel (mpi) unstructured graph partitioning
LICENSE= METIS
LICENSE_NAME= University of Minnesota METIS License
@@ -20,9 +20,9 @@ LICENSE_PERMS= auto-accept
OPTIONS_DEFINE= OPENMPI DOCS
OPENMPI_DESC= Use openmpi instead of mpich2
-USES= cmake
-USE_GMAKE= yes
+USES= cmake gmake
+MAKE_ARGS+= MAKEFLAGS=MAKE=${GMAKE}
PORTDOCS= manual.pdf
PLIST_FILES= include/parmetis/parmetis.h \
lib/parmetis/libmetis.a lib/parmetis/libparmetis.a
@@ -44,12 +44,12 @@ MPICC= ${LOCALBASE}/bin/mpicc
post-patch:
@${REINPLACE_CMD} -e \
's|BUILDDIR =.*|BUILDDIR = build| ; \
- s|make -C|$$(MAKE) -C|' ${WRKSRC}/Makefile
+ s|make -C|${MAKE_CMD} -C|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e \
's|"-O3"|""|' ${WRKSRC}/metis/GKlib/GKlibSystem.cmake
do-configure:
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} \
${MAKEFILE} config prefix="${PREFIX}" cc="${MPICC}"
do-install: