aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-10-08 04:00:53 +0800
committerkrion <krion@FreeBSD.org>2003-10-08 04:00:53 +0800
commit0c2e2d52ff780f9d853f4c2b206eca45c6e636eb (patch)
treeaa4fe609bb3048f3a919d6e815a492fc66cb5e55 /math
parent3572491d8c805222ba838ae216afc5029f480e9a (diff)
downloadfreebsd-ports-gnome-0c2e2d52ff780f9d853f4c2b206eca45c6e636eb.tar.gz
freebsd-ports-gnome-0c2e2d52ff780f9d853f4c2b206eca45c6e636eb.tar.zst
freebsd-ports-gnome-0c2e2d52ff780f9d853f4c2b206eca45c6e636eb.zip
Add py-fpconst 0.6.0, utilities for handling IEEE 754 floating
point special values. PR: 57708 Submitted by: Rui Lopes <rui@ruilopes.com>
Diffstat (limited to 'math')
-rw-r--r--math/Makefile1
-rw-r--r--math/py-fpconst/Makefile19
-rw-r--r--math/py-fpconst/distinfo1
-rw-r--r--math/py-fpconst/pkg-descr6
-rw-r--r--math/py-fpconst/pkg-plist3
5 files changed, 30 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 3ef545b02da0..039cb11c7dff 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -138,6 +138,7 @@
SUBDIR += ploticus
SUBDIR += plplot
SUBDIR += pspp
+ SUBDIR += py-fpconst
SUBDIR += py-gato
SUBDIR += py-gnuplot
SUBDIR += py-gsl
diff --git a/math/py-fpconst/Makefile b/math/py-fpconst/Makefile
new file mode 100644
index 000000000000..a8d6437a815a
--- /dev/null
+++ b/math/py-fpconst/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: py-fpconst
+# Date created: 7 Oct 2003
+# Whom: Rui Lopes <rui@ruilopes.com>
+#
+# $FreeBSD$
+
+PORTNAME= fpconst
+PORTVERSION= 0.6.0
+CATEGORIES= math python
+MASTER_SITES= http://www.analytics.washington.edu/Zope/projects/fpconst/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rui@ruilopes.com
+COMMENT= Utilities for handling IEEE 754 floating point special values
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/math/py-fpconst/distinfo b/math/py-fpconst/distinfo
new file mode 100644
index 000000000000..d18a504602d9
--- /dev/null
+++ b/math/py-fpconst/distinfo
@@ -0,0 +1 @@
+MD5 (fpconst-0.6.0.tar.gz) = 5eaf8e8d1978ca4bbead5b3f163b23a1
diff --git a/math/py-fpconst/pkg-descr b/math/py-fpconst/pkg-descr
new file mode 100644
index 000000000000..162cdf6e2375
--- /dev/null
+++ b/math/py-fpconst/pkg-descr
@@ -0,0 +1,6 @@
+This python module implements constants and functions for working with
+IEEE754 double-precision special values. It provides constants for
+Not-a-Number (NaN), Positive Infinity (Inf), and Negative Infinity (-Inf),
+as well as functions to test for these values.
+
+WWW: http://www.analytics.washington.edu/Zope/projects/fpconst/
diff --git a/math/py-fpconst/pkg-plist b/math/py-fpconst/pkg-plist
new file mode 100644
index 000000000000..180519d5ed0a
--- /dev/null
+++ b/math/py-fpconst/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/fpconst.py
+%%PYTHON_SITELIBDIR%%/fpconst.pyc
+%%PYTHON_SITELIBDIR%%/fpconst.pyo