aboutsummaryrefslogtreecommitdiffstats
path: root/math
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-07-12 16:13:25 +0800
committermaho <maho@FreeBSD.org>2007-07-12 16:13:25 +0800
commit20609b49e9ef3b04e5be45896a1c742075d627c9 (patch)
tree905066b1f300738102a3e261fa2d624bf515d0e5 /math
parenta38f63208fc4513e56113890a39d2920ac2488c2 (diff)
downloadfreebsd-ports-gnome-20609b49e9ef3b04e5be45896a1c742075d627c9.tar.gz
freebsd-ports-gnome-20609b49e9ef3b04e5be45896a1c742075d627c9.tar.zst
freebsd-ports-gnome-20609b49e9ef3b04e5be45896a1c742075d627c9.zip
Now we use USE_FORTRAN=yes to use FORTRAN compiler.
Diffstat (limited to 'math')
-rw-r--r--math/atlas-devel/Makefile5
-rw-r--r--math/atlas/Makefile5
-rw-r--r--math/gotoblas/Makefile5
3 files changed, 3 insertions, 12 deletions
diff --git a/math/atlas-devel/Makefile b/math/atlas-devel/Makefile
index 37a72e6c2517..148e54a8dee3 100644
--- a/math/atlas-devel/Makefile
+++ b/math/atlas-devel/Makefile
@@ -31,10 +31,7 @@ USE_LDCONFIG= yes
NOT_FOR_ARCHS= alpha
#to compile the ATLAS kernel we use gcc3. See ATLAS/INSTALL.txt for details.
-WANT_FORTRAN= yes
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
.if ${OSVERSION} > 700000
BUILD_DEPENDS+= gcc34:${PORTSDIR}/lang/gcc34
CCOMPILER= gcc34
diff --git a/math/atlas/Makefile b/math/atlas/Makefile
index d5cd6969aca0..7fece6e77f00 100644
--- a/math/atlas/Makefile
+++ b/math/atlas/Makefile
@@ -30,10 +30,7 @@ USE_LDCONFIG= yes
.include <bsd.port.pre.mk>
#to compile the ATLAS kernel we use gcc3. See ATLAS/INSTALL.txt for details.
-WANT_FORTRAN= yes
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
.if ${OSVERSION} > 700000
BUILD_DEPENDS+= gcc34:${PORTSDIR}/lang/gcc34
CCOMPILER= gcc34
diff --git a/math/gotoblas/Makefile b/math/gotoblas/Makefile
index ecbf90a4e7bb..350328a5c745 100644
--- a/math/gotoblas/Makefile
+++ b/math/gotoblas/Makefile
@@ -29,10 +29,7 @@ USE_PERL5= yes
.include <bsd.port.pre.mk>
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
.if ${ARCH} == "amd64" || ${ARCH} == "alpha" || ${ARCH} == "sparc64" || ${ARCH} == "ia64"
MAKE_FLAGS+= BINARY64=1